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Molecular Devices equipment, software, reagents, and consumables. This document 
is copyright protected and any reproduction of this document, in whole or any part, 
is strictly prohibited, except as Molecular Devices may authorize in writing.
Software that may be described in this document is furnished under a non-
transferrable license. It is against the law to copy, modify, or distribute the software 
on any medium, except as specifically allowed in the license agreement. 
Furthermore, the license agreement may prohibit the software from being 
disassembled, reverse engineered, or decompiled for any purpose.
Portions of this document may make reference to other manufacturers and/or their 
products, which may contain parts whose names are registered as trademarks and/or 
function as trademarks of their respective owners. Any such usage is intended only to 
designate those manufacturers’ products as supplied by Molecular Devices for 
incorporation into its equipment and does not imply any right and/or license to use 
or permit others to use such manufacturers’ and/or their product names as 
trademarks.
Each product is shipped with documentation stating specifications and other 
technical information. Molecular Devices products are warranted to meet the stated 
specifications. Molecular Devices makes no other warranties or representations 
express or implied, including but not limited to, the fitness of this product for any 
particular purpose and assumes no responsibility or contingent liability, including 
indirect or consequential damages, for any use to which the purchaser may put the 
equipment described herein, or for any adverse circumstances arising therefrom. The 
sole obligation of Molecular Devices and the customer's sole remedy are limited to 
repair or replacement of the product in the event that the product fails to perform as 
warranted.
For research use only. Not for use in diagnostic procedures. 
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Introduction
The MetaXpress® High Content Image Acquisition & Analysis Software is 
divided into two major parts: 

• Acquisition involves configuring settings, acquiring images, and 
storing plate data in a database. For information about image 
acquisition, see the user guide for the ImageXpress® Micro 
Widefield High Content Screening System or the ImageXpress® 
Ultra Confocal High Content Screening System. Both user guides 
are provided on the MetaXpress Software installation media and 
are available in the Molecular Devices knowledge base at 
http://www.moleculardevices.com/support.

• Analysis consists of selecting, measuring, assessing, and 
managing acquired images and plate data.

This guide describes the general analysis workflow:
• Chapter 1: Introduction on page 5
• Chapter 2: Before You Begin Your Analysis on page 9
• Chapter 3: Selecting and Analyzing Plates on page 11
• Chapter 4: Viewing Analysis Results on page 33
• Chapter 5: About Application Modules on page 49
• Chapter 6: Configuring Application Modules on page 55
• Chapter 7: About Custom Modules on page 71
• Chapter 8: Automating and Monitoring an Analysis on page 75
• Chapter 9: Batch Analysis on page 81
• Chapter 10: Managing Plate Data on page 85
5039429 B 5 
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Simplified Menu Structure
An optional simplified menu structure can be installed to reduce the 
number of top-level menus. All the features of the MetaXpress Software 
are available in this reorganized menu structure.
The procedures in this guide describe both the default menu structure 
and the simplified menu structure.
You can use the Menu Map in the Help menu to help you find the 
locations of features in the simplified menu structure.

1. Click Help > Menu Map.
2. In the Menu Map dialog, select to view the Default to 

customized menu map.
3. Click the menu path where the software feature you want is 

found in the default menu structure. 
The simplified menu path appears to the right of the desired 
feature in the menu.

4. Click the menu path in the software window to access the 
desired feature.

For example, if you want to make a duplicate of an image, then use the 
following procedure:

1. Click Help > Menu Map.
2. In the Menu Map dialog, select to view the Default to 

customized menu map.
3. Click Edit > Duplicate. 

The simplified menu path -> Edit: Image: Duplicate Image/Plane 
appears to the right of the Image option in the submenu.

4. In the software window, click Edit > Image > Duplicate 
Image/Plane.
6 5039429 B 
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Obtaining Support
Molecular Devices is a leading worldwide manufacturer and distributor 
of analytical instrumentation, software, and reagents. We are committed 
to the quality of our products and to fully supporting our customers with 
the highest possible level of technical service.
Our support web site, http://www.moleculardevices.com/support, has a 
link to the Knowledge Base with technical notes, software upgrades, 
safety data sheets, and other resources. If you do not find the answers 
you are seeking, follow the links to the Technical Support Service Request 
Form to send an email message to a pool of technical support 
representatives.
You can contact your local representative or contact Molecular Devices 
Technical Support by telephone at 800-635-5577 (U.S. only) or 
+1 408-747-1700. In Europe call +44 (0) 118 944 8000.
Part of effective communication with Molecular Devices is determining 
the channels of support for the 4000 Q TRAP system System, including 
the MetaXpress Software. Molecular Devices provides a wide range of 
support:

• Documentation: Check the guides that are included on the 
installation media and the help that is available within the 
MetaXpress Software. Help for an active dialog can be accessed 
by pressing F1 on your keyboard.

• Online knowledge base: The knowledge base has links to 
technical notes, software upgrades, newsletters, user guides, 
and other resources. Visit the Molecular Devices Support web 
page at http://www.moleculardevices.com/support and follow 
the links to the knowledge base.

• MetaMorph Software forum: This forum has information on 
journal scripts and custom modules, and has links to videos and 
webinars that can help you troubleshoot problems and be more 
productive using the software. Visit the forum at 
metamorph.moleculardevices.com/forum.
5039429 B 7 
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• Technical Support:
Phone: Contact Technical Support at (800)-635-5577 (U.S. only) 
or +1 408-747-1700. In Europe call +44 (0) 118 944 8000.
Online: Visit http://www.moleculardevices.com/support and 
follow the links in the knowledge base to the Technical Support 
Request Form to send an email to a group of experienced 
Technical Support representatives.
Please have the system ID number, system serial number, 
software version number, and the name of the system owner 
available when you call.
 To find your system ID number, in the MetaXpress Software, 

click Help > About MetaXpress. The About dialog displays 
your system ID number.

 The system serial number is located on your instrument.
• Additional support resources include:
 Nikon web-based microscopy course: 

http://www.microscopyu.com 
 The Molecular Probes Handbook: 

http://www.lifetechnologies.com/us/en/home/references/
molecular-probes-the-handbook.html 
This resource offers advice on fluorescent probes and can 
help you determine if there are better stains available for 
your analysis.

 The following sites offer filter information: 
- http://www.chroma.com 
- http://www.semrock.com 
- http://www.omegafilters.com 
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Before You Begin Your Analysis
When preparing to analyze plates, consider the following plate 
characteristics:

• Plate Specifications
How many wells are on the plate?
Plate size is a determining factor in the number of images 
included in the experiment. Experiments containing large 
numbers of images will need more time to be analyzed than ones 
from smaller experiments. These types of factors might influence 
the options and settings that you choose for your analysis.

• Wells
Were images acquired from all wells? 
Your plate might contain images for all wells, but because of the 
requirements of your experiment, you might not want to analyze 
all wells on all plates.

• Sites
How many sites were acquired for each well?
The number of sites acquired for each well can influence how to 
analyze the data and organize your analyzed data for review. 
Unless you are using adaptive acquisition, the number of sites 
value applies to all wells from which you are acquiring data; the 
quantity of data collected is multiplied by the number of sites 
visited in each well. 

• Wavelengths
How many wavelengths and which specific wavelengths were 
acquired?
Similar to sites, the number of wavelengths acquired contributes 
to the amount of data acquired from each well. Some application 
modules require a minimum number of wavelengths to be 
acquired in order to produce meaningful data, while other 
modules will produce good results with only a single wavelength.
5039429 B 9 
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• Images
What is the total number of images acquired on the plate?
The total number of images that you acquire is influenced not 
only by the number of wells that you acquire, but also the 
number of time points, the number of wavelengths for each time 
point, and the number of sites in each well. Therefore, it is 
possible to create very large data sets. Keep in mind that the 
amount of time available to process your data can become an 
important element in designing your experiment.

• Settings
What unique analysis settings do you need to make?
Each available application module can be saved with unique 
settings. After you save your settings for a module, you can 
retrieve and reuse these settings at any time. Saving and reusing 
your settings helps streamline your analysis workflow and 
ensures a high level of consistency and accuracy.

• Expected Results
What are the anticipated results of your experiment?
The results that you expect to obtain from your experiment can 
be one of the best guides in helping to properly design your 
experiment. By “working backward” from your anticipated 
results, you can ensure that you correctly identify all of the steps 
needed to design a successful experiment.

• Data Log Measurement Selections
Which measurements are the most appropriate to select for 
logging?
Most application modules create two different types of logs: 
 Summary log measurements are measurements that apply 

to the entire image and include a number of default 
measurements that apply to every image. 

 Data log measurements are measurements of each 
individual cell in the image that has been identified by the 
software. Data log measurements are also called “cell by cell 
measurements.” 

Some application modules have High Throughput (HT) versions. 
Because of the increased throughput, these modules log only 
summary measurements and not cell-by-cell measurements.
10 5039429 B 
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Selecting and Analyzing Plates
The first step in the image analysis process is to select the plate in the 
database that contains the images that are to be analyzed. You can then 
view and arrange the images in a variety of ways to examine and 
compare them to decide which wells in the plage are appropriate for 
analysis, and how you might need to analyze the wells. For example, you 
can specify the wavelengths to display in the images, combine 
wavelengths into a composite image, and display information such as the 
well number on the images. You can also scale 16-bit images and 
generate an intensity profile to help you determine the areas of the 
image that have the highest intensity. Based on all the information that 
you collect from arranging and viewing the images, you can select the 
appropriate wells for analysis. Finally, after you select the appropriate 
wells in the plate, you analyze the selected wells.

This chapter includes the following topics:
• Selecting a Plate for Analysis on page 12
• Viewing and Arranging Images on page 14
• Selecting Wells for Analysis on page 29
• Running an Analysis on page 30

Note: The settings that you use to select and view images for analysis 
in the Review Plate Data dialog are for display purposes only and 
cannot be saved to a settings file. They do not affect image analysis or 
other measurements and cannot be saved and reused. 

Settings made in application module dialogs (described in Chapter 6: 
Configuring Application Modules on page 55) define characteristics 
specific to the selected application module. These application module 
settings can be saved and reused.
5039429 B 11 
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Selecting a Plate for Analysis

1. Click Screening > Review Plate Data.
In the simplified menu structure, click Screening > Review Plate.

2. In the Review Plate Data dialog, click Select Plate.
3. In the Select Plate for Review dialog, expand the plates folder in 

the top pane to view the sub-folders that contain plates that 
have been saved in the database.

Note: For information about using the Review Plate Data dialog, see 
the video: https://www.youtube.com/watch?v=ks4UKc8vq-A.

Tip: To select the information such as a barcode or plate 
description by which to organize the sub-folders and plates, click 
the Configure Branches button in the upper right corner of the 
dialog.
12 5039429 B 
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4. Double-click a sub-folder in the top pane to display its contents 
in the middle pane.

5. In the middle pane, select a plate, and then click Select.
The Review Plate Data dialog opens. The Run Analysis tab is the 
open tab. The image data for the selected plate is displayed in 
the dialog.

6. Click the Display tab, and then continue to Viewing and 
Arranging Images on page 14.

Tip: After you select a plate, default information about the 
selected plate is displayed in the bottom pane of the Select Plate 
for Review dialog. To add or modify the information that is to be 
displayed for a selected plate, click the Configure Displayed 
Columns button in the upper right corner of the dialog.
5039429 B 13 
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Viewing and Arranging Images

In the Review Plate Data dialog, you use the Plate map and the options 
on the Display tab to view, arrange, and then ultimately select images for 
analysis. Each square in the Plate map represents a single well in plate. 
Markings, color highlighting, or shading are used to indicate the 
following:

• Wells that are marked with a hyphen (-) indicate that the wells 
contain image data.

• Wells that are highlighted in gray indicate wells that are 
displayed in a Montage window.

• Wells that are highlighted in bright green indicate wells that have 
been selected for analysis.

• Wells that are highlighted in dark green indicate wells that are 
included in the Montage window and that have also been 
selected for analysis.

• A well that is outlined in red indicates a well that is being 
displayed in its own individual image window.
14 5039429 B 
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For example:

The Data view drop-down list at the top of the Plate map is useful for 
arranging images according to time points and measurements after you 
have run an analysis on the images. Before analysis, the Plate map is 
arranged in the same order that the wells are arranged in the microwell 
plate (Well arrangement).

1. In the Review Plate Data dialog, in the Wavelengths section, 
select one or more wavelengths to display in the images. 

2. Do any or all of the following on the Display tab as needed to 
assist in the viewing and arranging of images. See:
 Selecting wells for the Montage window/viewing well 

images in a Montage window on page 15.
 Viewing and arranging images for multi-site wells on 

page 17.
 Generating a 3-D intensity profile graph on page 18.
 Assigning colors to acquisition wavelengths on page 18.
 Creating a composite image on page 18.
 Scaling 16-bit color composite images on page 19.
 Auto scaling of images for display on page 19.
 Viewing time point data on page 21.
 Viewing Z series images on page 25.
 Collating the images of multiple wells on page 29.

Selecting wells for the Montage window/viewing well 
images in a Montage window
You can view a thumbnail for each well in a plate in a Montage window 
and compare the overall density and distribution of the sample material 
in each well. Samples showing an overall high density and even 
distribution are typically better candidates for analysis than wells with 
very low sample density and uneven distribution. To select a well or wells 
for displaying in the Montage window, do the any of the following as 
needed:
5039429 B 15 
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• To select a single well in a plate for the Montage window, click 
once on the appropriate square in the Plate map. 

• To select multiple wells in a plate for the Montage window, click 
and hold the left mouse button, and then drag the cursor over 
the appropriate wells in the Plate map.

• To select all the wells in a plate for the Montage window in a 
single step, click in the upper left corner of the Plate map (the 
blank cell between “A” and “01”).
The Montage windows that open are labeled HTS- followed by 
the name of the stain or wavelength that you assigned to the 
wavelength; for example, HTS-DAPI or HTS-FITC. If you are 
viewing a color composite image, then the window is labeled 
HTS-Encoded.

You can open an image in a Montage window in a separate window at full 
resolution. To do so, click the image in the Montage window or right-click 
the appropriate well in the Plate map. For example, the following figure 
shows the image for well D10 in the Montage window. If you click D10 in 
the Montage window, the full resolution image opens in a separate 
window.

Note: The montage dimensions that are displayed in the Montage 
fields determine the total number of sites that are displayed across all 
the wells that have been selected for inclusion in the montage. 
Molecular Devices recommends that you do not manually adjust these 
values. Instead, allow the MetaXpress software to automatically adjust 
these dimensions as you select or de-select wells.
16 5039429 B 
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To display images in the Montage window for a different group of wells, 
do one of the following:

• Click on another well in the Plate map to indicate the top left 
well in the new group.

• Use the left or right arrow beneath the lower right corner of the 
Plate map to move the group of selected wells. 

The group of wells that is selected has the same number of wells (rows 
and columns) as the wells that were originally selected for the montage.
To toggle the display of the well number in the Montage window, select 
Show well information/No overlay display on the Image Overlay drop-
down list. To change the color of the well number in the Montage 
window, select a different color on the Col drop-down list.

Viewing and arranging images for multi-site wells
If images were acquired at multiple sites in the wells in a plate, then a 
Sites section is displayed to the left of the Plate map. The Sites graphic 
indicates the sites for each well for which data was acquired as specified 
on the Sites to Visit tab on the Plate Acquisition Setup dialog. If data was 
not acquired for a specified site, then a blank white pane is displayed for 
site in the graphic. If data was acquired for a site, then a hyphen (-) is 
displayed. For example, in the graphic below, data was acquired for only 
four of the six sites that were visited in each well. 

If images were acquired at multiple sites in a well, then: 
• Click any available site in the Sites section to view only this site 

for all selected wells in the Montage window. 
• Click All Sites to view all sites for all selected wells in the 

Montage window.

Note: If you right-click a well, then the well is not only outlined in red 
but it is also highlighted in green to indicate that is selected for analysis. 
To de-select the well for analysis, right-click it again.
5039429 B 17 
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Generating a 3-D intensity profile graph
To transform the image into a three-dimensional intensity profile graph, 
select Intensity Profile. The MetaXpress Software uses the colors that 
are assigned to the image and displays the highest intensities as the 
highest peaks in the graph.

Assigning colors to acquisition wavelengths
You can assign a color to each acquisition wavelength in your data set. 
How you assign colors depends on whether your images were acquired 
with a single wavelength or with multiple wavelengths.

• For single wavelength images, select an appropriate LUT on the 
image window.

• For multi-wavelength images, select the appropriate wavelength 
on the Source R (red), G (green), or B (blue) drop-down list on 
the Review Plate Data dialog. 

Creating a composite image
To combine images that were acquired with multiple wavelengths into a 
single composite image, select Color Composite. If images were acquired 
with multiple wavelengths, and Color Composite is not selected, then a 
separate Montage window displays the images for each wavelength that 
is selected in the Wavelengths section. Use the Toggle Channel Color 
buttons to turn on and off wavelengths as needed.

Note: If you select All Sites, then the MetaXpress software 
automatically adjusts the Montage dimensions to display all the 
sites in the selected wells in the Montage window.
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Scaling 16-bit color composite images
To manually define a range for scaling 16-bit color composite images, 
clear Auto Scale, and then in the Range field, select the upper range for 
the scaling.

Auto scaling of images for display
Auto Scale automatically adjusts the scaling based on the minimum and 
maximum intensities in an image. By default, when you open an image in 
the MetaXpress Software, Auto Scale is turned on. This is indicated by 
the letter “A” displayed in the Image Scale button on the toolbar of a 
Montage window, or an individual image window. With Auto Scale 
turned on, pixels in the upper 1% of the intensity range are assigned the 
maximum possible intensity (usually 65,535) and pixels in the lower 1% 
of the intensity range are assigned the minimum possible value (0, or 
black), therefore making the image brighter on the display. 

Note: If Color Composite is selected but all colors are set to [None] for 
Source, then no images are displayed for the plate and there will be no 
error messages.

Tip: Although the Color Composite option is helpful for reviewing 
images, it does not produce the best quality images for presentation or 
publication. For better quality images, clear Color Composite, open 
single wavelength full resolution images for the site of interest, and 
then use the Overlay Images function (Display > Overlay Images in the 
default menu or Edit > Display > Overlay Images in the simplified 
menu).

Note: Intensity Profile must be selected for scaling. To automatically 
scale 16-bit color composite images, select Auto Scale.
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When comparing different objects between multiple images, it is not 
helpful to have Auto Scale turned on, as both bright and dim samples 
appear with the same brightness.

If Auto Scale is turned off, only then do the objects or images appear with 
their true intensity levels.
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When comparing the intensity levels of objects across multiple images, 
you should turn off Auto Scale and use the Image Scaling sliders to adjust 
the image display, as shown in the following figure:

• Drag the top Image Scale slider to set the intensity at which 
images are turned brighter (white) or dimmer (black). Moving 
the top slider up turns the image darker. Conversely, moving the 
top slider down turns the image brighter. 

• Drag the bottom Image Scale slider to set the intensity at which 
the background is turned brighter (white) or dimmer (black). 
Moving the bottom slider up turns the background darker 
(black). Conversely, moving the bottom slider down turns the 
background brighter (white).

Viewing time point data
If you have acquired data for time point experiments, then multiple 
options are available for viewing this data. You can:

• View a thumbnail montage of multiple wells at a single time 
point. See To view a thumbnail montage of multiple wells at a 
single time point on page 22.

• View multiple wells at multiple time points. See To view multiple 
wells at multiple time points on page 22.

• View high resolution images from selected wells/time points. 
See To view high resolution images from selected wells/time 
points on page 23.

• View time points for a single site/well as a stack. See To view a 
stack (.stk) file of a series of time points from one site/well on 
page 24.
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To view a thumbnail montage of multiple wells at a single time 
point

1. In the Data view field, select Well arrangement.
2. In the Time points field, select the appropriate time point; for 

example, 3 of 5.
3. Select the wells that are to be displayed in the Montage window. 

See Selecting wells for the Montage window/viewing well 
images in a Montage window on page 15.

The well ID/time point for each selected well is displayed in the 
upper left corner of each thumbnail image in the Montage 
window; for example, A01t3, B01t3, and so on.

To view multiple wells at multiple time points
1. In the Data view field, select Time Point vs Well to change the 

layout of the Plate map. (The time points are displayed in the “X” 
direction and the well IDs are displayed in the “Y” direction.)

Note: You might need to use the scroll bars in the Sites graphic 
to scroll to a site to select it.
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2. Select the wells that are to be displayed in the Montage window, 
which tiles the images at each time point in a filmstrip-like 
format across the montage. See Selecting wells for the Montage 
window/viewing well images in a Montage window on page 15.

The well ID/time point for each selected well is displayed in the 
upper left corner of each thumbnail image in the Montage 
window; for example, A01t3, A01t2, and so on.

To view high resolution images from selected wells/time points
Click on any low resolution thumbnail image in an existing montage to 
open the corresponding high resolution image set. 

Note: You might need to use the scroll bars in the Sites graphic 
to scroll to a site to select it.
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To view a stack (.stk) file of a series of time points from one 
site/well

1. In the Data view field, select Time Point vs Well to change the 
layout of the Plate map. (The time points are displayed in the “X” 
direction and the well IDs are displayed in the “Y” direction.)

2. Do one of the following:
 If only a single site per well was acquired, then right-click a 

single well of interest (for example, C18) in either the Plate 
map or a thumbnail in the Montage window.

 If multiple sites per well were acquired, de-select All Sites, 
select the site of interest, and then right-click a single well of 
interest (for example, C18) in either the Plate map or a 
thumbnail in the Montage window.

3. Click Load Selected Images.
The well ID/time point for each selected well is displayed in the 
upper left corner of each thumbnail image in the Montage 
window; for example, A01t1, A01t2, and so on.

4. After you have created a stack file of a series of time points from 
one site/well, you can use the image slider or the playback 
controls at the top of a stack window to scroll through the 
images in the stack.

Note: If needed, to remove all selected wells from the stack, 
click Clear Selection.
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Viewing Z series images
If you have acquired Z series images for experiments, then multiple 
options are available for viewing this data. You can:

• View a 2D projection image for the Z series. See To view a 2D 
projection image for the Z series.

• View a thumbnail montage of multiple wells at a single Z step. 
See To view a thumbnail montage of multiple wells at a single Z 
step on page 26.

• View multiple Z steps from a single well or multiple wells. See To 
view multiple Z steps from a single well or multiple wells on 
page 26. 

• View a series of Z steps for a single site/well as a stack. See To 
view a stack (.stk) file of a series of Z steps from one site/well on 
page 27.

• View high resolution, single Z step images. See To view high 
resolution, single Z step images on page 28.

To view a 2D projection image for the Z series
1. In the Data view field, select Well arrangement.
2. Select 2D projection.
3. Select the wells that are to be displayed in the Montage window. 

See Selecting wells for the Montage window/viewing well 
images in a Montage window on page 15.
The well ID/2D projection for each selected well—always labeled 
as well ID/z0—is displayed in the upper left corner of each 
thumbnail image in the Montage window, for example, D04z0.
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To view a thumbnail montage of multiple wells at a single Z step
1. In the Data view field, select Well arrangement.
2. In the Z steps field, select the appropriate Z step, for example, 12 

of 16.
3. Select the wells that are to be displayed in the Montage window. 

See Selecting wells for the Montage window/viewing well 
images in a Montage window on page 15.
The well ID/Z step for each selected well is displayed in the upper 
left corner of each thumbnail image in the Montage window, for 
example, A01z12, B01z12, and so on.

To view multiple Z steps from a single well or multiple wells
1. In the Data view field, select Time Point vs Well to change the 

layout of the Plate map. (The time points are displayed in the “X” 
direction and the well IDs are displayed in the “Y” direction.)

2. Do one of the following:
 To select a single well, click and drag your cursor across 

the well’s Z Steps Plate map. You can select a subset of Z 
steps, or the full Z step course.

 To select multiple adjacent wells, click and drag your 
cursor over the appropriate range of wells.

As shown in the figure on the next page, images at each Z step 
are tiled in a filmstrip-like format across the montage. The well 
ID/Z step for each selected well is displayed in the upper left 
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corner of each thumbnail image in the Montage window, for 
example, A01z1, A01z2, and so on.

To view a stack (.stk) file of a series of Z steps from one site/well
1. In the Data view field, select Time Point vs Well to change the 

layout of the Plate map. (The time points are displayed in the “X” 
direction and the well IDs are displayed in the “Y” direction.)

2. Do one of the following:
 If only a single site per well was acquired, then right-click a 

single well of interest (for example, C18) in either the Plate 
map or a thumbnail in the Montage window.

 If multiple sites per well were acquired, de-select All Sites, 
select the site of interest, and then right-click a single well of 
interest (for example, C18) in either the Plate map or a 
thumbnail in the Montage window.

3. Click Load Selected Images.
The well ID/Z step for each selected well is displayed in the upper 
left corner of each thumbnail image in the Montage window, for 
example, A01z3, B01z3, and so on.

Note: If needed, to remove all selected wells from the stack, 
click Clear Selection.
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4. After you have created a stack file of a series of Z steps from one 
site/well, you can use the image slider or the playback controls 
at the top of a stack window to scroll through the images in the 
stack.

To view high resolution, single Z step images 

Click on any low resolution thumbnail image in an existing 
montage to display the corresponding high resolution image set.
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Collating the images of multiple wells
To collate the images of multiple wells into one window that you can 
scroll through and save as a stack (.stk) or as a multi-plane TIF (.tif) file, 
do the following:

1. In the Plate map, select the appropriate wells.
 To select a single well, right-click the well in the Plate map. 

Repeat this step to de-select the well.
 To select multiple wells, click and drag your cursor over the 

appropriate wells in the Plate map. Repeat this step to de-
select the wells.

 To select all the wells in a plate in a single step, click in the 
upper left corner of the Plate map (the blank cell between 
“A” and “01”). To de-select all wells at once, repeat this step. 

2. Click Load Selected Images.
A stack is created for each selected wavelength and displayed in 
an individual Selected (stack) window or, if Color Composite is 
selected, a single stack is created and displayed in a single 
Selected (stack) window. If All Sites is selected, then the stack 
contains the images for all sites in all selected wells.

3. Do any of the following as needed:
 To navigate through the images in the stack, drag the slider 

at the top of the Selected (stack) window. 
 To remove all selections from the stack, click Clear.

Selecting Wells for Analysis
Based on all the information that you collect from arranging and viewing 
the images, you can then select the appropriate wells for analysis. Wells 
that are selected for analysis are highlighted in a bright green. To select 
wells for analysis, do the following:

• To select a single well for analysis, right-click the well in the Plate 
map. Repeat this step to de-select the well for analysis.

• To select multiple wells for analysis, press and hold the Control 
key or the Shift key, click and hold the left mouse button, and 
then drag the cursor over the appropriate wells in the Plate map. 
Repeat this step to de-select the wells for analysis.

• To select all the wells in a plate for analysis in a single step, press 
and hold the Control key or the Shift key, and then click in the 
upper left corner of the Plate map (the blank cell between “A” 
and “01”). To de-select all wells for analysis, repeat this step. 
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The following functions on the Display tab are applicable for these wells: 
Load Selected Images and Navigate Selections. The Run on selection 
function on the Run Analysis tab is also applicable for these wells. 

Running an Analysis
After you select the appropriate wells in the plate, you analyze the 
selected wells. In most circumstances, despite the automated 
capabilities, you should manually run preliminary tests on one or more 
wells, such as both positive and negative controls, to ensure valid results. 
You use the Run Analysis tab to select the application module, custom 
module, or journal to run, and then run the analysis. The first time that 
you run a selected analysis, you must create the appropriate settings file. 
Otherwise, you can select from a list of available settings files.

1. In the Analysis field on the Run Analysis tab of the Review Plate 
Data dialog, select an application module, a custom module, or a 
journal.

2. On the Settings drop-down list, select the appropriate settings 
file.

3. Optionally, to log the measurement data from your analysis into 
the database, select Log into the database.

Note: You must make sure to select a file that has the 
appropriate settings based on the wavelengths that were used 
to acquire the plate. If this is the first time that you are running a 
selected analysis, then you must first create the appropriate 
settings file. See Chapter 6: Configuring Application Modules on 
page 55 and Chapter 7: About Custom Modules on page 71.
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4. If you a running a custom journal, or if the plate contains 
multiple time points, or Z step data, then do any of the following 
as applicable. Otherwise, continue to Step 5.
 If you are running a custom analysis that is derived from a 

journal and you have created a setup journal for it, then click 
Run Setup for Analysis to run the setup journal. 

• If the plate contains multiple time points, then select from the 
Time points options.
 All time points: Analyzes all the acquisition time points.
 Time point range: Analyzes only those acquisition time 

points that fall within in the defined range. To use a single 
time point, type the same value in both fields.

 Selected time point: Analyzes the currently selected time 
point. 

 Stack of all time points: Available when you select a 
timelapse journal that analyzes planes in a stack as separate 
time points.

• If the plate contains Z data, then select the from the Z steps 
options.
 All Z points: Analyzes all the acquisition planes.
 Z step range: Analyzes only those planes that fall within the 

defined range. To use a single time plane, type the same 
value in both fields.

 Selected Z step: Analyzes the currently selected Z step.

 Stack of all Z steps: Available only if the selected analysis is a 
journal.

Note: The setup journal must be in the same folder as the main 
analysis and must be named in the format: 
EXAMPLEJOURNAL_SETUP.JNL.

Note: Well arrangement must be selected for Data view to 
show the currently selected time point in the Time points field. 

Note: Well arrangement must be selected for Data view to 
show the currently selected Z step in the Z steps field. 
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 2D projection: Analyzes only the two-dimensional projection 
image.

5. To analyze the data, select one of the following options:
 Click Run on all wells to run the assay for all sites in all wells 

on the plate.

 Click Run on selection to run the assay on all sites in all 
selected wells. 

 Click Run on displayed site to run the assay for the currently 
selected site. 

6. After the analysis is run, view the results in the Cellular Results 
table, on the Measurements tab, or on the Graph tab. See 
Chapter 4: Viewing Analysis Results on page 33 for more 
information.

Note: You can select this option with or without all wells in the 
Plate map selected for analysis.

Note:  To run an analysis on only certain sites in the selected 
wells, you must use a journal. 

Note: This option requires an opened high resolution single 
image file for each wavelength that is analyzed.
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Viewing Analysis Results
The MetaXpress® Software provides several ways to review your analysis 
results, including image overlays, graphs, and heat maps. 
This chapter includes the following topics:

• Viewing Analysis Results on page 33
• Using the Cellular Results Table on page 36
• Filtering Data Analysis Values on page 38
• Generating a Heat Map for Analysis Results on page 39
• Viewing Image Overlay Information on page 42
• Exporting Selected Data on page 43
• Graphing Analysis Results on page 47

Viewing Analysis Results
After running an analysis, you can click Show Values on the Display tab 
to display the analysis results for each well in the Montage window as 
well as on the Plate map. Values in the Montage window and the Plate 
map are automatically updated based on a selected measurement. If a 
single site is selected for display, then the value that is displayed for a 
well in the Montage window and the value that is displayed for the 
corresponding well in the Plate map are identical. If all sites are selected 
for display, then the individual values are displayed for the sites in each 
well in the Montage window and the average of all the site values is 
displayed for the corresponding well in the Plate map. If the selected 
measurement is a “Cell” measurement, then the values that are 
displayed in the Plate map are the average of all cells that were found in 
the well. 

Note: In addition to the analysis review features of the MetaXpress 
Software discussed in this chapter, you can use the AcuityXpress 
Software for further visualization and investigation of your analysis 
results. Please contact your Molecular Devices representative for more 
information about the AcuityXpress Software. 
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1. On the Display tab of the Review Plate Data dialog, click Show 
Values.

2. Open the Measurements tab, and then do the following:
 On the Analysis drop-down list, select the appropriate 

analysis. 
 On the Measurement drop-down list, select the appropriate 

measurement.

3. By default, analysis data is displayed in Well Arrangement (the 
plate format). Optionally, to change the Data view, select one of 
the following:

Note: Measurements that are preceded by “Cell:” are cell-by 
cell data. To view cell-by cell data for the selected site/well, use 
the Cellular Results table. See Using the Cellular Results Table.

Table 4-1: Data view options for analysis results

Option Description

Time point vs well A matrix view of select measurements 
across all time points. Columns are time 
points and rows are well ID.

Z Step vs well A matrix view of select measurements 
across all Z steps. Columns are Z steps and 
rows are well ID.

Measurement vs well  A matrix view of all measurements for a 
single plane. Columns are measurements 
and rows are well ID.

Note: If you are viewing timelapse data or Z series data, then 
there are special considerations. See Viewing analysis results for 
timelapse experiments or Z step experiments on page 35.
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4. Continue to any of the following as needed for viewing and 
evaluating your data:
 Using the Cellular Results Table on page 36.
 Filtering Data Analysis Values on page 38.
 Generating a Heat Map for Analysis Results on page 39.
 Viewing Image Overlay Information on page 42.
 Exporting Selected Data on page 43.
 Graphing Analysis Results on page 47.

Viewing analysis results for timelapse experiments or Z 
step experiments
If you are viewing analysis results for timelapse experiments, or Z step 
experiments, then make note of the following:

• For timelapse experiments:
 If Well arrangement or Measurement vs well is selected for 

the Data view, then the data that is displayed is for the time 
point that is selected in the Time point fields.

 If a particular time point was not analyzed for the current 
measurement set, then no data is displayed when this time 
point is selected.

 To view the data from all time points (for example, to 
identify trends over time), select Time point vs well for the 
Data view.

• For Z step experiments:
 If Well arrangement or Measurement vs well is selected for 

the Data view, then the data that is displayed is for the Z step 
that is selected in the Z step fields.

 If a particular Z step was not analyzed for the current 
measurement set, then no data is displayed when this Z step 
is selected.

 If the 2D projection was selected for analysis, then select 2D 
projection to view the resulting data. If the analysis was 
performed on the 2D projection, then each of the individual 
Z planes displays the results of the analysis on the projection. 
If the 2D projection was not analyzed, then no data is 
displayed when 2D projection is selected.

 To view the data from all Z steps (for example, to identify 
trends through the Z-stack), select Z Step vs well for the 
Data view. Data from the 2D projection is not available from 
this view.
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Using the Cellular Results Table
The Cellular Results table provides a quick way to correlate individual 
cells in an individual well plate image with data that is obtained from an 
application module. The data that is displayed in the Cellular Results 
table is the same data that is configured with the Configure Data Log 
(Cells) option for the application module that you are using, or with the 
Measure tab for the custom module that you are using. You are not 
required to have a data log open to view the Cellular Results table.

1. In the Plate map, make sure that you have a well selected for 
display in its own individual image window. 

2. If the Cellular Results table has not opened automatically after 
running an application module analysis, then in the Review Plate 
Data dialog on the Display tab, click Cellular Results.

3. Do one or both of the following as needed to review the cellular 
data:
 Select one of the segmented cells in the image to highlight 

the corresponding data for the cell in the Cellular Results 
table.

 Select a row in the Cellular Results table to highlight the 
corresponding cell in the segmented image.

Note: Use Ctrl+Click to select multiple cells from the image. 

Note: Use Ctrl+Click to select multiple cells from the Cellular 
Results table. Use Shift+Click to select a range of cells from the 
table. 
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4. Optionally, to prevent the Cellular Results table from opening 
each time an application module runs, clear Show Cellular 
Results.

Note: This segmentation is absent if Save segmentation 
overlay to database was not selected. See Viewing Image 
Overlay Information on page 42.

Note: If you clear Show Cellular Results, but later want to view 
the Cellular Results table when running an application module, 
click Window > Show Cellular Results. In the simplified menu, 
click Measure > Show Cellular Results.
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Filtering Data Analysis Values
Use the options in the Select Wells Based on Variable Range section to 
highlight wells that fit criteria that you specify for a selected 
measurement.

1. In the Review Plate Data dialog, open the Measurements tab.

2. On the Analysis drop-down list, select the analysis that contains 
the measurements that are to be filtered. 

3. On the Measurement drop-down list, select the measurement 
for which values are to be filtered.

4. In the Display Format field, select the number of decimal places 
that are to be displayed for your data.

5. Make sure that Show Heat Map is not selected.

6. In the Select Wells Based on Variable Range section, specify the 
criteria for automatically selecting wells. 

7. Click Select to highlight the wells that meet the criteria in green 
in the Plate map.

Tip: The Select Wells Based on Variable Range provides a 
means of carrying out a subpopulation analysis by automatically 
selecting wells of interest which you can then use with the Run 
Analysis for Selections option on the Run Analysis tab.

Note: If a heat map is enabled, selected wells on the grid 
cannot be distinguished; however, the selected wells are 
outlined in green on the thumbnail montage.
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8. Do either one or both of the following as needed:
 To clear the selection, click Clear Selection.
 To log the data that is displayed in the Plate map, and if 

applicable, the Cellular Results table, see Exporting Selected 
Data on page 43.

Generating a Heat Map for Analysis Results
Visual representation of a data in a heat map provides a simple way to 
quickly identify general patterns; for example, clusters of similar values. 
By default, the heat map uses a green-red color scheme and distributes 
all of the measurement values on a linear scale. The lowest (“cold”) value 
is green, while the highest (“warm”) value is red. Measurements 
between the low and high ends are displayed with colors that correspond 
to the relative position of the values on the scale. You can distribute the 
data on a linear or logarithmic scale, set low and high thresholds, and 
change the color scheme. 

1. In the Data View field, select Well arrangement, and then on the 
Measurements tab, select Show Heat Map.

Note: If a heat map is enabled, selected wells on the grid cannot be 
distinguished; however, the selected wells are outlined in green on the 
thumbnail montage.
5039429 B 39 



MetaXpress High Content Image Acquisition & Analysis Software Analysis Guide

MX_AnalysisGuide.book  Page 40  Tuesday, September 8, 2015  10:44 AM
2. Click Heat Map.
The Heat Map dialog opens.

3. Optionally, do any or all of the following:
 Select the type of scale that the heat map uses to distribute 

the data.
Table 4-2: Heat Map scale options

Option Description

Linear Distributes the data using the actual measurement 
values. This type of scale is ideal for data that does not 
cover a wide range of values.

Logarithmic Distributes the data on a logarithmic scale, starting with 
.0001 and exponentially increasing the values using a 
base of 10 (.0001, .001, .01, .1, 1, 10, 100, 1,000, 
10,000). 

Note: The logarithmic scale presents a very wide 
range of data on a more manageable scale. The scale is 
particularly useful when you want to analyze values 
that are at the lower end of a wide range of data. 
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 Select the method that the heat map uses to calculate the 
range of data, and then define the range.

 Select a different color scheme for the heat map.
 To select a different color for invalid data in the heat map 

(for example, for wells that were not measured and for 
which data was not collected), click Select, and then in the 
dialog that opens, click a color and then click OK.

4. Click Close to close the Heat Map dialog and update the Heat 
Map display.

Table 4-3: Heat Map data calculation options 

Option Description

Manual If you select Manual, then in the Min and Max fields, type the lowest and 
highest values to include in the range of data. Values at or below the 
minimum (with rounding) are displayed with the “lowest” color and values at 
or above the maximum (with rounding) are displayed with the “highest” 
color. Values between the minimum and maximum are distributed along the 
scale and are displayed with corresponding colors.

Automatic If you select this option, then do one of the following for defining the range 
of data:
• To use the full range of data, select Data Min and Max.
• To have the MetaXpress Software distribute the data evenly below and 

above the mean value by a specific number of standard deviations, 
select Data range (# of SD’s), and then type a number of standard 
deviations. This option calculates the range of data using the following 
formulas:
 Minimum Value = Mean - (# Standard Deviations X Standard 

Deviation)
 Maximum Value = Mean + (# Standard Deviations X Standard 

Deviation) 
For example, if the mean value of the range of data is 50, the standard 
deviation between values in the data is 2, and you type 5 as the # 
standard deviations, then the minimum value is 40 (50 - (5 X 2)) and the 
maximum value is 60 (50 + (5 X 2)). Values at or below the minimum 
(with rounding) are displayed with the “lowest” color and values at or 
above the maximum (with rounding) are displayed with the “highest” 
color. Values between the minimum and maximum are distributed along 
the scale and are displayed with corresponding colors.
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Viewing Image Overlay Information
Two options are available on the Image Overlay drop-down list on the 
Display tab on the Review Plate Data dialog for viewing image overlay 
information: Show well information and Show cell segmentation. 
If Show well information is selected, then the well, site (if multiple site 
data), time point (if timelapse data), and Z plane (if Z series data) are 
displayed as a text overlay on the upper left corner of the image. If the 
plate has been analyzed, then the measurement value based on the 
current measurement set and selected measurement for the displayed 
site is displayed as a text overlay on the lower right corner of the image. 
You select the color of the overlay from the Col drop-down list on the 
Display tab on the Review Plate Data dialog. You can toggle the overlay 
on or off from the source image with the Show/Hide overlay button on 
the side of the image window. If you use File > Save As to save the source 
image, then the overlay is also saved. 
If Show cell segmentation is selected when you are reviewing the data 
for a plate that has been analyzed and for which Save segmentation 
overlay to database was selected, then the overlay is displayed on top of 
the image.

You can toggle the overlay on or off from the source image with the 
Show/Hide overlay button on the side of the image window. If you use 
File > Save As to save the source image, then the overlay is also saved. 

Note: The overlay is saved to the database after automated analysis 
only if you selected Save segmentation overlay to database when 
configuring the summary log for the application module, or Create 
Object Overlay when configuring the Measure tab for a custom 
module. The Save segmentation overlay to database option is not 
available for all application modules.
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Exporting Selected Data
After you display analysis results, you can use the Log Data option that is 
available on the Measurement tab to export the results to an Excel 
spreadsheet in exactly the same format in which the data is displayed in 
the Plate map. You can also export the results to a text file. If the data are 
cell-by-cell results, then you export this data using the Log Data option 
that is available on the Cellular Results table.

See:
• To export data to an Excel spreadsheet.
• To export data to a text (.log) file on page 44.
• To export cell-by-cell data to text (.log) file on page 45.

To export data to an Excel spreadsheet
1. Do one of the following:
 To log a single measurement in plate format, select Well 

Arrangement for Data View.
 To log all data in column format, select Measurement vs 

Well for Data View.

Note: Alternatively, you can use the Export Measurements option on 
the Plate Data Utilities dialog to export selected data of one or more 
measurement sets to a text file. For more information, see Exporting 
Measurements on page 89.
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2. Click Configure Log, and in the Configure Log dialog, configure 
header information (Plate info, Column and row Labels, or 
both).

3. Click Open Log, and then in the Open Data Log dialog, select 
Dynamic Data Exchange.

4. In the Export Log Data dialog box, do the following:
 On the Application drop-down list, select Microsoft Excel.
 Enter any of the following information: Sheet name, Starting 

Row, and Starting Column.
5. Click OK to close the Export Log Data dialog box and link the 

measurement data to the Excel spreadsheet.
6. With the Excel spreadsheet open and connected to the 

MetaXpress Software, click Log Data to export the data that is 
currently displayed in the Plate map to the spreadsheet.

7. Optionally, if Data View is set to Well Arrangement, then to 
export another measurement set to the log file, select the 
appropriate measurement on the Measurements drop-down 
list, and then click Log Data.

8. Optionally, to stop exporting the data to the Excel spreadsheet at 
any time, click Log > Close Data Log (the default menu) or 
Measure > Log > Close Data Log (the simplified menu).

To export data to a text (.log) file
Because Excel has a row limit, you should export data to a text file if you 
are exporting many data points, or if you are exporting cell-by-cell data. 

1. Click Configure Log, and in the Configure Log dialog, configure 
header information (Plate info, Column and row Labels, or 
both).

2. Click Open Log, and then in the Open Data Log dialog, select A 
text file.

Note: Repeat Step 7 as many times as needed to export 
different measurement set data for the same analysis. Every 
time that you click the Log Data button, the newly exported data 
is displayed below the previously exported data. As long as the 
connection between the Excel spreadsheet and the MetaXpress 
Software is maintained, existing data is not overwritten.
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3. In the Open Data Log file dialog, browse to the appropriate 
location for saving the log file, enter a name for the log file, and 
then click Save to close the dialog and create and link the text 
file.

4. Click Log Data to export the data that is currently displayed in 
the Plate map to the text file.

5. Optionally, if Data View is set to Well Arrangement, then to 
export another measurement set to the log file, select the 
appropriate measurement on the Measurements drop-down 
list, and then click Log Data.

6. Optionally, to stop exporting the data to the text file, at any time, 
click Log > Close Data Log (the default menu) or Measure > Log > 
Close Data Log (the simplified menu).

To export cell-by-cell data to text (.log) file
Cell-by-cell data is indicated by the word “Cell” preceding the 
measurement. 

1. Click Cellular Results to open the Cellular Results table.
2. In the Montage window, click the appropriate well.

3. Click Open Log.
4. Click Open Log, and then in the Open Data Log dialog, select A 

text file.

Note: The .log file must remain closed while logging data. If you 
open the file through Windows Explorer, your data is not logged. 

Note: Repeat Step 5 as many times as needed to export 
different measurement set data for the same analysis. Every 
time that you click the Log Data button, the newly exported data 
is displayed below the previously exported data. As long as the 
connection between the log file and the MetaXpress Software is 
maintained, existing data is not overwritten.

Note: Do not click in the Plate map as this simply changes the 
wells that are displayed in the Montage window.
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5. In the Open Data Log file dialog, browse to the appropriate 
location for saving the log file, enter a name for the log file, and 
then click Save to close the dialog and create and link the text 
file.

6. Click Log Data to export the data that is currently displayed in 
the Plate map to the text file.

7. Optionally, if Data View is set to Well Arrangement, then to 
export another measurement set to the log file, select the 
appropriate measurement on the Measurements drop-down 
list, and then click Log Data.

8. Optionally, to stop exporting the data to the text file, at any time, 
click Log > Close Data Log (the default menu) or Measure > Log > 
Close Data Log (the simplified menu).

Note: The .log file must remain closed while logging data. If you 
open the file through Windows Explorer, your data is not logged. 

Note: You can repeat Step 5 as many times as needed to export 
different measurement set data for the same analysis. Every 
time that you click the Log Data button, the newly exported data 
is displayed below the previously exported data. As long as the 
connection between the log file and the MetaXpress Software is 
maintained, any newly exported data will not overwrite any 
existing data.
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Graphing Analysis Results
To configure a graph to display your data, use the following procedure:

1. In the Review Plate Data dialog, open the Graph tab.

2. On the Analysis drop-down list, select the analysis that contains 
the data that is to be graphed.

3. In the Graph view section, select the source location for the 
data.

4. On the Graph type drop-down list, select a graph type. The 
options available for each graph type vary depending on the 
selected Graph view.

5. On the Measurement drop-down list and, if applicable, the 
Measurement2 drop-down list, select the measurement(s) that 
are to be graphed.

6. If you selected Histograms for the Graph type, then do the 
following. Otherwise, go to the next step.
 Select the number of bins to display in the resulting 

histogram in the Number of Bins field. 
 Select Auto Scale to automatically scale the bin(s) based on 

the range of data from the selected measurement.
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7. Click Show Graph to open the graph based on the current 
settings. For example:

8. Optionally, do one or both of the following as needed:
 To configure the graph settings, double-click anywhere on 

the graph or click the Show graph menu arrow on the 
bottom left corner of the graph and select Graph Settings.

 To reset the display parameters for the current graph to the 
default view, click Set Display to Default. 

Note: If the data on the graph is not displayed properly, click 
and drag one of the corners of the graph window to resize it.

Note: Each combination of Graph view and Graph type has its 
own unique graph default.
48 5039429 B 



5

MX_AnalysisGuide.book  Page 49  Tuesday, September 8, 2015  10:44 AM
About Application Modules
Application modules are the foundation of the MetaXpress® Software 
analysis workflow. These modules provide automated image analysis for 
biology-specific applications, interactive image segmentation and data 
results, and options for data recording and management. Some examples 
of application modules include Count Nuclei, Transfluor, Micronuclei, and 
Cell Cycle.
An application module can be run in a variety of ways:

• within the Review Plate Data dialog (see Chapter 6: Configuring 
Application Modules on page 55)

• as a stand-alone analysis using an option on the Screening menu 
(see the application Help)

• as part of a custom module (see Chapter 7: About Custom 
Modules on page 71 for an overview and the application Help for 
details)

• within a custom journal (see the application Help)
• in a queue of automated analyses (see Chapter 9: Batch Analysis 

on page 81)
• automatically in conjunction with the plate acquisition process 

(see Chapter 5: About Application Modules on page 49)
All modules share common conventions and settings. Once you learn 
how to use one application module, you can easily use other application 
modules. For example, each module asks you to provide certain basic 
information about your images, such as the size, shape, and intensity of 
objects to be included in your analysis. Application modules require 
grayscale 16-bit fluorescent images (one for each wavelength that will be 
analyzed); some modules will work with transmitted light images as well. 
Molecular Devices offers numerous application modules. The application 
modules that are available with your version of the software depends on 
the terms of your license. For a list of currently available application 
modules, visit www.moleculardevices.com.
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When choosing an application module, consider what your assay needs 
to measure. Your assay might encompass activation of a receptor, 
apoptosis, and proliferation and so on, but to obtain meaningful 
numerical data from screening, you need to describe a phenotype that 
can be measured by the imaging system. Imaging systems do well at 
determining intensity, area, number of objects, or any combination of 
these measurements. To effectively translate your assay into useful 
measurements, evaluate the requirements of your assay in the simplest 
possible terms. For example, when counting cells, the brightest spots are 
usually of the greatest interest. Of these, only certain sizes and shapes 
might be of interest, since the other shapes might be dead cells or debris 
in the culture. Use the following table to determine which application 
module is best suited for your assay.

Note: You can create your own custom module by combining a variety 
of image processing and segmentation steps in the Custom Module 
Editor. These steps can include the application modules described in 
this manual. For a brief introduction to custom modules, see Chapter 7: 
About Custom Modules on page 71. For detailed information about 
creating custom modules, see the help provided in the Custom Module 
Editor. You can open the Custom Module Editor from the Run Analysis 
tab in the Review Plate Data dialog. 

Table 5-1: Application Modules 

Assay Type Description Recommended 
Application Modules

Protein 
Localization/
Translocation

Typically a measurement of co-
localization. The protein of 
interest is labeled or bound to 
by a labeled antibody and used 
with other probes specific to 
cell types, organelles, or 
cytoskeletal structures. The 
assay determines how much 
area or intensity of the 
protein-of-interest co-localizes 
with another probe.

• Translocation
• Translocation-

Enhanced
• Multi Wavelength 

Translocation
• Nuclear 

Translocation HT
• Custom module

Cell Proliferation Typically a count of the cells or 
nuclei in an image. 

• Count Nuclei
• Multi Wavelength 

Cell Scoring
• Cell Proliferation HT
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Cell 
Viability/Apoptosis

Typically a count of objects 
having specific characteristics. 
The cells are rounded up 
(shape and area), the cells 
label or do not label with a 
specific probe (intensity and 
count), or specific proteins 
localize to a sub cellular 
compartment (intensity and 
count); for example, the 
mitochondria. 

• Live/Dead for a two- 
wavelength assay

• Cell Health for a 
three-color assay, 
such as DAPI, 
Annexin, or 
Propidium Iodide 
(PI)

Receptor 
Internalization and 
other Punctuate 
Staining

Usually measured by a probe 
moving to coated pits or 
vesicles, such as in the 
Transfluor assay for GPCR 
activation. Count and measure 
labeled pits or vesicles, or 
other punctate staining.

• Granularity
• Transfluor
• Transfluor HT 
• Custom module

Angiogenesis Typically an area 
measurement. Either the 
length of tubules is measured 
or the creation of holes in a 
cell monolayer is measured.

• Angiogenesis 

Cell Physiology 
(Calcium/pH)

Almost always involves 
measurements of intensity. 
Typically a probe is used that 
changes its fluorescence 
intensity using one or two 
wavelengths under different 
physiological conditions. 
Two examples of this are Fluo-
3 which increases its 
fluorescence with increasing 
free calcium concentration or 
Fura-2 in which the 
fluorescence with 340 nm 
excitation increases and 380 
nm excitation decreases with 
increasing free calcium 
concentration.

• Cell Scoring
• Multi Wavelength 

Cell Scoring 
• Custom module

Table 5-1: Application Modules (cont’d)

Assay Type Description Recommended 
Application Modules
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Kinase Activity 
Assays

Generally involve measuring 
the phosphorylated epitope of 
the kinase by measuring 
fluorescence intensity. This 
value should be normalized to 
the number of cells expressing 
the kinase – a counting 
measurement. 

• Cell Scoring 
• Multi Wavelength 

Cell Scoring 

Neurite Outgrowth Assesses changes in shape and 
lengths. The outgrowth 
lengths, number of 
outgrowths, branching, and 
other parameters are counted.

• Neurite Outgrowth 
• Custom module

Cell Cycle Typically involves the 
classification and counting of 
cells in specified stages of the 
cell cycle and analyzing the 
distribution of cells within 
these classes in response to 
compounds. 

• Cell Cycle for 
detailed 
classification using 
one to three 
wavelengths — from 
a single nuclear stain 
to combinations 
including optional 
mitosis-specific 
and/or apoptosis-
specific stains. 

• Mitotic Index for a 
simple two-
wavelength 
application with a 
nuclear stain and a 
mitosis-specific stain 
to measure the 
percent of cells that 
are mitotic.

• Monopole Detection 
for specific analysis 
of spindle formation 
and the disruption of 
centrosome 
separation.

Table 5-1: Application Modules (cont’d)

Assay Type Description Recommended 
Application Modules
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Polynucleation and 
Genotoxicity

Typically with micronuclei, 
which are small nuclei 
produced during cell division 
by a lagging chromosome 
fragment or an entire 
chromosome and their 
induction is a highly 
quantitative measurement of 
chromosomal damage. 

• Micronuclei for 
genotoxicity by 
detection of 
micronuclei in 
populations of 
mono-, bi- and multi-
nucleated cells. Can 
also be used for 
detection of yeast 
budding.

• Custom module

Table 5-1: Application Modules (cont’d)

Assay Type Description Recommended 
Application Modules
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Configuring Application Modules
Most application modules share similar configuration steps, such as 
selecting the source image to process, determining the width of an 
object, and providing the intensity above local background value. Once 
you are familiar with these basic steps, you will be able to use any of the 
various application modules.
This chapter includes the following topics:

• Basic Setup Procedure for Application Modules on page 55
• Example: The Transfluor Application Module on page 65
• Cell-by-cell Multiplexing with Application Modules on page 69

Basic Setup Procedure for Application Modules
For best results, calibrate the source images in all application modules in 
microns. You must also make sure that the X and Y calibration for an 
image match, and if more than one image is used as a source image, then 
the images must have identical distance calibrations. Images acquired 
using an ImageXpress® Micro System are calibrated in microns. Images 
that have been imported from another system or that have been 
processed might not be calibrated. 

Note: You can create your own custom module by combining a variety 
of image processing and segmentation steps in the Custom Module 
Editor. These steps can include the application modules described in 
this manual. For detailed information about creating custom modules, 
see the Help provided in the Custom Module Editor. You can open the 
Custom Module Editor from Run Analysis tab in the Review Plate Data 
dialog. 
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Selecting the source image, result images, and algorithm
1. Click Screening > Review Plate Data.

In the simplified menu structure, click Screening > Review Plate.
2. Open the plate and images that you want to analyze as described 

in Chapter 3: Selecting and Analyzing Plates on page 11.
3. In the Review Plate Data dialog, click the Run Analysis tab.
4. From the Analysis drop-down list, select an application module.

5. Click Configure Settings.

Each application module needs at least one source image to 
process. Some modules need more than one source image. 
Examples of source image names in various application modules 
include:
 Count Nuclei: Source image
 Angiogenesis: Source image
 Translocation: Compartment image and Translocation Probe 

image
 Neurite Outgrowth: Neurite image and Nuclear Image

Note: This procedure uses the Count Nuclei application module 
as an example.
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6. Click Source image and select one of the images that you opened 
in Step 1 (do not select images that start with HTS as these are 
thumbnail images).

7. To create a separate result image, select Display result image.
The result images are not saved, but are useful when creating 
journals.

8. Open the image selector for Display result image and if needed 
change it to one of the following:
 Overwrite — (Recommended) Overwrites a selected image 

or creates a new image if one does not exist.
 Add to — Adds a plane to a stack.
 New — Creates a new image every time the assay is run.

9. Click on the image name (typically indicated with [Source]) and 
select the appropriate image name from the field. 

Note: The appropriate type of source images varies depending 
on the application module used. For more information about 
source images, view the application help for the module you are 
using.

Note: There are two ways to view the results of each 
application module: Displaying a result image or using an image 
overlay. Selecting Display result image will open or overwrite 
(see Step 8) a new image depicting what was measured. Using 
an image overlay creates an overlay on the main image. You can 
toggle the image overlay on or off with the Show/Hide overlay 
button on the side of the image window.

Note: To display a result image, Display result image and an 
image must be selected. If Display result image is selected, but 
an image is not selected, then you receive an error if you try to 
run the application module.

Note: Do not select images that start with HTS as these are 
thumbnail images.
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10. For a journal, select Specified and give the image an appropriate 
name, such as Result.

11. If the application module provides an Algorithm option, select 
either Standard or Fast. The algorithm option determines how 
quickly the analysis will be performed. Both algorithms produce 
similar but not exactly identical results. If you select the Fast 
algorithm, then in the Intensity above local background field 
enter approximately half of the value that you calculate in 
Calculating the intensity above background value on page 62.

Determining object widths
Most application modules require that you specify object size 
measurements before processing the image(s). You can measure an 
object using one of the following:

• Region tools Line tool
• Caliper tool
• Show Region Statistics dialog

To measure the width of an object using the Region 
tools Line tool

1. If the Region toolbar is not open, click Regions > Region Tools.
In the simplified menu structure, click Measure > Regions > 
Region Tools.

2. Click the Line tool.
3. Click on one of the edges of the largest object that you want to 

include in your analysis. 
A tooltip appears showing the current X and Y values of the 
pointer, as well as the length.

4. Move the cursor to the opposite edge of the object and note the 
Length value.

Note: The Standard algorithm is the algorithm that was used in 
version 3.1 and earlier of the MetaXpress Software.
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In the following example, the value is 10 pixels (or 12.87 μm). 
This number represents the cell width in pixels. If the image is 
calibrated, then the length is in pixels and calibrated units.

5. Enter or select the value in microns in the Approximate max 
width field of the application module’s Configure Settings 
dialog. The next figure shows the new Approximate max width 
value.

6. To remove the region lines, select Clear Regions on the Regions 
menu or right-click on the region and click Delete Region.

7. Repeat the steps above for the smallest object that is to be 
included in your analysis, and then enter the value in the 
Approximate min width field.
5039429 B 59 



MetaXpress High Content Image Acquisition & Analysis Software Analysis Guide

MX_AnalysisGuide.book  Page 60  Tuesday, September 8, 2015  10:44 AM
To measure the width of an object using the Caliper tool

1. Click Measure > Calipers. 
In the simplified menu structure, click Measure > Distances > 
Calipers.

2. In the Calipers dialog, select the image to measure from the 
Image selector. 
The calipers appear on the selected image, as shown in the 
following figure. 

3. To move the calipers, click the cross-bar so that it appears as a 
blinking line, and then drag the cross-bar to the desired location.

4. Click one of the caliper edge lines so that it appears as a blinking 
line, and then drag the line to the desired distance. The other 
caliper line remains anchored.

5. Double-click the caliper cross-bar so that “nodes” appear at each 
end. With your mouse, drag one of the nodes away from the 
other to the desired distance. 
The size of the line is displayed in the image and in the Caliper 
dialog.

Note: The caliper feature is a drop-in option and might need to be 
loaded into the MetaXpress Software. If the option is not present on the 
Measure > Distance menu (simplified menu) or the Measure menu 
(default menu), please contact your System Administrator or Technical 
Support to have this drop-in loaded.
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6. In the Configure Settings dialog of the application module, in the 
Approximate max width field, type the width of the largest 
object that you want to include your analysis.

7. Repeat Step 3 through Step 5 for the smallest object that you 
want to include in your analysis and type its width in the 
Approximate min width field.

Measuring the area of an object
1. If the Region toolbar is not open, click Regions > Region Tools.

In the simplified menu structure, click Measure > Regions > 
Region Tools.

2. Select the Trace Region tool as shown in the previous figure. 
3. Click and hold the left mouse button to draw a region of interest 

around a typical compartment. Double-click the left mouse 
button to close the region. 

4. Select the region (the region blinks when it is selected) and then 
click Measure > Show Region Statistics.
In the simplified menu structure, click Measure > Regions > 
Show Region Statistics.
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Calculating the intensity above background value
The Intensity above local background field is common for all application 
modules. It specifies a value for the intensity threshold of the object(s) of 
interest compared to the neighboring background gray-level values. This 
setting controls the sensitivity of the object detection and segmentation.

1. If the Region toolbar is not open, click Regions > Region Tools.
In the simplified menu structure, click Measure > Regions > 
Region Tools.

2. Select the Arrow tool as shown in the following figure.

3. Move the arrow cursor over the dimmest part of the dimmest 
object in the image. 
As you move the cursor, the X,Y coordinates and the gray-level 
value of the pixel under the cursor are indicated at the bottom of 
the MetaXpress Software desktop. The X,Y coordinates are in 
parentheses and the gray-level value is to the right of the arrow. 
For example:

4. Note the gray-level value of the object. 
5. Move the cursor just outside the object to the background of the 

image and note the gray-level value of the background.
6. Calculate the difference between the gray-level value of the 

object and the background. For example, using a cell’s gray-level 
value of 366 and a background value of 304, the calculation 
would be: 366 – 304 = 62.

7. The value that you enter in the Intensity above local background 
field depends on whether the application module provides the 
Standard and Fast algorithms. If the application module does not 
provide either algorithm or if you select the Standard algorithm, 
enter a value that is slightly lower than the calculated value. In 
the previous example, a value of approximately 60 is 
appropriate. If you select the Fast algorithm, then in the 
Intensity above local background field enter approximately half 
of the value that you calculated.

8. Proceed to the next procedure without closing the application 
module dialog.
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Testing and saving settings
After the module is configured, you should test the settings, make 
adjustments if needed, and then save the settings.

1. In the application module dialog that you just configured, click 
Test Run.

The application module runs and an overlay image appears on 
the original image. A result image also opens if Display result 
image is selected. A Cellular Results table containing individual 
object data also opens. The following figure shows a sample 
source image with an overlay (left) and a result image with the 
cells individually colored (right).

Tip: You can also consider Linescan as an alternate method for 
intensity measurements. Draw a line across a dim object and its 
local background, and then use the Linescan tool that is 
available from the Measure > Intensities menu (simplified 
menu) or the Measure menu (default menu) to see more exact 
intensity values. See the MetaXpress Software online help for 
more information about this tool.

Note: Configure and save settings before you run an application 
module for the first time. After the settings are saved, they can be 
loaded as needed without further configuration. 

Note: The Preview option, if it is available, shows the 
segmented image using just the selected wavelength. For the 
final test use the Test Run option as it uses all wavelengths. 
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2. Click on a cell in the image to highlight the data in the Cellular 
Results table for that selected cell. Use Ctrl+Click or Shift+Click to 
select more than one row of data. If the table does not open 
when you run an application module, from the Window menu, 
select Show Cellular Results.

3. Compare the result image with the source image to determine if 
all the objects of interest have been detected. If not, lower the 
value in the Intensity above background field and run the 
module again before modifying the Approximate max width and 
Approximate min width fields.

4. Click Configure Summary Log to specify which application 
module data will be recorded.

5. In the Configure Log dialog, select or clear individual settings. 
For more information on the data that can be logged, refer to the 
online help Dialog Box Options topic for the application module 
you are using.

6. Click Configure Data Log to configure the data log if applicable.
7. Click Save Settings.
8. Enter a name and description for the settings in the Save 

Settings dialog and click OK. 
The settings are saved to the database.

9. Click Close.

Note: The image overlay is saved to the database with the 
image after automated analysis only if you select the Save 
Segmentation Overlay to Database option when configuring the 
summary log for the application module. This option is not 
available for the Cell Proliferation HT, Nuclear Translocation HT, 
and Transfluor HT application modules. 

Note: Segmentation overlay takes a significant amount of space 
in the database and Molecular Devices does not recommend to 
save it for large screens.
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Example: The Transfluor Application Module
The procedures in the previous section work with any application 
module. The procedure in this section is specific to the Transfluor 
application module. This section assumes you have purchased the 
Transfluor module with your license for the MetaXpress Software.

1. Select a plate using the Review Plate Data dialog as described in 
the previous procedures.

2. Click on one of the wells to display an image.

3. In the Review Plate Data dialog, click the Run Analysis tab.
4. Select <Transfluor> from the Analysis field.
5. Click Configure Settings.
6. In the Configure Settings for Transfluor dialog, click Pits and 

Vesicle image, and then select the wavelength image 
representing the pits and vesicles.

7. Click on the pits and vesicles image, and then increase the zoom 
by clicking the magnifying glass icon on the image window or by 
pressing Page Up on the keyboard.
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8. Use the Single Line tool of the Region toolbar to measure a 
granule width by following these steps:
 If the Region toolbar is not open, click Regions > Region 

Tools.
In the simplified menu structure, click Measure > Regions > 
Region Tools.

 From the Region Tools toolbar, select the Single Line tool.

.  In the image window, locate a small pit.
 Move the cursor to one edge of the pit and click to anchor 

the line in position. 
 Move the cursor to the other edge of the pit and read the 

length of the line region. 
The following figure shows that, in this example, the length is 3 
pixels or 1.41μm.

 Enter this number in the Approximate min width field in the 
Pits section.

 Repeat Step 8 for a larger pit. Enter that number in the 
Approximate max width field in the Pits section.

9. To determine the Intensity over local background value, select 
the Locator Arrow on the Region toolbar and follow Steps 10 - 
14.

10. Find the dimmest pit.
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11. Position the cursor over the dimmest pit and read the gray-level 
value. 
The gray-level value is the number that is displayed at the middle 
of the bottom of the screen after the right arrow. In the example 
below it is 162.

12. Move the cursor to just outside the pit to measure the 
background. 

13. Calculate the difference between the gray-level value of the pit 
and the background. For example, 2030 - 1029 = 1001. 

14. In the Intensity above local background field, enter or select a 
value that is slightly lower than the calculated value. For this 
example, a value of 800 is appropriate. 

15. Repeat the steps above for vesicles, if applicable (if not, then 
clear the Vesicles check box).

16. Make sure that the Nuclear stain check box is cleared. 
17. Click Test Run to test your settings. 

The pits and vesicles segmentation appears as an overlay on top 
of the image. 

18. Use the Show/Hide Overlay tool on the toolbar to toggle the 
results on or off to make sure all the pits are detected. 

Note: Vesicles are much larger and brighter than pits.
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19. If the pits are not all detected, then lower the Intensity above 
local background value. If this does not produce the result that 
you want, then change the other parameters.

20. Select a negative control image and click Test Run to make sure 
that your settings are correct.

21. If you are using a nuclear stain, then select the Nuclear stain 
check box and repeat the steps above for the nuclei. 

22. Click Test Run.
The Cellular Results table appears, which you can use to 
interactively view individual cellular results. Clicking a cell in the 
image highlights the data for the selected cell in the table. 
Clicking on a row in the table highlights the corresponding cell in 
the image. To select and view more than a single line of data, 
press Ctrl+click; to select non-contiguous cells or lines of data 
can, press Shift+click.

23. Click Configure Summary Log to specify how data should be 
recorded. 
The Configure Log dialog opens.

24. Select or clear individual settings; to display the cellular results 
table after the application module runs, select Save 
Segmentation. For more information, refer to the online help 
Dialog Box Options page for the application module you are 
using.

25. Click Configure Data Log to configure the Data log if needed.
26. Click Save Settings and then close the dialog.
27. In the Review Plate Data dialog, on the Run Analysis tab, select 

the saved setting in the Settings field. 
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28. Select one of the following options:
 Click Run on all wells to run the assay for all positions on the 

plate.
 Click Run on selection to run the assay on all sites in the 

selected wells. To select wells, right-click them in the well 
selection table in the Review Plate Data dialog (selected 
wells are highlighted in green).

 Click Run on displayed site to run the assay for the currently 
selected site. 

29. After the analysis is run, view the results in the Cellular Results 
table, on the Measurements tab, or on the Graph tab. See 
Chapter 4: Viewing Analysis Results on page 33.

Cell-by-cell Multiplexing with Application Modules
One of the advantages of high content screening is the ability to 
multiplex assays by running multiple analyses on the same samples. For 
example, you could run a Cell Scoring assay to measure transfection 
efficiency and a Transfluor assay to measure receptor internalization on 
the same sample. In the MetaXpress Software, these analyses may be 
multiplexed on cell-by-cell data.
Compatible modules include Cell Cycle, Cell Health, Cell Scoring, Count 
Nuclei, Granularity, Mitotic Index, Monopole Detection, Multi 
Wavelength Cell Scoring, Multi Wavelength Translocation, and Transfluor 
assays.

1. Configure each application module. Make sure that the same 
nuclear detection settings and algorithm are selected for each 
module.

2. Run each application module separately for selected wells or for 
all wells.

3. Review the data in either the AcuityXpress Software or in 
another application such as Microsoft Excel.

Note:  To run an analysis on only certain sites in wells, you must 
use a journal. 
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For more information about techniques for multiplexing assays, contact 
Technical Support.

Note: You can also multiplex assays by creating a custom module that 
includes multiple application modules. For detailed information about 
creating custom modules, see the help provided in the Custom Module 
Editor. You can open the Custom Module Editor from the Analysis tab in 
the Review Plate Data dialog.
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About Custom Modules
Not all samples can be meaningfully or accurately assessed with just one 
standard application module. Often, you need to combine an array of 
pre-processing and segmentation methods to effectively analyze sets of 
images. Applications such as protein subcellular patterns or fluorescence 
co-localization of objects are often best performed with a sequence of 
steps. 
For example, you might want to remove noise, invert an image, increase 
intensity levels, extract objects of interest, shrink or remove objects, and 
then measure the objects in images acquired with different channels. A 
custom module makes this type of complex, repetitive task simple to 
perform. You can re-use a saved custom module with your copy of the 
software or you can share a custom module with other researchers for 
use with their data sets.
The Custom Module Editor is a flexible, interactive environment where 
you create and test a template for an image analysis that can be re-used 
on multiple data sets. Choose from galleries of processing options, 
morphology filters, application modules, and segmentation methods to 
construct a sequence of analysis steps. 

After you save the final version of your custom module, the module 
automatically appears in the list of available analyses on the Run 
Analysis tab in the Review Plate Data dialog. 

Note: For detailed information about how to create a custom module, 
see the help provided in the Custom Module Editor. 
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Application modules are enclosed in brackets in the list. Items that are 
not enclosed in brackets can be either custom modules or journals. For 
example, the following list includes two custom modules.

To add a custom module to the database
In the Custom Module Editor, a custom module can be saved as an XML 
file so that it can be provided to other users for use with their copies of 
the MetaXpress Software. To use a custom module that has been 
transferred from another computer, you must add it to the list by 
following these steps:

1. Click Screening > Add Custom Module to Database.
2. Locate and select the custom module XML file and click Open.

The software uses the custom module file name as the setting 
name. If the module already exists in the database, you can add a 
new setting or overwrite an existing setting for the module.

3. Keep the setting name or enter a new setting name for the 
custom module and click Add.

The custom module is appended to the list of analyses on the Run 
Analysis tab.
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To remove a custom module from the list of analyses
To delete a custom module, you must delete all of the settings associated 
with the module by following these steps:

1. Click Screening > Review Plate Data.
In the simplified menu structure, click Screening > Review Plate.

2. On the Run Analysis tab, in the Analysis field, select the custom 
module.

3. Click Edit List.
4. Delete each setting associated with the custom module.
5. After you delete the last setting, click Yes to confirm that you 

want to remove the custom module from the list of analyses.
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Automating and Monitoring an Analysis
After you have tested the analysis settings for a specific application 
module or a custom set of journals and are confident in the results, you 
can use the automated analysis features in the MetaXpress® Software to 
increase your data analysis throughput. 
Automated analyses can be started at one or more analysis workstations 
concurrently with acquisition. You can also automatically run analyses on 
an acquisition system after the acquisition is complete. 

An analysis can run on systems running either the full or offline (analysis 
only) version of the MetaXpress Software. The systems must be 
connected to your database and logged in with privileges to view plates 
and write data. As image data is retrieved from the MDCStore™ database 
storage location that is specified during acquisition, the systems need 
privileges to access this storage location as well. Once the images are 
analyzed, the analysis results are stored back in the MDCStore database. 
Using automated analysis provides several benefits, including the ability 
to dedicate designated workstations for running specific analysis 
application modules. Also, by dedicating a workstation for performing 
acquisitions only, the overhead for the acquisition system is significantly 
reduced.

Note: Automated analysis using application modules and custom 
modules can also be run with the MetaXpress® PowerCore™ Software 
after the acquisition has been completed. Analysis of custom journals 
must be performed using the MetaXpress Software. For more 
information about the MetaXpress PowerCore Software, see the 
product documentation available in the Molecular Devices knowledge 
base at http://www.moleculardevices.com/support.
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Setting up and running an automated analysis involves two main steps:
1. Before starting an acquisition, configure the analysis settings on 

the acquisition workstation using the Post Acquisition tab in the 
Plate Acquisition Setup dialog. 

2. Initiate automated analysis using the Auto Run Mode dialog. 

After the Auto Run Mode has started, you can use the Auto Run Plate 
Statuses dialog to monitor and control the progress of each analysis 
running for each plate being analyzed. 
This chapter includes the following topics:

• Setting Up an Automated Analysis on page 76
• Initiating an Automated Analysis on page 78
• Monitoring the Status of Automated Analyses on page 79

Setting Up an Automated Analysis
To choose a specific analysis to run on a data set after the acquisition is 
complete, select Analyze Images After Acquisition on the Configure tab 
on the Plate Acquisition Setup dialog, and then specify the analysis 
options on the Analysis tab. The data set will be added to the Auto Run 
queue for analysis by a system set to Auto Run mode. You can select from 
a list of saved settings for any application module, custom module, or 
journal assay saved to the database. 

Note: If the analysis that is configured on an acquisition workstation 
calls for an application module to run, the application module drop-in 
must be installed on the computer that is running in Auto Run Mode. 
The application module drop-in must be enabled on the acquisition 
workstation before you can select it here.

Note: If you do not want to automatically run post-acquisition analysis, 
ensure that Analyze Images After Acquisition is not selected on the 
Acquisition tab.

Note: The list of available assays and settings is a subset of the list that 
is on the Run Analysis tab of the Review Plate Data dialog. Analyses 
that do not have settings defined are not shown.
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To select an analysis to automatically run after acquisition:
1. In the Plate Acquisition Setup dialog, on the Acquisition tab, 

select Analyze Images After Acquisition, and then open the 
Analysis tab.

2. In the Analysis field, select the assay (application module, 
custom module, or journal assay) to run after acquisition.

3. On the Setting field, select a settings file. 
A description of the settings file appears below the Settings field.

Note: Only analyses that have defined settings are listed.

Note: You can configure and save settings in the Review Plate 
Data dialog.
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Initiating an Automated Analysis
Using the Auto Run Mode, a networked system can run an analysis on 
plates automatically after they are acquired. After each plate is acquired 
on the main MetaXpress Software system, information regarding analysis 
of the plate is placed in a queue in the database. When other 
MetaXpress Software computers that are connected to the database are 
set in Auto Run Mode, they check the queue and run analyses on plates 
as the data becomes available.
Having separate computers to acquire and analyze your screening data 
greatly reduces the overall screening time by freeing up the main 
MetaXpress Software system to continue acquisition. You can also set up 
more than one MetaXpress Software computer to run in Auto Run Mode, 
further reducing the time it takes to process multiple plates.

To set up and use Auto Run Mode:
1. On the computer that is acquiring images, start the MetaXpress 

Software.
2. Click Screening > Plate Acquisition Setup. 

In the simplified menu structure, click Screening > Acquisition 
Setup.

3. In the Plate Acquisition Setup dialog, on the Acquisition tab, 
select Analyze Images After Acquisition, and then open the 
Analysis tab.

4. In the Analysis field, select the assay (application module, 
custom module, or journal assay) to run after acquisition.

5. Continue to set up and run your acquisition. After the plate is 
acquired, it is added to the Auto Run queue.

6. On the computers running the analysis, start the MetaXpress 
Software.

7. Click Screening > Start Auto Run Mode [DB].

Note: When the MetaXpress Software is in Auto Run Mode, the 
application cannot be used for any other purpose.
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8. In the Auto Run Mode dialog, to run the analysis on more than 
one plate, clear the Leave auto run mode when plate is finished 
check box. If the check box is selected, only one plate is analyzed. 
Select this option if you want to use the system for other tasks 
and do not want the MetaXpress Software to start analyzing the 
next plate once it is finished with the one it is currently 
analyzing. Note that while in Auto Run Mode, all other 
MetaXpress Software options are disabled.

9. After the analysis is completed for all plates, click Cancel to close 
the Auto Run Mode dialog. 
Data from sites analyzed will remain in the database, but the 
plate will be removed from the Auto Run queue.

Monitoring the Status of Automated Analyses
1. On the computer running the analysis, click the Screening > Auto 

Run Plate Statuses [DB].
Alternatively, click Screening > Start Auto Run Mode [DB], and 
then in the Auto Run Mode dialog, click Status.

Note: The Auto Run Plate Statuses dialog also shows any plates 
to be analyzed from the Review Plate Data dialog. However, 
these plates will not be claimed by computers in Auto Run 
Mode.
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The following statuses are possible:
 Running indicates that the analysis is currently running on 

the plate. After the analysis is completed for the plate, the 
plate will be removed from the auto run plate status list.

 Timeout indicates that the analysis has not completed on a 
well or site in the expected time. The maximum time allowed 
for analysis is set in the MDCStoreToolsTM Data Management 
Utility with the Set Auto Run Timeout option. A timeout is 
normally caused by an error on the machine running the 
analysis. To diagnose the cause of the timeout, inspect the 
machine that has timed out for error messages or other 
problems. In some cases the problem can be resolved and 
the analysis can continue. If this happens, the status will 
return to Running. In other cases, the Auto Run must be 
canceled and the analyses run again. Some analyses, 
particularly custom modules or journal analyses, take a long 
time to complete. In this case, increase the timeout value set 
for the Set Auto Run Timeout option to allow enough time to 
run the analysis.

 Pending indicates the analysis has not yet started on the 
plate.

 Acquiring indicates that the plate is currently being acquired. 
Analysis does not happen until after the acquisition is 
complete.

 Error indicates an error in the analysis and that the analysis 
was unable to be completed as a result, for example, analysis 
settings that were defined for different wavelengths than 
those that are available on the plate.

2. To stop running an analysis on a plate, select the plate from the 
table in the Auto Run Plate Statuses dialog, and click Cancel 
Selected Plate.

3. To stop running the analysis on all plates, click Cancel All Plates.
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Batch Analysis
Although the MetaXpress® Software provides features for automating 
analyses in conjunction with image acquisition, you can use the Plate 
Data Utilities dialog to manually initiate an analysis on more than one 
plate at a time. 

1. Click Screening > Plate Data Utilities.
In the simplified menu structure, click Screening > Plate Utilities.

2. In the Plate Data Utilities dialog, click Run Analysis. 
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3. In the Select Plates for Analysis dialog, use the query tools or 
expand a folder so that several plates open in the bottom 
window.

4. Select a plate or use Ctrl+click or Shift+click to select multiple 
plates.

5. Click Select.
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6. In the Run Analysis on Plates dialog, from the Analysis list, select 
the assay to run.

7. From the Settings list, select the appropriate setting.
8. Select a Run method:
 Select Run now on this computer to start the analysis only 

on this computer.
 Select Add to auto run list to add the job to the autorun 

queue to run on other computers that are in autorun mode, 
or to run with the MetaXpress® PowerCoreTM Software.

9. If you selected Run now on this computer, then From the 
Images to open for the analysis list, select the wavelengths to 
use with the selected assay.

Note: If you select Add to auto run list, you must also start the 
Auto Run mode that is available on the Screening menu, or the 
MetaXpress PowerCore Software must be running. The 
MetaXpress PowerCore Software processes application modules 
and custom modules, but it does not process journals. 
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10. If the plate contains multiple time points, then select from the 
Timelapse options:
 All time points analyses all acquisition time points.
 Time point range analyses the time points in the defined 

range. To use a single time point, type the same time point in 
both fields.

 Stack of time points is available when you select a timelapse 
journal that analyzes planes in a stack as separate time 
points from the Analysis list.

11. If the plate contains Z data, then select the from the Z Steps 
options:
 All Z points analyzes all the acquisition planes.
 Z step range analyzes only those planes that fall within the 

defined range.
 Stack of all Z steps is available when the selected analysis is 

a journal.
 2D projection analyzes only the two-dimensional projection 

image.
12. Click OK. 
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Managing Plate Data
Use the Plate Data Utilities dialog to manage images and data acquired 
during plate acquisition:

This chapter includes the following topics:
• Importing Images on page 86
• Exporting Measurements on page 89
• Exporting Images on page 96
• Deleting Plates on page 96
• Deleting Images on page 98
• Deleting Measurements on page 99

For information about the Run Analysis option on the Plate Data Utilities 
dialog, see Chapter 9: Batch Analysis on page 81.

Note: The Delete Measurements, Delete Images, and Delete Plates 
options mark data for deletion but they do not delete the data from the 
database/fileserver. To permanently remove the data from the 
database/fileserver, you must use the MDCStoreToolsTM Data 
Management Utility. For more information, see the MDCStoreToolsTM 
Data Management Utility User Guide. 
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Importing Images
Use the Import Images option to import one or more data sets created 
by other Meta Imaging Series® applications into the configured image 
storage location in the MDCStore database. Only images that have been 
saved with the appropriate file naming conventions and with an 
associated HTD file may be imported. The data will then be accessible 
using either the Plate Data Utilities dialog or the Review Plate Data 
dialog. You can also use this dialog to import a plate of Cellomics DIB files 
into the MDCStore fileserver or database as described in the next 
section.

1. In the Plate Data Utilities dialog, click Import Images. 
2. In the Import Images dialog, click Select Directory.
3. In the Browse for Folder dialog, navigate to the local or network 

folder containing the data set(s) to import, and then click OK. 
The path is displayed next to the Select Directory button and the 
HTD files are displayed in the HTD Files field.

4. Select the data set(s) to import by selecting the check boxes next 
to the HTD files in the HTD Files field.

5. Select a location (either the fileserver, a UNC path location, or 
the database) to import the data sets to from the Move images 
field.

Note: To import third party images or images with varying file name 
conventions into the MDCStore database, use the MDCStoreTM Xchange 
Data Conversion Service that is available as an optional component of 
the MetaXpress Software installation. 

Note: The locations in this list are configured using the 
MDCStoreToolsTM Data Management Utility. 
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6. Click Import. 
The files are imported and are available for review in the Review 
Plate Data dialog.

Importing Cellomics Data
Use the Import Special option to convert sets of Cellomics DIB files into 
data sets in the database that can be accessed using either the Plate 
Data Utilities dialog or the Review Plate Data dialog. The Import Special 
option creates MetaXpress HTD files based on the data in the DIB files 
and converts the images to the TIFF format. It then moves the data into 
your MetaXpress Software screening database or a selected local or 
network folder.

Note: Depending on the number of files being imported, this 
step may take several minutes to complete.

Note: You can also import third party images into the MDCStore 
database using the MDCStoreTM Xchange Data Conversion Service that 
is available as an optional component of the MetaXpress Software 
installation. 

Note: Cellomics DIB files do not include image calibration data. A 
default calibration of 1 μm = 1 pixel will be applied to the imported 
images unless you enter a specific calibration when you import the 
data.
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1. In the Plate Data Utilities dialog, click Import Images, and then 
click Import Special.

2. In the Import Special dialog, click Select Directory. 
3. In the Browse for Folder dialog, navigate to the local or network 

folder containing the Cellomics data to import, and then click 
OK. 
The path is displayed next to the Select Directory button and the 
Cellomics files are displayed in the Data sets field.

4. Select the check box next to the Cellomics file set that you want 
to import.

5. Select a location (either the database or an available network 
folder) to import the Cellomics data to from the Store images in 
drop-down field.
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6. Enter a calibration ratio (μm per pixel) for the x and y values of 
the imported images in the Image calibration section. The 
default calibration is 1 μm = 1 pixel.

7. Click Import. 
The files are imported and will be available for review in the 
Review Plate Data dialog.

Exporting Measurements
The Export Measurements option exports selected data of one or more 
measurement sets to a text file. The Export Measurements wizard 
provides a query builder that helps you select the data to export. For 
example, of all the cell data in a measurement set, you might want to 
export data only from cells with a nuclear intensity greater than some 
threshold. Or, of all the image data, you might want to export data only 
from images where the number of cells is above some threshold.
When using the wizard, keep in mind the following:

• On both the Step 1 page and the Step 2 page of the wizard, the 
pane on the left contains the measurement sets or data types 
that can be queried, and the pane on the right displays the query 
as you build it.

• In the Query pane, multiple measurement set queries are 
combined with an OR by default, causing all selected 
measurement sets to be included.

• In the Query pane, multiple data type queries are combined with 
an AND by default, requiring that all conditions defined be met 
at the same time.

• To change the way queries are combined (known as Boolean 
expressions), in the Query pane, use Ctrl-click or Shift-click to 
select the individual queries for measurement sets or data types, 
and then click the OR or AND button. To undo or separate a 
combination, select the Boolean expression and click Break Up. 

• To remove an expression from the Query pane, select the 
expression and click Remove.

• To save the query for later use, click Save. To load a query that 
was saved earlier, click Load.
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To construct a query
Two methods for constructing a query are available: simple and 
advanced. With either method, on the Step 1 page of the wizard, you 
select or specify the measurement sets to export and then, on the Step 2 
page, you select the type of data to export and filter that data. The main 
difference between the two methods is the way in which you select or 
specify the measurement sets:

• Simple Query - On the Step 1 page, select the measurement sets 
from a list. 

• Advanced Query - On the Step 1 page, specify the attribute 
criteria that identify the measurement sets (for example, 
measurement sets that contain data for plates acquired on a 
certain date). To use this method, you must know some of the 
unique attributes that identify the measurement sets containing 
data that you want to export (for example, the date created, 
creator name, or name, or the plate information contained in 
the measurement set such as date annotated or global ID).

1. Click Screening > Plate Data Utilities.
In the simplified menu structure, click Screening > Plate Utilities.

2. In the Plate Data Utilities dialog, click Export Measurements.
3. Select the type of measurement data that you want to export: 

cell measurements, image measurements, or both and then click 
OK.

4. On the Export Measurements Wizard - Step 1 page, select 
Simple Query and proceed to Step 5 or select Advanced Query 
and proceed to Step 8.

5. To construct a simple query, in the top left pane, double-click 
the measurement set folder that contains the data that you 
want to export.
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The measurement set attributes are displayed in a “tree view” in 
the top left pane and the measurement set is added to the list in 
the lower left pane. For example:

The attributes are displayed for informational purposes only to 
help you identify the measurement sets. As described in Step 11, 
you will select the data types to export on the next page of the 
wizard.

6. In the lower left pane, select the measurement sets containing 
data that you want to export and then click the arrow between 
the panes to add the measurement sets to the Query pane.

Note: To add, remove, or rearrange columns in the lower left 
pane, click the Configure Columns button. In the dialog that 
appears, use Ctrl-click or Shift-click to select columns, and then 
click an arrow between the panes to move the columns.

Tip: To quickly add all measurement sets to the lower left pane, 
double-click the top-level Measurement Set folder in the top 
left pane. Then, in the lower left pane, use Ctrl-click or Shift-click 
to select measurement sets to add to the query.
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7. When all of the measurement sets containing data that you 
want to export are listed in the Query pane, click Next, and 
proceed to Step 11.

8. To construct an advanced query, in the left pane, expand the 
Measurement Sets folder, and then expand a folder containing 
measurement set attributes. For example:

9. Double-click the attribute that you want to use to identify the 
measurement sets for the query and, in the New Query dialog, 
select an operator and type a value to filter the data that will be 
exported.
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For example, to export just those measurement sets that contain 
data for plates acquired on February 20, 2015, expand the Plate 
Info branch, double-click Date Created, select “=” for the 
Operator, and select the date in the Value field:

10. When you have included all of the criteria that identifies the 
measurement sets containing data that you want to export in 
the Query pane, click Next.

11. On the Export Measurements Wizard - Step 2 page, expand the 
Data Types folder, expand a sub-folder, and then double-click 
the type of data that you want to export.

12. Define the criteria for the data that should be exported for the 
data type by selecting an operator and a value.
For example, to export measurements that contain a total nuclei 
count of more than 20, select “>” for the Operator, and type 
“20” in the Value field:

13. Click OK.
The query statement that defines the data that should be 
exported for that data type is added to the Query pane.

14. Continue to add as many data types as needed to the query.
15. Click Finish.
16. Proceed to the next section for instructions on specifying how 

the data will appear in the text file.
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To configure the data for export
After you have used the wizard to configure the query, the Configure 
Data Export dialog appears. Use this dialog to specify how the data will 
appear in the text file and then export the data.

1. In the top left pane of the Configure Data Export dialog, select 
the data type that you want to display in rows in the text file (for 
example, sites, compounds, plates, cells, or wells) and then click 
the arrow to move the data type to the right pane. 

2. In the lower left pane, select the measurement type that you 
want to display in columns for each data type (for example, total 
nuclei, total cell area, average intensity) and then click the arrow 
to move the measurement type to the right pane.

3. To calculate a statistic for the exported data (for example, if you 
are averaging the data for multiple cells or wells), select the 
statistic from the list in the Apply Calculation field. If you do not 
want to include a statistic in the text file, select None. 
The Data Layout View section shows how the data will appear in 
the text file.

4. Click OK.
The Export as text file dialog that appears lists the measurement 
sets that contain the data to be exported. By default, the data 
for each measurement set is saved as a separate text file with a 
system-generated file name. By default, the data for each 
measurement set is saved as a separate text file with a system-
generated file name.

5. To change the name of the system-generated file name, select 
the file name in the list, and then click the Edit File Name button 

.
6. To combine the measurement data for all measurement sets 

into one text file, select Export all measurements to one file and 
type a file name.

Note: To resize the width of the columns, drag the column 
headings or right-click and select Fit Columns. To sort the data in 
a column in ascending or descending order, click once in the 
column heading. To reorder the items in the right panes, click 
the up and down arrows.
94 5039429 B 



Managing Plate Data

MX_AnalysisGuide.book  Page 95  Tuesday, September 8, 2015  10:44 AM
7. To include information in the header of the text file such as the 
plate name, date the measurement set was created, or the plate 

description, click the Configure Columns button . In the 
dialog that appears, use Ctrl-click or Shift-click to select columns, 
and then click an arrow between the panes to move the 
columns.

8. Click OK.
The data is saved in the text file or text files, and the Export 
Measurement Set Summary dialog appears.

9. To create a separate text file that contains the computer name, 
destination folder, number of files, and file names related to the 
export, click Save Summary.

10. Click Close.
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Exporting Images
To export images to a local or networked folder:

1. Click Screening > Plate Data Utilities. 
In the simplified menu structure, click Screening > Plate Utilities.

2. In the Plate Data Utilities dialog, click Export Images to export 
images. 

3. In the upper pane of the Select Plate for Export dialog, expand 
the Plate folder to view folders containing plates saved to the 
database.

4. Double-click a folder to view its name, date created, creator, and 
barcode (if applicable) on the lower pane.

5. Select the plate to export from the lower pane and click Select. 
6. In the Browse for Folder dialog, navigate to the local or 

networked folder to export the images to and click OK. 
The acquired images (TIF), thumbnail images (TIF) and the associated 
experiment plate information file (HTD) are exported.

Deleting Plates
To delete plates from the database you must first delete them using the 
Delete Plates option. After that, use the MDCStoreTools Data 
Management Utility to permanently remove the plates from the 
database or fileserver. If you create an archive or a backup of the images 
with the MDCSToreTools Data Management Utility, then you will be able 
to retrieve the plates with the images, but not the measurements. For 
more information, see the MDCStoreToolsTM Data Management Utility 
User Guide.

Note: You must have the appropriate security privileges to select 
plates for deletion. Deleting plates will delete related images and 
measurements.
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To delete a plate:
1. Click Screening > Plate Data Utilities. 

In the simplified menu structure, click Screening > Plate Utilities.
2. In the Plate Data Utilities dialog, click Delete Plates. 
3. In the upper pane of the Select Plates for Deletion dialog, 

expand the Plate folder to view folders containing plates saved 
to the database.

4. Double-click a folder to view its name, date created, creator, and 
barcode (if applicable) on the lower pane.

5. Use Ctrl+click or Shift+click to select the plates to delete from 
the lower pane, click Select and then click OK.

Note: This step removes the data from the Select Plate for 
Deletion dialog but not from the database/fileserver. To 
permanently remove the data from the database/fileserver, you 
must use the MDCStoreTools Data Management Utility. For 
more information, see the MDCStoreToolsTM Data Management 
Utility User Guide.
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Deleting Images
To delete images from a plate you must first delete them using the 
Delete Images option. After that, use the MDCStoreTools Data 
Management Utility to permanently remove the images from the 
database or fileserver. See the MDCStoreToolsTM Data Management 
Utility User Guide for more information. (The image measurements and 
data will remain in the database.)

To delete images from a plate: 
1. Click Screening > Plate Data Utilities. 

In the simplified menu structure, click Screening > Plate Utilities.
2. In the Plate Data Utilities dialog, click Delete Images.
3. In the upper pane of the Select Plates for Image Deletion dialog, 

expand the Plate folder to view folders containing plates saved 
to the database.

4. Double-click a folder to view its name, date created, creator, and 
barcode (if applicable) on the lower pane.

5. Select the plate containing the images to delete from the lower 
pane and click Select and then click OK.

Note: If you delete only the images from a plate (and not the 
measurements or the plate itself) that has been analyzed and contains 
data, you can still view the data from the plate using the Review Plate 
Data dialog.

Note: This step does not remove the images from the 
database/fileserver. You must use the MDCStoreTools Data 
Management Utility to permanently remove the images from 
the database or fileserver. See the MDCStoreToolsTM Data 
Management Utility User Guide for more information.
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Deleting Measurements
To delete measurements from a plate you must first delete them using 
the Delete Measurements option. After that, use the MDCStoreTools 
Data Management Utility to permanently remove the measurements or 
a selected measurement from the database or fileserver. See the 
MDCStoreToolsTM Data Management Utility User Guide for more 
information. 

1. Click Screening > Plate Data Utilities. 
In the simplified menu structure, click Screening > Plate Utilities.

2. In the Plate Data Utilities dialog, click Delete Measurements.
3. In the upper pane of the Select Plates for Measurement 

Deletion dialog, expand the Plate folder to view folders 
containing plates saved to the database.

4. Double-click a folder to view its name, date created, creator, and 
barcode (if applicable) on the lower pane.

5. Use Ctrl+click or Shift+click to select the plates containing the 
measurements to delete from the lower pane and click Select.

Note: This option deletes all the measurement sets associated 
with a plate. To delete just one measurement set from a plate, 
use the Manage Measurement Set option in the MDCStoreTools 
Data Management Utility. For more information, see the 
MDCStoreToolsTM Data Management Utility User Guide.

Note: This step does not remove the data from the 
database/fileserver. To remove the data from the 
database/fileserver, you must use the MDCStoreTools Data 
Management Utility. For more information, see the 
MDCStoreToolsTM Data Management Utility User Guide.
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