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ScreenWorks System Control Software
General Information

Introduction

ScreenWorks® System Control Software controls Molecular Devices
FLIPR® Tetra High Throughput Cellular Screening System.

The following topics are included in this chapter:
e Computer System Requirements on page 7
e Installing ScreenWorks Software on page 8
e Activating the ScreenWorks Peak Pro License on page 9
e Uninstalling ScreenWorks Software on page 10
e Starting the Software on page 10
e Online vs. Offline on page 11

Computer System Requirements

Supported Operating Systems

*  Windows XP Professional, 32-bit
*  Windows 7, 32-bit and 64-bit
*  Windows 10, 32-bit and 64-bit

For data analysis usage, ScreenWorks Software version 4.2.1 can be
installed on a computer with the following minimum system
specifications.

Hardware

e 3.4 GHz or faster processor

e 2 GB SDRAM or more

e 160 GB or more of available hard disk space
e 1024 x 768 or higher-resolution display

e DVD-CDRW Drive
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Installing ScreenWorks Software

As of version 3.1, the installer automatically uninstalls the old software
version as long as it is same major release (3.1 to 3.2). If you are replacing
ScreenWorks Software version 3.2, with version 4.0 or newer, manually
uninstall the software. See Uninstalling ScreenWorks Software on

page 10.

1

Double-click the ScreenWorks_4_2_1_x.exe ScreenWorks
Software installation file. A Welcome to the ScreenWorks Setup
Wizard dialog is displayed.

Click Next.

In the License Agreement dialog box, select | accept the terms of
the license agreement, and click Next.

In the Online/Offline Mode dialog, designate the default mode
in which you want the software to start.

In Online, ScreenWorks Software automatically looks for a
connected instrument when the software is started.

In Offline, ScreenWorks Software does not automatically
look for a connected instrument.

Refer to Online vs. Offline on page 11 for further details.
Click Next.

In the Destination Folder dialog, the Install ScreenWorks 4.2.1
to field displays the default installation directory. To change the
installation directory, click Change, navigate to the desired
directory, then click OK.

Click Next.

In the Select Program Folder dialog, leave the displayed default
Program Folder settings. Select Anyone who uses this computer
to make ScreenWorks Software available to all users on the
FLIPR® Tetra System host computer, then click Next.

In the Configuring the ScreenWorks installation dialog, if you
want to make any changes, click Back to go to the previous
screen, otherwise click Next to start the installation.

When the installation is complete, the Completing the
installation process dialog appears. Click Finish to exit the
wizard.

11. Restart your computer before using the software update.

v4.2.1
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Activating the ScreenWorks Peak Pro License

vd.2.1

The ScreenWorks® Peak Pro functionality is license-protected. The
software license activation enables the Peak Pro functionality any time
after the trial period expires.

Note: There is a one time 14-day Peak Protrial usage option in the Help
menu. When the trial period expires, the Peak Detection functionality
disappears, and the Help menu trial option is inactive. The rest of the
ScreenWorks Software version 4.2.1 remains functional.

To activate the ScreenWorks Peak Pro software license:

1

2
3.
4.

Start the ScreenWorks Software application.
Click the Help Tab.
Click Software License.

If you have not started the available 14-day Peak Pro trial, the
option to start the 14-day Peak Protrial, or enter the product key
appears. Click Yes.

If the trial has expired, only the option to provide a software
license product key appears.

If you have internet connectivity, type the provided Product Key
in the field and click Activate Online, and then follow the
on-screen instructions.

If you do not have Internet connectivity, click Activate Offline
and follow the on-screen instructions. Activate Off line requires
the following:

Your product key
A separate computer with Internet connectivity
A USB drive for transferring files between the computers.
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Uninstalling ScreenWorks Software

Starting the Software

10

L

Click Start > Control Panel and double-click on Add or Remove
Programs from the Windows Control Panel dialog.

Find ScreenWorks in the list of currently installed programs and
click Remove to initiate the uninstall process.

When prompted to Uninstall ScreenWorks, click Next.

In the Configuring the ScreenWorks installation dialog, click
Next.

When the installation is complete, the Completing the
installation process dialog appears. Click Finish to exit the
wizard.

To start the software under normal conditions, wait for the connected
instrument to complete its start-up sequence, and then double-click the
ScreenWorks icon on your desktop to start the program. To start the
program from the Windows Start menu, click Start > All Programs >
Molecular Devices > ScreenWorks4.2.1

Note: You can start the ScreenWorks Software with or without an
attached instrument. When no instrument is attached you cannot
acquire data. To perform operations that require data you must be able
to open an existing data file.
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Online vs. Offline

vd.2.1

The software has two start-up modes:
Offline (Desktop)
Online (Instrument)

The default start-up mode is determined during software installation in
the Online/Offline dialog.

Once the software is open, you can switch modes by selecting Go Online
or Go Offline from the Instrument menu.

Note: Switching modes once the software is opened does not change
the software startup mode chosen at the time of installation. To change
the default startup mode the ScreenWorks Software must be
reinstalled.

Online (Instrument) Mode

When launched in this mode, ScreenWorks Software checks for
instrument connections. If no connections are sensed, you are notified.
You may then either check the connections and attempt to connect
again, or choose to run the software in Offline mode.

If you create a protocol in Online mode, only the current instrument
settings are allowed. Protocols created in Offline mode with hardware
settings that do not match current hardware settings are flagged. You
must change the hardware settings to match those in the protocol in
order to run it.

When ScreenWorks Software is launched in Online mode and connects
to the instrument, the default installation configuration file is
overwritten using the current instrument settings and plate library
information.

If you are running in Online mode and then switch to Offline mode, the
instrument setup configuration will be the last Online configuration.

Note: To be able to select any configuration to generate protocols, you
must install the software in Offline (desktop) mode.

11
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Offline (Desktop) Mode
When ScreenWorks Software is launched in Offline mode, you are
enabled to configure the following hardware options:
Camera Type
Excitation Wavelengths
Emission Wavelengths
Pipettor (automatically selects matching tip washer type)
Cell suspension
TETRAcycler™ (automatically sets bar code reader status)

Note: Regardless of the start-up mode, pipettor head and tip washer
type must always match. If the TETRAcycler is installed, it is assumed the

bar code reader is also connected.
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ScreenWorks System Control Software
Version 4.2.1 Release Notes

Introduction

The ScreenWorks® System Control Software version 4.2.1 update is a
minor release. The following is a summary of the changes incorporated in
this revision as compared to version 4.2, the last general release of the
ScreenWorks System Control Software.

e |[ssues Addressed in ScreenWorks Software v4.2.1

Issues Addressed in ScreenWorks Software v4.2.1

v4.2.1

High Density Plates Performance Issue

Tracking ID: FB5249

The data review process is slow for a high density plate because when
clicking on a well to review data, the whole plate needs to be scanned
before clicking on a different well.

Resolution:

You can now click on wells to review data during a plate scan and the
scan will begin again.

Impact of fix:
This fix has no impact on data.

Incorrect Recorded Time

Tracking ID: FB4567

If the date changes while the software is recording data, the software
adds 24 hours to the time gap between the recorded time points.

Resolution:

Software has been updated to correctly record the time regardless of
date changes.

Impact of fix:
This fix has no impact on data.
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Maximum Read Limit is Incorrect

Tracking ID: FB4778
The software allows a total of 5,000 reads in a protocol, however due to
resource limitations, only 800 reads can process.

Resolution:
The maximum read limit now matches the resource limit of 800 reads.

Impact of fix:
This fix has no impact on data.
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ScreenWorks System Control Software
Version 4.2 Release Notes

Introduction

The ScreenWorks® System Control Software version 4.2 update is a minor
release. The following is a summary of the changes incorporated in this
revision as compared to version 4.1, the last general release of the
ScreenWorks System Control Software.

e Modified in ScreenWorks Software v4.2
Modified in ScreenWorks Software v4.2

Faster Data Processing

Faster plate data processing, which significantly reduces the processing
time of long runs with high-density plates.

v4.2.1 15
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ScreenWorks System Control Software
Version 4.1 Release Notes

Introduction

The ScreenWorks® System Control Software version 4.1 update is a minor
release. The following is a summary of the changes incorporated in this
revision as compared to version 4.0.1, the last general release of the
ScreenWorks System Control Software.

e New in ScreenWorks Software v4.1

New in ScreenWorks Software v4.1

Windows 10 Operating System Support
Adds software support for Windows 10 (32 and 64 bit) operating system.

v4.2.1 17
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ScreenWorks System Control Software
Version 4.0.1 Release Notes

Introduction

The ScreenWorks® System Control Software version 4.0.1 update is a
minor release. The following is a summary of the changes incorporated in
this revision as compared to version 4.0, the last general release of the
ScreenWorks System Control Software.

e |[ssues Addressed in Version 4.0.1

Issues Addressed in Version 4.0.1

v4.2.1

1536 Pin Tool Protocol Causes Dispense Parameter Error

Tracking ID: FB4917

When running a 1536 Pin Tool protocol, an error message that the
parameter is invalid is displayed.

Resolution:

This is corrected in version 4.0.1.
Impact of fix:

This fix has no impact on data.
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ScreenWorks System Control Software
Version 4.0 Release Notes

Introduction

The ScreenWorks® System Control Software version 4.0 update is a major
release. The following is a summary of the changes incorporated in this
revision as compared to version 3.2, the last general release of the
ScreenWorks System Control Software.

* New in ScreenWorks Software v4.0

* Modifications Made to ScreenWorks Software v4.0
e Issues Addressed in Version 4.0

e Known Issues

New in ScreenWorks Software v4.0

v4.2.1

340 and 385 LED Modules Support

Support for two new ultraviolet spectrum LED modules is available. The
340 Module provides the 335-345 nm spectrum, and the 388 Module
provides the 380-390 nm spectrum.

LED Module Temperature Detection and Reporting

Alert message appears when an LED module high temperature threshold
is exceeded. LED modules high temperature thresholds range between
46 °C to 65 °C depending on module.

Excitation LED Calibration

The 340 Module LED requires a one time excitation calibration. To
facilitate this calibration, the Excitation LED Calibration button has been
added to the Calibration dialog.

Diagnostic Mode in Yellow Plate Signal Test

The Diagnostic button functionality, now visible in the Yellow Plate Signal
Test dialog, is only for Molecular Devices Technical Support diagnostic
services. If you click the button you will be prompted for a User Name
and a User Password.

21
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Modifications Made to ScreenWorks Software v4.0

22

ScreenWorks Peak Pro Software Trial and License

Help > Software License replaces the pop-up dialog so that you can start
a 14-day trial period, or activate the software license product key.
Version 4.0 Software Installs Parallel with Version 3.x
Software on an Analysis PC

Both ScreenWorks Software version 4.0 and ScreenWorks Software
version 3.x. can be installed on a single PC, but only for offline analysis
usage.

Removed ChangedOptics Option from Instrument Menu
Detecting when the lower front door opens and closes, replaces the
Instrument > ChangeOptics requirement.

Open and Close Lower Front Door Process Changed

Opening and closing the lower front door no longer requires a reset of
the instrument when the optical components are changed. When the
lower front door closes, a message appears about updating optics.

Calibration Dialog Changes

A status list box replaces the drop-down list. The status list box includes
Excitation/Emission Wavelength status for Flat-Field Calibration and
LED Calibration, either Done or NotDone.

Yellow Plate Signal Test Dialog Defaults to Flat-Field
Calibration Settings

Formerly, the Yellow Plate Signal Test dialog defaulted to the settings of
whichever protocol was open. The default flat-field calibration settings
offer a better baseline.

Save As Protocol File Version 3.1 and 3.0

Software version 4.0 Data Files and Protocol Files are not backward
compatible. You can specify File > Save As for Data Files Version 3.1 &
3.0 (*.fmd), and Protocol File Version 3.1 & 3.0 (*.fmp) to later open in
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the earlier versions of the software, but software version 3.2 and newer
functionality will be excluded.

Issues Addressed in Version 4.0

vd.2.1

Tetra Automation Returns Incorrect Instrument Status

Tracking ID: FB3207

During an automation operation of Tetra+, the outer door was closed for
the removal of the plate from the instrument to the landing pad. The
status command reported incorrectly that the door was open after a 402
plate handling error. The door was actually closed. Error message was
out of synch with the instrument status.

Resolution:

Refreshing the real-time status more frequently.
Impact of fix:

This fix has no impact on data.

Asks to Overwrite With a New File

Tracking ID: FB3267

In Windows 7, when saving a new protocol by modifying an existing file
name, the new file name would not be recognized.The Save As > Save
message “<File name> already exists. Do you want to replace it?”
appeared. Clicking Yes, did not overwrite the existing file. The newly
named file was saved.

Resolution:

Now recognizes the new file name, and no erroneous prompt to
overwrite the existing file appears.

Impact of fix:
This fix has no impact on data.

Reduction Type List Empty After Peak Pro Trial License
Expiration
Tracking ID: FB3272

When the Peak Pro license expires, none of the Kinetic Reduction
Configuration >Reduction Type values are available, even the existing
default types (average, sum, max, min). They also are missing from
Export File > Statistics and Export File > Group Statistics default values.

23
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Known Issues

24

Resolution:

The default list of Kinetic Reduction Configuration >Reduction Type
values now appear, as do the Export File > Statistics and Export File >
Group Statistics default values.

Impact of fix:
This fix has no impact on data.

Miscalculating the Average Ratio Graph

Tracking ID: FB3273

Average Ratio Graph is incorrect due to a miscalculation. Instead of the
average ratio, the numerators were averaged, and then the
denominators were averaged, and then the ratio between them was
calculated.

Resolution:

The graph calculation is fixed.
Impact of fix:

This fix has no impact on data.

During Long Interval Read Time Settings, Between Read
Commands, Data Acquisition Reads Quicker Than Set

Tracking ID: FB3172

During long interval read time settings, intermittently, data acquisition
reads occur faster than the designated interval time.

Workaround:

Include additional reads to compensate for the incorrect shortened time
intervals between reads.

Auto Print Does not Print Details Graph Without Group
Definition on the Plate

Tracking ID: FB3276

When no group is defined in the plate, the traces in the Details Graph are
missing.

Workaround:
Define a group.
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