
0112-0178 D
March 2017

GenePix® Pro
Microarray Acquisition and Analysis Software

User Guide



This document is provided to customers who have purchased Molecular Devices 
equipment, software, reagents, and consumables to use in the operation of such 
Molecular Devices equipment, software, reagents, and consumables. This document 
is copyright protected and any reproduction of this document, in whole or any part, 
is strictly prohibited, except as Molecular Devices may authorize in writing.
Software that may be described in this document is furnished under a non-
transferrable license. It is against the law to copy, modify, or distribute the software 
on any medium, except as specifically allowed in the license agreement. 
Furthermore, the license agreement may prohibit the software from being 
disassembled, reverse engineered, or decompiled for any purpose.
Portions of this document may make reference to other manufacturers and/or their 
products, which may contain parts whose names are registered as trademarks and/or 
function as trademarks of their respective owners. Any such usage is intended only to 
designate those manufacturers’ products as supplied by Molecular Devices for 
incorporation into its equipment and does not imply any right and/or license to use 
or permit others to use such manufacturers’ and/or their product names as 
trademarks.
Each product is shipped with documentation stating specifications and other 
technical information. Molecular Devices products are warranted to meet the stated 
specifications. Molecular Devices makes no other warranties or representations 
express or implied, including but not limited to, the fitness of this product for any 
particular purpose and assumes no responsibility or contingent liability, including 
indirect or consequential damages, for any use to which the purchaser may put the 
equipment described herein, or for any adverse circumstances arising therefrom. The 
sole obligation of Molecular Devices and the customer's sole remedy are limited to 
repair or replacement of the product in the event that the product fails to perform as 
warranted.
For research use only. Not for use in diagnostic procedures. 

Product manufactured by Molecular Devices, LLC.
1311 Orleans Drive, Sunnyvale, California, United States of America 94089.
Molecular Devices, LLC is ISO 9001 registered.
© 2017 Molecular Devices, LLC.
All rights reserved.

The trademarks mentioned herein are the property of Molecular Devices, LLC or their respective owners. These 
trademarks may not be used in any type of promotion or advertising without the prior written permission of 
Molecular Devices, LLC.

http://www.moleculardevices.com/productpatents


Contents
Preface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
About this User Guide. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

Technical Assistance and Feedback  . . . . . . . . . . . . . . . . . . . . . . . . . 8
Additional Assistance . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

The Help System . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

Chapter 1: Software Features and Principles . . . . . . . . . . . . . . . 11
Software Features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Imaging . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Analysis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Batch Scanning . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Software Principles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Spots, Features, Blocks, Scan Areas, and Arrays . . . . . . . . . . . . . . 13
Array Lists and the Array List Generator  . . . . . . . . . . . . . . . . . . . . 13

Barcodes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Image Display  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

Ratio Image Creation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Ratio Image Biology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Analytic Algorithms. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Feature Intensities . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Background Intensities. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Block Alignment and Background Thresholds . . . . . . . . . . . . . . . . 22
Ratio Quantities  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Quality Factors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

Data Normalization . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Origins of Variability. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Normalization Methods . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Normalization Process . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

File Formats . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

Chapter 2: Tutorial: Image Acquisition & Analysis  . . . . . . . . . . 33
Starting the Software . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

Analysis Only Mode . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
0112-0178 D 3 



GenePix Pro Microarray Acquisition and Analysis Software User Guide
Image Acquisition. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Configuring Laser Settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Performing Preview Scans  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
Creating Scan Areas  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
Performing a Multiple Wavelength Data Scan . . . . . . . . . . . . . . . . 37
Optimizing Scanner Settings. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
Saving Images  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
Configuring Automatic File Names  . . . . . . . . . . . . . . . . . . . . . . . . . 46

Image Analysis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Selecting a Color Mode. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Opening Images. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47
Opening Images in Four-color Mode . . . . . . . . . . . . . . . . . . . . . . . . 48
Registering Images  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
Customizing Ratio Formulation . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
Image Display and Color Control . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
Zooming the Display . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Using the Navigation Window . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Using the Feature Viewer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54
Creating and Using Analysis Arrays . . . . . . . . . . . . . . . . . . . . . . . . . 55
Working with Spots, Features, Blocks, Scan Areas, 
and Arrays  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
Importing Clone Information . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Creating non-circular Feature Indicators. . . . . . . . . . . . . . . . . . . . . 61
Zooming in on Blocks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62
Moving and Resizing Blocks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
Rotating Blocks and Arrays. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
Manually Moving, Resizing, and Fine-tuning Feature Indicators  . 64
Quick Zooms  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Flagging Feature Indicators  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Creating Custom Flags  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
Resetting Flags and Positions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68
Saving the Positions of Blocks and Feature Indicators. . . . . . . . . . 68
Locking Settings. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Customizing Background Subtraction . . . . . . . . . . . . . . . . . . . . . . . 70
Performing the Analysis and Viewing the Results  . . . . . . . . . . . . . 70
Using the Results Spreadsheet. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
Linkage . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73
Web Interactivity. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
4 0112-0178 D 



Contents
Defining Your Own Flagging Criteria . . . . . . . . . . . . . . . . . . . . . . . . 76
Using Flag Features for Complex Quality Control 
Queries  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77
Saving and Exporting Data. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79
Viewing Scatter Plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80
Report Tab and Scripting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82

Special Functions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Using the Measuring Tools  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Viewing Pixel Plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84
Viewing Histograms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85
Performing a Batch Scan . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86
Stopping and Restarting a Batch Scan  . . . . . . . . . . . . . . . . . . . . . . 93
Reviewing the Batch Scan Log File  . . . . . . . . . . . . . . . . . . . . . . . . . 94
Running a Batch Analysis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
Workflow Automation Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
Find  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
Lab Book . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98
Calibrate System. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98

Chapter 3: Software and Protection Key Installation  . . . . . . . 101
Installing the Software . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101

Computer Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101
Running the Installation File  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Connecting the Protection Key  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
Single-User License Protection Keys . . . . . . . . . . . . . . . . . . . . . . . 103
Multi-User Network Protection Keys . . . . . . . . . . . . . . . . . . . . . . 103

Troubleshooting the Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . 105

Glossary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

Index  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111
0112-0178 D 5 



GenePix Pro Microarray Acquisition and Analysis Software User Guide
6 0112-0178 D 



Preface
The GenePix® Pro Microarray Acquisition and Analysis Software User 
Guide contains in-depth conceptual information about the use of the 
GenePix 7 Software for GenePix Microarray Scanners, as well as an 
overall image acquisition and analysis workflow tutorial.
Topics in this section include:

• About this User Guide on page 7
• Technical Assistance and Feedback on page 8
• Additional Assistance on page 8
• The Help System on page 8

About this User Guide
The sections in this guide are structured to provide the information 
needed to understand the overall operation of the Software. This 
includes:

• Software Features and Principles on page 11: The introduction 
explains all the main features and concepts used in the Software. 
If you are new to the software or to microarray scanners and 
image analysis in general, read this section thoroughly.

• Tutorial: Image Acquisition & Analysis on page 33: This workflow 
tutorial walks you through a complete image acquisition and 
analysis cycle, and describes some of the other special functions 
you will use regularly. If you are a new user, we recommend that 
you work through this tutorial with the Software.

• Software and Protection Key Installation on page 101: The 
installation appendix describes how to install the Software and 
the required hardware protection key.

• Glossary on page 107: The glossary provides a reference of terms 
central to the Software and its use.

Note: VERIFICATION: This program is extensively tested before 
distribution. Nevertheless, researchers should independently verify its 
performance using known data.
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Technical Assistance and Feedback
If you need help to resolve a problem, or want to provide feedback about 
this product, contact us at:
1-408-747-1700 or
1-800-635-5577 (North America only) or
+44 118 944 8000 (Europe)
OR
www.moleculardevices.com
Or see our knowledge base at:
http://www.moleculardevices.com/support

Additional Assistance
The scanner and software package includes the following documentation 
and help materials:

• An online help system providing reference and procedural 
information for all software functions. Click the Help button to 
access the online help.

• A printed hardware guide containing comprehensive scanner 
and software installation instructions.

The Help System

Figure 1-1: Help Icon

Use the Help system to access reference and procedural information 
while you are working in the software. 

To access the Help system
• Click the Help button or press F1 at any time to open a Help topic 

specific to the window or dialog box in which you are working.
At the top of the Help window is a toolbar for common tasks, such as 
printing and going back to the previous page. The tabbed pane on the 
left provides several navigational aids to help you find the information 
you need. The main pane on the right is where the Help topics are 
displayed.
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Preface
Figure 1-2: Welcome Screen

Contents
The Contents tab arranges Help topics by subject, just like the Table of 
Contents in a book. Click a book icon to display an overview of the topics 
in that section. Click a topic icon to display a particular topic.

Index
Use the Index tab to search the Help index for a word. Type the word you 
want to look up in the text box and click Display, or click the topic in the 
alphabetical list. The chosen topic is displayed.

Search
Use the Search tab to locate a word, phrase, or set of words. The help 
system uses boolean, wildcard and nested expressions to refine a search. 
With the AND, OR, NOT, and NEAR operators you can precisely define 
your search by creating a relationship between search terms. If no 
operator is specified, AND is used. For example, the query “spacing 
border printing” is equivalent to “spacing AND border AND printing.”
0112-0178 D 9 
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To perform a search
1. Type the words or phrase you want to search for in the text box 

and click List Topics. The topics containing the word or phrase 
are displayed, including a Rank to help you choose the topic you 
want to view first.

2. Select a topic from the list and click Display. The topic you have 
chosen is displayed in the main window.

Favorites
Use the Favorites tab to quickly find frequently used help topics. You can 
store the current help topic in a Favorites list by clicking Add at the 
bottom of the Favorites tab, then return to the topic anytime by 
double-clicking the title on the tab.

Table 1-1: Search Table

To search for Use Example Results

More than one 
term in the same 
topic

AND baseline AND 
correction

Topics that contain both the 
words “baseline” and 
“correction”

Either of two 
terms

OR spectrum OR 
spectra

Topics containing either the 
word “spectrum” or the word 
“spectra” or both

The first term 
without the 
second term

NOT peak NOT table Topics containing the word 
“peak” but not the word 
“table”

Both terms in the 
same topic, close 
together

NEAR samples NEAR 
high

Topics containing the word 
“samples” within eight words 
of the word “high”
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1
Software Features and Principles
This section provides a brief overview of the GenePix® Pro 7 Software. It 
introduces the basic features and techniques of the system.
Topics in this section include:

• Software Features on page 11
• Software Principles on page 13
• Barcodes on page 15
• Image Display on page 16
• Analytic Algorithms on page 18
• Data Normalization on page 27
• File Formats on page 29

Software Features
The GenePix Pro 7 Software is a fully featured array acquisition and first-
pass analysis package, possessing advanced imaging and data 
manipulation capabilities.

Imaging
• Incorporates precise software control of scan conditions and 

scan areas, reducing scan time and image storage requirements
• Allows you to create, analyze, and view data for multiple scan 

areas as necessary, processing information for each area 
individually or for all areas at once

• Scan area spin control lets you quickly browse images, data, and 
scatter plots across multiple scan areas

• Facilitates quick feature block creation and manipulation, 
including group rotation for multiple blocks

• Displays and analyzes up to four wavelength images and three 
ratio images

• Automatically sets PMT gain
• Constructs user-configurable pseudocolor intensity and ratio 

images for the easy visualization of activity levels
0112-0178 D 11 
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• Acquires images from any GenePix scanner and displays a ratio 
image in real time

• Aligns and analyzes images from third-party scanners

Analysis
• Automatically constructs resizable arrays of blocks and feature 

indicators for identifying and analyzing individual features on a 
slide

• Performs batch analyses of an unlimited number of microarray 
images

• Automatically aligns circular, square, or irregular feature 
indicators with features

• Automatically reads a variety of barcode types on array slides
• Automatically associates individual array features with substance 

names and IDs
• Allows multiple flagging of features as measures of individual 

feature quality, by fully general Boolean queries
• Automatically calculates and subtracts background effects with a 

choice of algorithms, such as local, global, negative control, and 
morphological methods

• Includes two instant data viewers, one for instant zoom views 
and primary data previews (the Feature Viewer), and one that 
graphs pixel intensity distributions for individual features and 
includes more advanced data preview (the Pixel Plot)

• Includes measurement tools for detailed analysis of specific 
image regions

• Includes advanced control of data and image normalization
• Is fully integrated with web-based genomics databases
• Presents the extracted data in a spreadsheet for rapid sorting
• Draws Scatter Plots of any extracted data measurements for all 

the features on an array
• Applies user-defined threshold boundary lines to Scatter Plot 

data
• Exports intensity, ratio, and quality control data for analysis with 

advanced informatics systems
• Is fully configurable on a per-user basis in multi-user 

environments
• Automatically logs all experimental procedures and protocols in 

an electronic Lab Book
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Software Features and Principles
• Includes full scripting support in VBScript and JavaScript for all 
acquisition and analysis functions

Batch Scanning
• Scans all selected slides in the GenePix® SL50 Slide Loader, 

without any user intervention
• Includes customizable hardware (scanner) settings and analysis 

settings
• Provides Global file options, including file naming, file saving, 

and workflow options
• Includes a Manual scan mode, enabling the GenePix SL50 Slide 

Loader to operate much like a manual GenePix scanner
• Allows you to stop, restart, and review a scan
• Allows you to check a batch scan log file if problems occur

Software Principles
While the Software has been designed so that a user can acquire and 
analyze images of arrays without having to learn the finer details of 
image processing, understanding the concepts and algorithms used is 
invaluable for interpreting the acquired data.
Although you will use the Software primarily to control your scanner, you 
can also use it as a standalone analysis platform. To do this, you need to 
be able to import array images in TIFF format.

Spots, Features, Blocks, Scan Areas, and Arrays
Within the Software, each individual spot on the array is called a feature, 
and is assigned a circular feature indicator. Feature Indicators are the 
primary unit of analysis in the Software. A collection of feature indicators 
is called a block. There can be several blocks on a single array, depending 
upon the type and configuration of the arrayer used to place the features 
on the slide. Scan areas identify the sections of the image you want the 
software to scan; you can create single or multiple scan areas on each 
array, as required, with each containing single or multiple blocks of 
features.

Array Lists and the Array List Generator
To employ the full power of automated array analysis, you can use the 
Array List Generator to construct a GenePix Array List (GAL) file. 
0112-0178 D 13 
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To open the Array List Generator window
• From the Start menu, select All Programs > Molecular Devices > 

GenePix Pro 7 > Tools > Array List Generator or press Alt+G to 
use the keyboard shortcut from the GenePix Pro Software user 
interface.

The software uses GAL files to construct an array of blocks to match the 
size and positioning of printed features, and to apply substance names to 
the features. It is critical that the identity of the substance in each spot is 
maintained throughout the analysis, so use a GAL file when you have 
files containing substance IDs and names for each spot on the array. 
Substance IDs must be unique identifiers, such as Swiss-Prot and FlyBase 
identifiers, or GI (GenInfo Identifier) numbers.
The Array List Generator is designed to work with arrayers and arrays 
that have the following characteristics:

• The slides and source plates are perpendicular to one another.
• The robotic motions follow a raster pattern (left to right, then 

down, left to right again), both in loading samples from the 
source plate, and when depositing subsequent spots onto slides. 
Movement between slides does not have to follow a raster 
pattern.

• There are no replicate spots, although there can be replicate 
samples in the microplate wells.

• There is one block of spots per pin being used. For example, 
4 pins = 4 blocks of m rows and n columns.

Therefore, you cannot use the Array List Generator to automatically 
create a GAL file in the following cases, although you may always create 
one manually:

• Arrays where the print-head is in the opposite orientation to the 
slide; for example, pin 1,1 dips into well A,12.

• Replicate spots of any nature, either in adjacent spots or in 
separate blocks. However, the user can manually edit the GAL 
file to insert replicates.

• Non-standard robotic movements, such as printing out of 
sequence; for example, returning to previously used wells in the 
source plate.

• Robotics movements that are non-raster (such as top to bottom, 
then over), either in loading sample from the source plate, or in 
the slide spotting pattern.

• More than one block per pin.
• Slides printed on other commercial arrayers that do not conform 

to the aforementioned specification.
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Many commercial arrayers automatically generate GAL files. If your 
arrayer does not have GAL output functionality, please contact your 
arrayer manufacturer directly and request GAL file support. 

To load a GAL file
• Click File > Load Array List.

A standard GAL file contains multiple data columns containing position 
and identity information for each feature: Block, Column, Row, ID, and, 
optionally, Name. The Software can also read GAL files containing 
additional user-defined columns, should you wish to include extra 
annotation information about your features—for example, their status as 
normalization spots.

Barcodes
If a slide has a barcode on it, the Software automatically reads the 
barcode symbols from Preview Scans, Data Scans, and saved images. The 
extracted barcode symbols are reported in the B field in the Status Bar at 
the bottom of the main window, and are exported in the header of the 
Results file. You can also use the barcode symbol as the image file name. 
To do this, select the Barcode option in the Save Images dialog box.
The Software reads several of the most common barcode formats: 
code 39, code 128, code I2of5, and codabar:

If you know the type of barcode that your slides use, you can set the 
barcode detection so that it searches for that type only. This speeds up 
the detection process. 

To set barcode detection by type
• Click Options > Workflow, and then click Barcode Types.

If your scanner has an integrated barcode reader, the Software 
automatically uses that reader to detect the barcode.

Table 1-1: Barcode Formats

Barcode 
type

Numerical 
character

Alpha 
character

Special 
character String length

Code 39 0–9 A–Z, space –  $  %  +  / no limit

Code 128 All ASCII characters no limit

Code I2of5 0–9 N/A N/A no limit (even)

Codabar 0–9 N/A - : . $ / + no limit
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Image Display
Most GenePix scanners operate using sequential scanning: that is, the 
slide is scanned first using one color laser, and then another, and so on. 
The images at each wavelength are displayed as they are acquired in real 
time; a ratio image appears as each subsequent wavelength image is 
superimposed on the first. 
The GenePix 4000B scanner is an exception. It uses simultaneous laser 
scanning systems to acquire and display two wavelength channels as 
ratio images in real time.

Ratio Image Creation
In the Software, each raw wavelength image, such as the green 532 nm 
image or the red 635 nm image, is collected at 16-bit resolution. Ratio 
images are standard 24-bit composite RGB (Red-Green-Blue) images. 
When the Software is set to the default red–green display scheme in 
two-color mode, with the default ratio formulation, the image from the 
532 nm laser is placed in the green channel, and the image from the 
635 nm laser is placed in the red channel. The blue channel is set to 0. So 
each color channel of the RGB images is composed only of an 8-bit 
image. This means that the ratio image is not, strictly, an image of the 
ratio data.
For display purposes only, each of the individual wavelength images must 
be reduced to 8 bits in order to be displayed as a 24-bit composite RGB 
overlay image. There are two options to reduce each raw wavelength 
image to 8 bits: 

• Compress 16 bits into 8 bits
• Selectively use only 8 of the 16 bits

To compress the 16 bits into 8 bits, the Software uses a square root 
transform, whereby the square root of the image intensity is computed 
and displayed, which effectively reduces 16 bits to 8 bits ({216} = 28).
Alternatively, to strip out 8 of the 16 bits, you can configure the software 
to keep only the bottom, middle, or top eight bits. The effect of each of 
these options on the range of the intensities that is used to display the 
ratio image is summarized in the following table:
Table 1-2: Bit compression 

Method of ratio processing Range of image intensity used

Square Root Transform 0–65535

Preserve High Intensities 256–65535
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What happens if you have selected a ratio processing method and you 
have pixels that are outside the range of acceptable intensities? The ratio 
processing method affects only the display of the ratio; it does not have 
any effect on the display of the raw wavelength images, nor does it affect 
the computation of the ratio data displayed in the Results tab. For 
example, if you have a pixel that has a green value of 15000 and a red 
value of 30000, and the ratio that you are computing is based on red 
divided by green, the ratio value would be 2 (30000 / 15000). If you are 
using the Square Root Transform method, you can display all pixels from 
0 to 65535. In this scenario, the pixel in question is red, as the red 
channel is contributing twice the intensity to the RGB image as the green 
channel.
However, when you select Preserve Low Intensities, the maximum pixel 
value is 255. In this case, both the green and red pixels contribute the 
same intensity to the RGB image, because each image is effectively 
treated as 255. This is because both images exceed an intensity of 255, 
and are clipped at a value of 255. The result is a ratio displayed that is 
yellow, corresponding to a ratio of 1 (255 / 255).
Although the Software can analyze four individual wavelength channels, 
a ratio image can be created from only two at a time. You can specify up 
to three independent pairs of channels to display as ratio images.

Ratio Image Biology
The ratio image typically represents the comparison of test to reference 
sample that is bound to the spotted, or arrayed, substance. If the 
reference sample is labeled with Cy3 (excited by a green laser light such 
as 532 nm), and the test sample is labeled with Cy5 (excited by a red laser 
light such as 635 nm), then both of these samples are mixed with and 
bind to the spotted substances on the slide. In the derived ratio image, a 
red spot indicates that the test sample for this feature is more abundant 
than the reference sample; a green spot indicates that the test sample 
has a lower activity than the reference sample; a yellow spot means that 
there is no change in the activity level between the two populations of 
test and reference sample.

Preserve Middle Intensities 16–4095

Preserve Low Intensities 0–255

Table 1-2: Bit compression (cont’d)

Method of ratio processing Range of image intensity used
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Analytic Algorithms
To quantify changes in activity or abundance accurately, you must extract 
the intensity of a given feature from an image, and refine this data before 
a final ratio value is computed. Several other parameters are measured 
to evaluate the quality of the data for a given feature.

Feature Intensities
For each raw image, the mean, median, and standard deviation of the 
pixel intensities in each feature indicator are computed. The pixels used 
to compute the standard deviation include only those located completely 
inside the feature indicator. Any pixel that overlaps the feature indicator 
boundary is excluded.

Background Intensities
The fluorescent intensity measured inside a feature usually includes a 
certain amount of stray fluorescence from various sources:

• Auto-fluorescence of the slide
• Non-specific binding of test and reference sample

The software must subtract this stray fluorescence, known as 
background, from the measured feature intensity to produce a true 
measure of the feature’s fluorescence. The following types of 
background subtraction are available:

• Local methods
• Global methods
• Negative controls
• Morphological methods

The local median intensity is the default background subtraction method. 
Local methods, where the background value for a feature is calculated 
from a region near the feature, have the advantage that they track 
background variation across a slide. However, they can be unrealistically 
high or low if there are local defects near a feature, and thus may not be 
representative of the background contribution inside a feature. For 
example, when due to non-specific binding, background fluorescence 
may be overestimated, which may, in turn, lead to negative intensities 
with low intensity signals.
Global background methods, where a single background value is 
calculated for each wavelength, have the advantage of providing a 
uniform background estimation for a whole slide, particularly when 
features are so close together that local methods cannot be applied. 
However, where the background varies significantly across a slide, one 
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single estimate may not accurately represent the background 
contribution to all features.
Negative control methods, where the background for a feature is 
estimated from the intensity of a nearby feature, have a number of 
advantages over local and global methods—most notably allowing you to 
more accurately measure low-intensity features. Negative controls are 
features that are known not to be reactive, so that they can relied upon 
always to give the same intensity values independent of the experiment. 
If background is due to non-specific binding, then it is plausible that 
non-specific binding is lower where features have been printed on a 
slide, compared to the space between features. Thus it makes sense to 
estimate non-specific fluorescent background from negative control 
features, rather than from local regions between features. Also, if 
implemented correctly, background intensities can be calculated from 
negative controls close to a feature, and thus will vary as the background 
varies across a slide. However, unlike other methods which are purely 
computational and can be applied to any slide, negative controls must be 
part of the microarray slide design from the beginning.
Morphological methods address the problem wherein the background 
estimated for a feature is higher than the feature’s intensity. This 
situation can be catastrophic, as a negative background-subtracted 
intensity can lead to a negative ratio and an undefined log ratio, meaning 
that the feature is lost from all further data analysis. In morphological 
methods, a copy of each single-wavelength image is created, and then 
each image is filtered to construct a background image for each 
wavelength. Two morphological background methods are available:

• Closing followed by opening: Small dark regions are filled in on 
the background image, then a local minimum filter is applied to 
the whole image.

• Opening: A local minimum filter is applied to the whole image.
The Opening method produces a significantly lower estimate of 
background than any other background subtraction method, and 
guarantees that the background estimate is always lower than the 
feature intensity. However, it may underestimate the true background 
level.
Compared to the default local background subtraction method, the 
Closing Followed by Opening method produces background estimates 
that are slightly lower for regions of low background, but significantly 
lower for regions where there are bright patches in the background. 
However, background-subtracted intensities can still be negative using 
this method.
Regardless of the method chosen, the calculated background intensity is 
subtracted from the feature intensity before any ratios are calculated.
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Local Methods
In local background subtraction methods, a different background is 
computed for each individual feature indicator, and the mean, median 
and standard deviation of the background pixel intensities are reported. 
For all ratio calculations that require background subtraction, the median 
background value is used.
The background is calculated using a circular region that is centered on 
the feature indicator. This region has a diameter that is three times the 
diameter of the corresponding feature indicator. All the pixels within this 
area are used to compute the background unless one of the following is 
true:

• The pixel is not wholly outside a two pixel wide region around a 
feature indicator

• The pixel resides in a neighboring feature indicator
• The pixel is within the feature indicator of interest

Figure 1-1: Defining background pixels

In Figure 1-1, the dark grey region represents the pixels used for 
computing the background, the colored region represents the pixels used 
for the feature intensities, and the light gray region represents excluded 
pixels.
You can adjust the diameter of the background region and width of the 
exclusion region around a feature. Typically, you would make the 
exclusion region smaller and the diameter of the region larger as the 
density of features on your arrays increases.
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To change background settings
1. Click Options > Analysis.
2. Under Background Subtraction, edit the values for the exclusion 

region and the background region.
The allowable exclusion values are between 1 and 8, inclusive; the 
allowable background diameter values are between 2 and 5, inclusive.
The Software also reports the percentage of pixels exceeding local 
background-related thresholds—the percentage of pixels that are 
greater than the background+1 standard deviation, and background+2 
standard deviations. These threshold-related values are often useful in 
evaluating the quality of the data.

Global Methods
Several global background subtraction methods are available. In a global 
method, a single value for the background is used for a whole array at 
each wavelength. The global background values are either calculated 
from a mean or median of all local values, or specified as individual 
values for each channel.

Negative Controls
To use negative control background subtraction, you must identify 
features as negative controls by giving them a characteristic substring in 
their ID. By default, the Software looks for the substring "_NCTRL". For 
each feature, the name of the nearest negative control in the same block 
appears in the Negative Control column in the Results tab. The 
identifying substring is not case-sensitive, so you can use either "_nctrl" 
or "_Nctrl".

Morphological Methods
Morphological background subtraction starts with a copy of the image 
and filters it to construct a background image. The background value for 
a feature is then the intensity at the feature’s center on the background 
image.
Closing removes small dark regions from the image. Any dark region that 
fits into a square with sides given by the closing value is removed from 
the image. Closing prevents the measured background from being too 
low.
Opening removes bright regions. Any bright region that fits into a square 
with sides given by the opening value is removed. Opening prevents the 
measured background from being too high.
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If the opening value is too small, then features may not be removed from 
the background image. This typically happens on high-density arrays 
where the features are very close together.

Block Alignment and Background Thresholds
To align a feature indicator with a feature, the Software’s proprietary 
spot-finding algorithm makes several assumptions about feature 
intensity relative to the intensity of the background, feature size, and 
feature position.
A feature is marked Not Found if:

• The feature has fewer than six pixels
• The feature diameter found is greater than the lesser of: (a) 

three nominal diameters (as set in Block Properties) or (b) the 
diameter that would cause it to overlap an adjacent feature of 
nominal diameter

• The feature diameter goes outside the bounds set in 
Options  > Alignment

• The feature has been found in a position that would overlap an 
adjacent feature

If the spot-finding results in feature indicators that are larger than your 
features, it can be due to extreme background variation: bright 
background pixels may be included as feature pixels. To avoid this, try 
increasing the Composite Pixel Intensity threshold value on the 
Options > Alignment tab to a value slightly higher than the brightest 
background pixel near your features.

Ratio Quantities
The software computes a large number of different ratio quantities, each 
of which provides a different insight into the raw data. The main ratio 
quantities are described on the following pages and their significance is 
briefly discussed. They are divided into three different subgroups: those 
that are ratios of quantities derived from whole features (such as median 
and mean pixel intensities), those that are derived from pixel-by-pixel 
ratios of intensities, and quality factors.
All ratios and derived quantities are corrected for background effects. 
Pixel intensities at a wavelength have the median intensity of background 
pixels at that wavelength subtracted from them to produce a corrected 
intensity.
To get a better understanding of ratio computations it is useful to 
examine the Pixel Plot (press <P> when the cursor is over a selected 
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feature indicator). This plot shows you the pixel values for a selected 
feature, so you can see the contribution of each pixel to a ratio value.

Ratios of Overall Derived Feature Properties
In ratiometric fluorescence studies we are typically most interested in the 
difference in substance levels between the test and the reference 
samples. This eventually translates to differences in intensity on the two 
images analyzed by the software, which can be quantified by taking a 
ratio of image intensities for each feature. Because each feature on the 
image is made up of many pixels, we need a method of finding a 
representative intensity for each feature.

• Ratio of medians: Median intensities are often preferred to 
arithmetic mean intensities because they are not as seriously 
affected by extreme values at either end of a distribution. The 
ratio of medians is the ratio of the background subtracted 
median pixel intensity at the second wavelength, to the 
background subtracted median pixel intensity at the first 
wavelength.

• Ratio of means: Mean intensities are familiar quantities, but 
they can be significantly skewed by extreme values at either end 
of a distribution. However, calculating the mean allows you to 
evaluate the variability of the data. This variability is reported as 
the standard deviation. The ratio of means is the ratio of the 
arithmetic mean of the background-subtracted raw pixel 
intensities at the second wavelength, to the arithmetic mean of 
the background subtracted raw pixel intensities at the first 
wavelength.

On grounds of consistency you might expect to use the mean background 
instead of the median background when using the mean intensity. 
However, it is more important to use the most reliable value for the 
background than to be consistent. The fact that means can be skewed by 
extremely low and high values suggests that you should use the median 
background.

Note: The form of all ratio calculations is user-selectable from the 
Options > Analysis > Ratio Formulation dialog box. In this guide, we 
assume that wavelength 2 is always in the numerator and wavelength 1 
is in the denominator.
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Quantities Derived from Pixel-by-Pixel Ratios
An alternative to computing the ratio from calculated means and 
medians of each whole feature is to compute the ratio on a pixel-by-pixel 
basis, and then to calculate the arithmetic mean and median of these 
many ratio values. An advantage of this approach is that non-specific 
signal, which appears in both wavelength images, has less of an effect 
than when the feature is treated as a whole.

• Median of ratios: As is the case with the overall derived feature 
properties, median intensities are often preferred to mean 
intensities because they are not as seriously affected by extreme 
values at either end of a distribution as compared to the 
arithmetic mean. The median of ratios is the median of the 
pixel-by-pixel ratios of pixel intensities that have had the median 
background intensity subtracted.

• Mean of ratios: The mean of ratios is the geometric mean (the 
mean in log space) of the pixel-by-pixel ratios of the raw pixel 
intensities that have had the median background intensity 
subtracted.

• Regression ratio: The regression ratio is a method of computing 
the ratio that does not require rigidly defining background and 
foreground pixels, so it is the most objective of the three 
methods. Every pixel within a circle of twice the diameter of the 
feature of interest is used. The relationship between wavelength 
1 and wavelength 2 is determined by computing a linear 
regression between these two populations of pixels. The slope of 
the line of best fit (least-squares method) is the regression ratio. 
The coefficient of determination provides a measure of the level 
of accuracy of the fit. The regression ratio makes no assumptions 
about feature pixels or background pixels, so it can be useful for 
features that are badly misshapen, such as extreme 
donut-shaped features. However, the regression ratio can be 
seriously affected by saturated pixels. On a good array, all of the 
ratio values tend to converge. If the regression ratio is 
significantly different from the other ratio quantities for some of 
your features, look at each of these features in more detail to 
determine what is causing the deviation. The Pixel Plot is a useful 
tool for this.
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Quality Factors

Sum of Medians and Sum of Means
The sum of medians and the sum of means are useful measures to 
interrogate the quality of an individual feature. If either sum is 
unreasonably low, this indicates that there is very little signal in both 
channels, suggesting that any ratio derived from this feature should be 
interpreted with caution.
The sum of medians is the sum of the median of the pixel intensities at 
each wavelength, with the median background pixel intensity at each 
wavelength subtracted.
The sum of means is the sum of the arithmetic mean of the pixel 
intensities at each wavelength, with the median background pixel 
intensity at each wavelength subtracted.
These quantities are calculated on a per ratio channel basis; that is, for 
each pair of wavelengths in a ratio, a separate sum of medians and sum 
of means column is calculated.

• Log ratio: The log ratio is a base two logarithm of the ratio of 
medians. This type of log transformation is often used in 
ratiometric studies as it helps to compare levels of over-activity 
and under-activity. For example, if you have a four-fold increase 
in activity (a ratio value of 4), the log base 2 ratio is +2; if you 
have a four-fold decrease in the ratio (a ratio value of 0.25), the 
value is –2. The log base two transform allows you to normalize 
the distribution so that a four-fold increase and a four-fold 
decrease have the same magnitude.

• Signal to noise ratio: Signal-to-noise is important for 
determining the confidence with which one can quantify a signal 
peak of a given value, especially a signal near background. The 
confidence in quantifying the peak increases as the variation in 
background noise decreases, regardless of the absolute value of 
the average background.
You can easily compute the signal-to-noise ratio (SNR) by 
measuring the mean signal intensity for a feature, subtracting 
the mean background signal, and dividing by the variation in the 
background, so the signal-to-noise ratio is defined as: 
(F635Mean – B635Mean) / B635SD where F635Mean is the 
mean of all the feature pixel intensities at 635nm, B635Mean is 
the mean of all the background pixel intensities at 635nm, and 
B635SD is the standard deviation of the background pixel 
intensities at 635nm.
0112-0178 D 25 



GenePix Pro Microarray Acquisition and Analysis Software User Guide
Because medians are more robust to outliers than means, we 
typically recommend the median instead of the mean as a 
measure of feature or background intensity. However, because 
the signal-to-noise ratio is well understood theoretically when 
calculated using means, we calculate the signal-to-noise ratio 
using the mean intensity and mean background.

Flags
You can flag individual features manually with quality flags, such as Good, 
Bad, Absent, and Not Found. Flags are also used to indicate which 
features to use in the normalization of the image. And you can create 
custom User Defined flags to track Good and Bad traits of particular 
importance to your analyses. See Creating Custom Flags on page 66 for 
more information.
The Bad flag is useful when doing a cursory analysis of your images. If you 
observe a region where the features are sub-standard, you can flag them 
Bad and a flag value of –100 is noted in the analysis results.
Alternatively if you see a feature that shows some especially promising 
properties, you may want to flag it Good. If so, a flag value of +100 is 
noted in the Results. Select flagging commands from the Feature menu 
on the right-hand side of the main window.
Absent (numerical value –75) is applied to a feature when a GAL file is 
missing an entry for a feature, or when the ID is “Empty”. In a GAL file, 
each feature must show a value in the ID column; if that value is “empty”, 
the software automatically flags it as absent.
A feature is flagged Not Found (numerical value –50) when Align Blocks 
fails to align a feature indicator. See Block Alignment and Background 
Thresholds on page 22 for conditions under which alignment can fail.
A second type of flag is the Normalize flag. It has its own column in the 
Results tab, and is used to mark features for use in Normalization. For 
each feature you can choose to Include in Normalization or Remove from 
Normalization. When exported, these flags have the values 1 and 0 
respectively.
Features can be flagged according to general Boolean conditions using 
the Flag Features dialog box on the Results tab. The expression is 
evaluated for each row in the Results tab, and features are flagged 
according to whether or not the expression is true or false for them. See 
Defining Your Own Flagging Criteria on page 76.
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Data Normalization

Origins of Variability
Comparing the data from different array experiments is a complex task. 
Small variations in the many steps that produce an array image can make 
comparisons across arrays problematic. Variations can be due to 
differences in labeling efficiencies (dye and batch variations), chemical 
properties of different dyes, pin tips, slide batches, and scanner settings 
(such as, red/green channel settings, multiple scanners). Any of these 
variations can be corrected by normalization. Normalization can also 
help you to compare multiple channels—for example, the green and red 
channels—within a single microarray. No one normalization method will 
correct all types of variation. Choose a normalization method based on 
the known or expected sources of error, and the characteristics of the 
experiment. Validate the method empirically, for example by reversing 
the dye labeling to test a normalization method for channel balancing.
In the acquisition step of an experiment, one of the main contributors to 
variability between channels is setting PMT values incorrectly, so that the 
total signal acquired in one channel is significantly different from the 
total signal acquired in the other (assuming that when scanning a 
particular sample, the total signal in each channel is in fact the same). In 
such a case ratio values may be biased towards one channel. To minimize 
this form of variability, you should perform preliminary scans to adjust 
the PMTs so that they are producing roughly the same response in both 
channels. See Optimizing Scanner Settings on page 39.

Normalization Methods
In the analysis step, you can improve comparisons across many arrays by 
normalizing the data from each array. One method of normalization is 
based on the premise that most genes on the array will not be 
differentially expressed, and therefore the geometric mean of the ratios 
from every feature on a given array should be equal to 1. If the mean is 
not 1, a value is computed which represents the amount by which the 
ratio data should be scaled such that the mean value returns to 1. This 
value is the normalization factor.
Another method is to choose a subset of the features on an image as 
control features. All substances change expression levels under different 
conditions. Normalization control features should be selected based on 
their consistent behavior in all experimental conditions used on your 
arrays, not on their historical use as housekeeping genes in other 
molecular biology techniques. For example, the control spots might be 
such that each is expected to have a ratio of 1, so the mean of the control 
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features should be 1. Assuming that variations are uniform across the 
array, a single normalization factor can be calculated from these features 
and then applied to the whole array.

Normalization Process
Having chosen a normalization method, it must be implemented in 
software. The software employs a global normalization method in which 
images and results are normalized together. If the current results are not 
derived from the current images (that is, if they are not linked), then 
results data are normalized alone; see Linkage on page 73. You can 
always remove normalization to return to your original images.
Because ratios are not normally distributed, the software first takes the 
log of each ratio value when normalizing. The mean x of a set of n ratios 
{x} is therefore:

Figure 1-2: Normalization Formula

Ratio values less than 0.1 or greater than 10 are excluded from the 
calculation, as are features flagged Bad, Absent or Not Found.
Four-color normalization is done on a ratio-by-ratio basis. For example, if 
you choose to normalize so that the mean of the Ratio of Medians is set 
to 1.0, each Ratio of Medians data type that you have defined in the 
Options > Analysis > Ratio Formulation dialog box is normalized 
independently.
To calculate the wavelength-specific normalization factors that are 
reported in the Results Header, the change to the ratio is distributed 
equally between the wavelengths, so one wavelength scales up by the 
square root of the ratio scale factor and the other scales down.
For example, suppose the mean of Ratio of Medians of 635/532 is 1.21. 
The square root of 1.21 is 1.1, so we set the scale factor for the 532 
wavelength to 1.1, and the scale factor for the 635 wavelength to 
1/1.1 = 0.91. After applying these scale factors, the new mean of the 
Ratio of Medians is 1.21 * 0.91 / 1.1 = 1.0.
Because normalization can scale up the data, it is possible for 
normalization to produce pixels with intensities greater than the 
hardware limit of 65535.
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File Formats
The Software recognizes and uses several different file types.

ATF (Axon Text File Format)
This is a tab-delimited text file format that can be read by typical 
spreadsheet programs such as Microsoft Excel. It is used for GAL files and 
GPR files.
An ATF text file consists of records. The group of records at the beginning 
of the file is called the file header. The file header describes the file 
structure and includes column titles, units, and comments. Each line in 
the text file is a record. Each record may consist of several fields, 
separated by a field separator or column delimiter. The tab and comma 
characters are field separators. Space characters around a tab or comma 
are ignored and considered part of the field separator. Text strings are 
enclosed in quotation marks to ensure that any embedded spaces, 
commas and tabs are not mistaken for field separators.

GAL (GenePix Array List File)
The GAL file conforms to the Axon Text File (ATF) format. The GAL file 
contains entries to describe the layout of each block, and to assign names 
and identifiers (IDs) to each feature on an array. The software can also 
read GAL files with user-defined data columns beyond the usual five; 
information in user-defined columns is preserved and written to the GPR 
file when results are saved.

GIS (GenePix Image Set File)
The GIS file links GPS settings information to a set of images (for example, 
as captured in a Save Images—All Scan Areas process). To open a GIS file, 
click File > Open Image Set; this opens the images and their related 
settings all at once.
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GPA (GenePix Loader File)
GenePix scanners with robotic slide loaders only: Settings for batch 
scanning (which GPS or GAL file to use, Auto PMT setting, and so forth for 
each slide) are saved as a binary file.

GPL (GenePix Lab Book File)
The GPL is a read-only binary file. See Special Functions on page 82 for 
more information about the Lab Book.

GPR (GenePix Results File)
Results data are saved as GPR files, which are in Axon Text File (ATF) 
format. The results file contains general information about image 
acquisition and analysis, as well as the data extracted from each 
individual feature. Results can be saved with the entire table in a single 
GPR file, or with each block in a separate GPR file.

GPS (GenePix Settings File)
Acquisition, analysis and display settings are saved as binary GPS files. 
Settings are organized into several different categories (acquisition, 
analysis and display) all of which are saved together in the GPS file. 
However, when opening a settings file you can choose which subset of 
the settings you want to open.
Acquisition settings include which laser was enabled during the 
acquisition, the PMT Gain settings, the lines averaged, and the scan area. 
Analysis settings include the location and identification of blocks and 
feature indicators that were defined on the image. Display settings 
include brightness and contrast settings, and the ratio color mapping.
GPS files and GAL files both contain block and feature geometry, and 
both can be used to apply a grid template to an image. However, a GAL 
file does not contain the acquisition and display settings that are saved in 
a GPS file.

JPEG (Joint Photographic Experts Group)
You can save images in JPEG format for use in presentations or reports, 
but these JPEG images cannot be used for analysis. JPEG is a compressed 
image format which creates smaller files than other formats, such as TIFF.
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TIFF (Tagged Image File Format)
Images acquired are by default saved in the TIFF format. This is a 
standard, uncompressed graphic file format that can be read by many 
graphics and imaging programs. The primary data acquired by the 
software are the single-wavelength images, and by default these are 
saved as 16-bit grayscale TIFFs in a single multi-image TIFF file. Not all 
graphics applications can read multi-image TIFF files. You may want to try 
opening a multi-image file with your preferred graphics application to see 
if they are supported. If not, save the single-wavelength images as 
separate single-image files. The software exports its preview and 
pseudocolor ratio images as 24-bit color TIFFs, but it does not read them, 
as data are not extracted from them.
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Tutorial: Image Acquisition & Analysis
This tutorial guides you through loading your first array and scanning 
your first array image. It also leads you through a basic array analysis, and 
describes more advanced functionality.
Topics in this section include:

• Starting the Software on page 33
• Image Acquisition on page 34: Image Acquisition begins with 

starting the scanner and takes you through to scanning an array 
and saving your images. If you are using the Software in Analysis 
Only mode, you can skip this topic.

• Image Analysis on page 46: This topic begins with loading an 
image, and takes you through all the analysis steps required to 
extract data from the image.

• Special Functions on page 82: This topic describes additional 
features you might use regularly.

Starting the Software
The GenePix® Software installation program creates a Molecular Devices/ 
GenePixPro 7 folder in your Programs list and a shortcut icon on your 
desktop. The folder contains several programs, including the main 
GenePix Pro 7 and GenePix Pro 7 (Analysis Only) entries. Either program 
will start the Software, but the Analysis Only option operates 
independently and does not interact with the scanner hardware. The 
Programs folder also contains shortcuts to the Array List Generator, 
Tools, Uninstall, Help, Reset to Program Defaults, Tutorial, and GenePix 
Utilities.
If you have not yet installed your GenePix® scanner, do so, referring to 
your scanner documentation.

Note: The scanner must be running before your computer is started so 
that the software can verify that the scanner is connected and 
operational.
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Analysis Only Mode
The GenePix Pro 7 (Analysis Only) shortcut accesses the standalone 
version of the software. This version provides the same functionality as 
regular mode, except that the Software does not interact with a physical 
scanner.
You can use Analysis Only mode to:

• Mimic the scanning process while training or working through 
this tutorial. In this mode, sample images appear when you press 
a scan button. The software installation file includes all the 
necessary settings and analysis files to accompany the sample 
images.

• Acquire image data on one computer (run in regular mode) and 
perform analyses on another (run in Analysis Only mode).

• Save wear on the lasers while running multiple or lengthy 
analyses.

Image Acquisition
This section leads you through the entire image acquisition process, from 
performing a preview scan to scanning an array and saving your images. 
If you are running the Software in Analysis Only mode, you can skip this 
topic.

Configuring Laser Settings

Figure 2-1: Laser Settings

Figure 2-2: Erase All Scan Area Images

Note: After power-on, give the scanner 15 minutes to warm up before 
acquiring any images with it. This allows time for the lasers’ output to 
stabilize.
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Use the Laser Settings dialog box to define the pixel size and wavelengths 
per image channel you wish to use. You can alter your laser settings only 
before beginning a scan. If you have already acquired data, you must 
clear the existing images before you can reconfigure the laser settings.

To configure laser settings
1. On the Image tab, click Laser Settings.

Figure 2-3: Laser Settings dialog box

2. In the Pixel Size spin box, select the desired size to use for your 
scan areas.

3. In the Wavelength drop-down lists, select the desired 
wavelengths to use per image channel.

4. Click OK.

Note: The Software uses the first Data Scan to automatically determine 
the pixel size that will be used for all scan areas. When you run a Data 
Scan, the Pixel Size control is disabled. To clear images and allow a new 
pixel size to be set, click Erase All Scan Area Images.
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Performing Preview Scans

Figure 2-4: Preview Scan

For information on inserting and removing arrays, see the 
documentation accompanying your scanner.
Use a Preview Scan, running at a relatively low resolution of 40 μm, to 
find the areas of interest on the array. You can then select those regions 
as Scan Areas and follow with a high resolution Data Scan.

To perform a Preview Scan
1. Start the Software.
2. Insert a slide with the arrayed features facing down.
3. On the Image tab, click Preview Scan.

Creating Scan Areas

Figure 2-5: New Scan Area

After running a preview scan, you can define specific scan areas. By 
default, the initial scan area for the slide (Scan Area 1) is sized to the 
dimensions of the entire slide. To adjust the data scan area to include 
only the features in your array, click the Scan Area Properties button and 
enter the desired dimensions. You can create as many scan areas as you 
need; click New Scan Area to add subsequent scan areas. The number in 
the top left corner of the scan box shows the scan area ID.
When a scan area is locked, the word Locked appears in the bottom right 
corner of that area. All scan areas are locked during the acquisition of 
image data; when data acquisition is complete, all scan areas with 
images become locked.
When scan areas are unlocked, you can use your cursor to move or resize 
them as required, using standard click, drag, and drop functions.
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To create a Scan Area

Figure 2-6: View Scan Area

1. On the Image tab, click View Scan Area > New Scan Area.
2. In the New Scan Area dialog box, specify the desired size and 

position of the scan area. 
3. The settings in this dialog box default to those of the scan area 

last created or selected. 
4. Click OK. 

The scan area appears on the image.

5. Press <5> to zoom into the selected scan area.

Performing a Multiple Wavelength Data Scan

Figure 2-7: Data Scan

A data scan is a high-resolution scan that is used for data analysis. You 
can set it to run at resolutions scaling from 5 μm/pixel to 100 μm/pixel 
(for the GenePix 4400A scanner, this range runs from 2.5 μm/pixel to 
100 μm/pixel). Scan at the lowest end of the range to analyze features 
smaller than 100 μm in diameter. A 100 μm circular feature scanned 
with 10 μm pixels contains about 78 pixels, which is sufficient for an 
accurate intensity measurement. For features larger than 100 μm, the 
negligible difference in accuracy is unlikely to justify the fourfold increase 
in file size and the twofold increase in scan time required by a 5 μm scan.

Figure 2-8: Data Scan All

Where multiple scan areas exist, clicking Data Scan runs a scan for the 
selected scan area only. During the scan, only the image for the active 

Tip: You can also click and drag with your cursor to change the 
size and position of any scan area.
0112-0178 D 37 



GenePix Pro Microarray Acquisition and Analysis Software User Guide
scan area is visible, and scan areas are locked. Following the scan, all 
image areas become visible, and any scan areas that do not contain 
images are unlocked so that you may select a subsequent scan area for 
scanning.

Figure 2-9: Scan Area Spinner

To scan multiple scan areas at once, click Data Scan All. Each scan area 
will be scanned in sequence.
To view the images, results, or scatter plots for any of a series of multiple 
scan areas, click the appropriate tab and use the Scan Area spin box tool 
to select the number of the scan area you want to see.

To change the resolution for a data scan
1. Ensure any existing images are erased. To do this, click Erase All 

Scan Area Images. 
2. You are prompted to save the existing images.
3. Click Laser Settings.
4. In the Pixel Size spin box, select the desired value.
5. On the Image tab, click Data Scan.

During scanning, all image display controls and zooming functions are 
fully operational. See Image Analysis on page 46.

Performing Single Wavelength Scans

Figure 2-10: Single Wavelength Scan

If you have scanned two, three, or four wavelengths (depending on your 
model of scanner), and one of the wavelengths scans was done at an 
incorrect PMT setting, for example, you can use the Single Wavelength 
Scan function to scan just that wavelength again, while retaining all the 
other wavelengths.

Note: When you perform a single wavelength scan, the original image 
for that wavelength is overwritten.
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Optimizing Scanner Settings
The Hardware Settings dialog box controls many different scanner 
settings, such as PMT gain, filter selection, lines to average, and focus 
position.

Maximizing the Dynamic Range of a Scan
The complete dynamic range of the scanner is being used when you see a 
range of intensities on the image from 1 to 65535. A pixel with an 
intensity of 65535 is saturated. Saturated pixels represent a condition in 
which there are more photons detected than the PMT can process, or 
the output of the PMTs exceeds the range of the analog-to-digital 
converters. A saturated pixel is not an accurate measurement of the 
signal from the pixel, so it is imperative to set the PMT Gain to avoid 
saturation. Note that you should not set the PMT gain to lower than 400, 
as this will result in a nonlinear signal.
Saturated pixels are drawn as white on the image, and appear on the far 
right of the histogram. See Special Functions on page 82.

To maximize the dynamic range of your scanner for a slide
1. Click Hardware Settings. The Hardware Settings dialog box can 

remain open while scanning.
2. Click Preview Scan.
3. While scanning, increase the PMT Gain for each wavelength until 

there are no pixels that are saturating in each single wavelength 
image. You should not set the PMT gain to lower than 350, as this 
will result in a nonlinear signal.

Balancing PMTs
The ideal scan is one in which the same amount of red and green feature 
signal is acquired in each channel, resulting in a pixel ratio of 
approximately 1.0. Post-acquisition normalization can correct for 
variations in relative signal intensities, so scanner settings need only 
approximate a ratio of 1.0. Balancing the two channels by eye is often 
sufficient.

To Balance PMTs
1. On the Image tab, select a scan area.
2. Click Hardware Settings. The Hardware Settings dialog box can 

remain open while scanning.
3. Click Preview Scan.
4. Zoom into the part of the image that contains the features.
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5. Click the Histogram tab.
6. In the Image Balance section, set the Min Intensity and Max 

Intensity to 500 and 65530, respectively.
The Count Ratio field at the bottom left of the Histogram tab 
reports the ratio of counts in each channel.

7. While scanning, in the Hardware Settings dialog box, adjust the 
PMT Gain in each channel until this ratio is about 1.0. You should 
not set the PMT gain to lower than 350, as this will result in a 
nonlinear signal.

For more information about the Histogram tab, see Special Functions on 
page 82.

Automatically Balancing PMTs
Instead of manually adjusting the PMT gain, to maximize the dynamic 
range and balance the signal from the channels you can use the 
automatic PMT balancing routine.
To use this routine you need to have a GAL or GPS file for the slide that is 
approximately positioned on blocks of features on the slide. The GAL file 
should also have accurate default feature diameters. Any good GAL file 
will be correctly positioned, even before any manual editing or spot 
finding.
Where multiple scan areas exist, the Auto PMT is calculated separately 
for each area. Select the scan area containing the blocks where you want 
the Auto PMT calculation to occur. During the scan, the Image tab enters 
Preview mode and runs multiple scans on the selected area. When the 
preview scans are complete, the dialog box displays the optimum PMT 
gains, which you can then apply to the hardware settings for the selected 
scan area by clicking Apply.

To automatically balance PMTs
1. On the Image tab, select a Scan Area.
2. Click Hardware Settings.
3. Click Auto PMT. 

The Set PMT Gain dialog box appears.
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Figure 2-11: Set PMT Gain dialog box

4. In the Set the saturation tolerance spin box, select the amount 
of saturation (in terms of the percentage of pixels) that you want 
to allow in the scanned image. Molecular Devices does not 
recommend setting zero saturation, as a bright artifact on the 
image can cause the rest of the image to be scaled so that it is 
very dim. The default saturation of 0.05% is recommended for 
most slides.

5. Select or clear the Automatically Apply Calculated PMT Gain 
Values and Then Do a Data Scan option as desired. When 
enabled, this sets the software to perform a data scan 
immediately following the automatic PMT routine.

6. Click Start. 
The routine performs a number of Preview Scans at different 
PMT gain settings. When it is finished, it recommends PMT gain 
settings to be used for your Data Scan. 

7. If you want to accept recommended PMT gain settings, click 
Apply.
If you want to revert to the original PMT gain settings, click 
Cancel.
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Using Line Averaging
To maximize the signal-to-noise ratio, you may want to average multiple 
lines. If you set Lines to average to 2, for example, the scanner scans each 
line twice and averages the value. Keep in mind that as you increase the 
amount of line averaging you correspondingly increase the amount of 
time needed to complete each scan. For example, averaging two lines 
doubles the scan time.
To average more than one line in a Data Scan

1. Click Hardware Settings. The Hardware Settings dialog box can 
remain open while scanning.

2. Change the Lines to Average field to the number of lines that you 
want to average (for example, 2).

3. Click Data Scan.

Changing Filter Selections
The Hardware Settings dialog box displays the filter selection field only if 
your scanner supports the installation of additional custom filters. Only 
the currently installed filters are displayed.
The emission filters that come installed as standard in your scanner are 
optimized for use with specific fluorophores—for instance the factory-
installed filters in the GenePix® 4100A scanner are optimized for use with 
Cy3 (excited by 532 nm laser) and Cy5 (excited by 635 nm laser). You 
might want to install additional filters if you are using dyes with emission 
characteristics different from those for which the standard filters are 
designed.
If additional emission filters have been installed on your scanner, you can 
select which filter is used with which wavelength laser scan.

To change filter selection
1. Click Hardware Settings.
2. Change the Filter field for each wavelength to the desired filter.
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Changing Laser Power
The Hardware Settings dialog box displays laser power adjustment only if 
your scanner is equipped with this feature.
You may want to reduce the laser power to avoid photobleaching if you 
have a particularly photosensitive sample, or if you need to scan a slide 
more than once, for example when fine-tuning focal plane adjustments. 
Some dyes, such as Cy5, are particularly prone to photobleaching. 
However, reducing laser power also reduces signal-to-noise ratio. Laser 
power cannot be adjusted while the scan is in progress.

To adjust the laser power
1. Click Hardware Settings.
2. Change the Power field for each wavelength to the desired value.

Changing Focus Position
If your scanner has the ability to change focus position, then the 
Hardware Settings dialog box displays focus position adjustment. You can 
change the focal point from –50 μm to +200 μm relative to the zero 
position, where a negative value is towards the slide. You can choose to 
focus manually for any sample with appreciable thickness, such as one 
with a cover slip. The best focus position is that at which the intensity is 
maximized.
Photobleaching may be a problem if you scan repeatedly to find the right 
focal point. If you are scanning repeatedly, you may want to reduce laser 
power. The focal plane can be adjusted while the scan is in progress.
To change the focus position

Figure 2-12: Hardware Settings

1. Click Hardware Settings.
2. Change the Focus Position field to the desired value.
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Saving Hardware Settings
You can save your acquisition settings, as well as analysis and display 
parameters, in a GPS file. These settings can be opened later for use on 
other slides.

To save settings
1. Click File > Save Settings As.
2. From the Save as type field, select GenePix Settings File (*.gps).
3. Type in a file name and click Save.

Saving Images

Figure 2-13: File... icon

When your array has been scanned, the next step is to save the images. 
You can save the image for just the selected or active scan area, or you 
can choose to save the images for all existing scan areas on the slide at 
one time.

Choosing a File Format
By default, all images created are saved as 16-bit multi-image TIFF files. 
Each multi-image TIFF file contains the images of the individual 
wavelengths scanned. The ratio image is not saved because it is 
recomputed when the multi-image TIFF file is opened.

To save images as multi-image TIFFs
1. Click File > Save Images—Active Scan Area or File > Save 

Images—All Scan Areas, as desired.
2. In the Save as type field, select Multi-image TIFF Files.
3. Click Save.
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The Software also provides the option to save each image component of 
the acquired image as a separate TIFF file. There are several reasons why 
you might want to do this:

• Some graphics applications cannot read multi-image TIFF files; if 
you use one of these applications, you need to save the images 
separately if you are going to import them into such a program.

• You might want to save just the ratio image for presentation 
purposes. You can only save the ratio as a single-image file; it is 
not saved in the multi-image TIFF file.

To save images as single-image TIFFs
1. Click File > Save Images—Active Scan Area or File > Save 

Images—All Scan Areas, as desired.
2. In the Save as type field, select Single-image TIFF Files.
3. Click the check boxes to select the images to save.
4. Click Save.

We recommend that for all data analysis purposes you save your images 
as multi-image TIFF files. The Software also allows you to export images 
in JPEG format. We recommend that you do not use the JPEG format to 
archive images; use it only for presentation purposes where image 
quantitation is not required.

To export images as JPEGs

1. Click File > Export Images.
2. Enter a file name for your images.
3. Select the check boxes to select the images to export.
4. Click Save.

Note: It is important to realize that if you do not save the raw 
wavelength images, that is, you save only the ratio image, then future 
analysis is impossible.

Note: Images saved in the JPEG format cannot be re-opened in the 
Software.
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Configuring Automatic File Names
The Software offers several options to generate file names automatically 
when saving images.

To set automatic file names
1. Click File > Save Images—Active Scan Area or File > Save 

Images—All Scan Areas, as desired.
2. In the Naming group, select one of the following:
 Select the Date Prefix option to prefix the file name with the 

current date (yyyy-mm-dd).
 Select the Numeric Suffix option to add a four-digit suffix to 

the file name, where numbering begins at ‘0000’.
 Select the Scan Area Suffix option to add the scan area ID as 

a suffix to the file name.
 Select the Barcode Prefix option to prefix the file name with 

any barcode symbols from your image.
 Select the User Name option to add the user name to the 

front of a file name (you can set the software to be opened 
by user name; see Workflow Automation Options on 
page 97).

The Software controls the last few characters of the file name, which are 
reserved to indicate a file number, and the type of image if separate 
image files are being created. When saving single-wavelength images as 
either TIFFs or JPEGs, the Software adds the wavelength of the image as 
a suffix to the file name.

Image Analysis
After an image has been acquired, the next step is to view the image and 
measure the signal intensity of each feature.

Selecting a Color Mode
You can launch the Software in different modes for one-color, two-color, 
or four-color analysis. In two-color mode, you can load two 
single-wavelength images and define one ratio. In four-color mode, you 
can load up to four single-wavelength images, and define up to three 
independent ratios. In one-color mode, you load only a single 
wavelength channel at a time and thus do not measure any ratios, only 
intensity, in that channel.
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To select a color mode

Figure 2-14: Options

1. Click Options > Display.
2. In the Color Mode section, select the desired mode, and then 

click OK.
3. If you changed the color mode, shut down the Software and then 

restart it.

Opening Images
If you have just acquired an image, it will be displayed on the screen 
ready for you to analyze it. If you want to save an image that has just 
been scanned, be sure to do so before proceeding with analysis. 
Alternatively, you can open a previously saved image.
To open an image

Figure 2-15: File... icon

1. Click File > Open Images.
2. Navigate to a directory that contains previously saved TIFF 

images. For example, open one of the sample TIFF files in the 
Program Files\Molecular Devices\GenePix Pro 7\Sample Data 
directory.

3. Select the image you want to view and click Open.
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Opening Images in Four-color Mode
VTo produce a sensible ratio image, images must be acquired with the 
same Scan Area (that is, with the same Settings file) and at the same 
resolution.

To open multiple images in four-color mode
1. Start the Software in four-color mode.
2. Click File > Open Images.
3. Navigate to a directory that contains previously saved TIFF 

images. For example, open one of the sample TIFF files found in 
the Program Files\Molecular Devices\GenePix Pro 7\Sample 
Data directory.

4. Hold down the Ctrl key to select multiple images.
5. Click Open. 

The Assign Image dialog box appears. For each image, assign a 
wavelength and a color.

If the images were acquired on an GenePix scanner, the software 
automatically recognizes the wavelengths used for each channel. You can 
avoid the Assign Images dialog box by clearing the Enable User Assigned 
Wavelengths and Channels check box in the Open Image > Options 
dialog box. You can also override the actual values (for example to do 
ratio analysis of two images both scanned with the red laser) by selecting 
the check box and entering any wavelength values you choose.
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Registering Images
Images acquired from more than one scanner, or acquired sequentially 
(instead of simultaneously) may need to be registered (aligned) before 
they can be analyzed. If images are misregistered, you can register them 
by hand, or allow the software to register them automatically.

To register images automatically

Figure 2-16: Image Tools icon

1. On the Image tab, click Image Tools>Find best registration 
automatically.
If your images are very badly misregistered, for example, greater 
than 10 pixels, you need to set a starting offset for the 
registration algorithm.

2. If the registration fails, perform it again, but specify starting 
offsets.

To register images manually
1. Zoom in to the image so that you can see one or two features 

only.
2. On the Image tab, click Image Tools > Register Images. 
3. The Register Images dialog box appears.
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Figure 2-17: Register Images dialog box (4-color mode)

4. (Four-color mode only) Select a Base Wavelength. This is the 
image against which the others will be aligned.

5. Specify offsets as desired.
6. Click OK.

Customizing Ratio Formulation
The ratio formulation specifies which image is the numerator and which 
is the denominator for each ratio image. In two-color mode this is a 
simple binary choice, but in four-color mode there are many more 
choices.
For example, if you have four images numbered 1 to 4, your ratio images 
could be 1/2, 1/3 and 1/4, or they could be 1/2, 2/3 and 3/4, which is a 
very different experiment.

To change the ratio formulation
1. Click Options.
2. Click the Analysis tab.
3. Click Select in the Ratio Formulation group.
4. In two-color mode, switch to the reciprocal ratio formulation. In 

four-color mode, check up to three ratios.
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In four-color mode, it is possible to select a set of ratios where one of the 
ratios can be expressed as a product of the others. This is known as a 
dependent set of ratios, and the set cannot be normalized. For example, 
1/2, 2/3, and 3/1 is a dependent set. If you want to be able to normalize 
your data, use an independent set of ratios, such as 2/1, 3/1, 4/1.

Image Display and Color Control
The Software has many commands with which you can change the 
display of the image.

To switch between single-wavelength and ratio images
• In the Image group at the top left of the Image tab, click the 

image name buttons.

To change the colors displayed for an image

Figure 2-18: Color Selection

1. On the Image tab, click Color Selection.
2. Select from the list of wavelength color combinations at the top 

of the menu.
These image display controls are also available in real time during an 
acquisition. Experiment with the various display settings to find what 
works best for you. For example, green–blue with inverted color is good 
for distinguishing features from background at high magnifications.

To invert colors
1. On the Image tab, click Color Selection.
2. Select Invert Color from the menu.

To change the brightness and contrast of an image
1. To set brightness and contrast to their optimum settings, click 

Auto Scale Display Settings.
2. Move the individual brightness and contrast sliders for custom 

settings.
3. If you want to return brightness and contrast to their defaults, 

click Reset.
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Zooming the Display
The Software has several sophisticated controls for magnifying an image.

To increase the magnification of the image being displayed

Figure 2-19: Zoom Mode

1. On the Image tab, click Zoom Mode.
2. With your cursor, click and draw a rectangle around the area that 

you would like to view at higher magnification.

To return to the previous magnification

Figure 2-20: Undo Zoom

1. Click Undo Zoom.
2. Repeat as necessary, to back out to the desired level of 

magnification.

To view the image at full scale

Figure 2-21: Zoom Full Scale

1. Click Full Scale.

Using the Navigation Window
The Navigation window displays a greatly reduced image of the entire 
scanned area with the current zoomed area bounded by a resizable 
Navigation region. 

To move around the image using the Navigation window
1. Use the Zoom tool to zoom into a region of the image.
2. Hold down the mouse cursor in the Navigation region of the 

Navigation window, and drag it to the part of the image that you 
want to see.
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To zoom with the Navigation window

Figure 2-22: Navigation Tool

1. On the Image tab, click Navigation Tool.
2. Place the mouse cursor over a corner of the Navigation region 

until it turns into a four-way arrow cursor.
3. Drag the cursor to zoom in or out on the image:

Figure 2-23: Navigation window and cursor
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Using the Feature Viewer
The Feature Viewer is located on the Image tab to the left of the main 
image window. It displays a zoomed view of the image that is currently 
under the mouse cursor. It also reports important information about 
each feature, such as the (x, y) coordinates of the cursor, and various 
ratio and intensity values.

Figure 2-24: Feature Viewer

When you move your cursor over a feature indicator in an array, the 
Feature Viewer reports the intensity of the pixels in that feature 
indicator, its background intensity level, its location in the array, and any 
substance IDs or names defined for the features.
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To change the magnification of the Feature Viewer

Figure 2-25: Options

1. Click Options > Display.
2. Change the Field of View field to the new value.

To hide feature indicators in the Feature Viewer display
1. Click Options > Display.
2. Clear the Show feature indicators check box, and then click OK.

To undock the Feature Viewer in four-color mode
1. Start the Software in four-color mode.
2. Click Options > Display.
3. Clear the Docked check box, and then click OK.

Creating and Using Analysis Arrays
In order to measure the intensity of individual features you must create 
an analysis array, which defines the dimensions and location of each 
feature. A detailed discussion of the algorithms used by the array can be 
found in Analytic Algorithms on page 18.

Working with Spots, Features, Blocks, Scan Areas, 
and Arrays
Within the Software, each individual spot on the array is called a feature, 
and is assigned a circular feature indicator. Feature Indicators are the 
primary unit of analysis in the software. A collection of feature indicators 
is called a block. There can be several blocks on a single array, depending 
upon the type and configuration of the arrayer used to place the features 
on the slide. Scan areas identify the sections of the image you want the 
software to scan; you can create single or multiple scan areas on each 
array, as required, with each containing single or multiple blocks of 
features.
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Using a GAL File to Create Blocks
The Software can automatically generate blocks using the information 
contained in a GAL file. GAL files are used to link the information from 
the array process to the analysis. They speed the analysis process and 
add to the data extracted from the array. When a GAL file is imported, 
the Feature Viewer reports the substance ID or name associated with a 
feature when you move your cursor over it, and an Analysis operation 
exports these names to the Results tab together with all other extracted 
data.

Figure 2-26: Sample array of blocks

To open a GAL file
1. Click File > Load Array List.
2. Select the desired file, for example, see demo.gal.
3. Click Open.

This procedure automatically creates blocks, and assigns substance 
names and identifiers (if they are in the GAL file) to each spot. To create a 
new GAL file, see Importing Clone Information on page 59.
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Creating blocks manually

Figure 2-27: Block Mode

Figure 2-28: New Block

You can also create blocks manually using the Block mode functions.

To create blocks manually
1. On the Image tab, click Block Mode and then New Blocks. 

The New Blocks dialog box appears.
2. In the Blocks group, specify the number of rows and columns 

you want the array to contain. For example, to create a 4  4 
array of blocks, enter 4 for the number of columns and 4 for the 
number of rows.

3. To determine the position of the blocks, specify the distance 
between them. If you do not have these distances from your 
array manufacturer or spotter, you can measure these distances 
directly from the array image using the X and Y coordinates 
reported in the Feature Viewer.

4. Specify the layout of the individual feature indicators in each 
block.

Figure 2-29: Block and feature indicator spacing
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Replicating Existing Blocks
Instead of creating a full array of blocks, it is sometimes easier to create 
one block and then copy it.

To replicate an existing block

1. On the Image tab, click Block Mode and then View Blocks.
2. Select an existing block, or create a new block and then select it.
3. Click Replicate Block Mode.
4. Click on the image (for example, click on the top left feature of 

each block of features).
A new, identical block is created wherever you click.

Table 2-1: Icon Descriptions

Icon Description

Block Mode

View Blocks

Replicate Block Mode
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Importing Clone Information
Clone information, such as substance IDs and names, is imported using a 
GAL file, which also creates blocks. You can create GAL files in several 
different ways. Some arrayer software writes out GAL files with clone 
information. If you are buying slides from your array manufacturer, they 
will supply you with a GAL file for the array.

Creating a GAL File from Current Settings
If you create a GAL file in this way, you need to add substance IDs and 
names manually in a spreadsheet such as Microsoft Excel.

To create a GAL file from your current analysis (block) settings
1. Create blocks as described previously.
2. Click File > Save Settings As.
3. From the Save as type list, select GenePix Array List Files.
4. Click Save.

Creating a GAL File with the Array List Generator
The Array List Generator converts plain text files or ATF files containing 
substance names and IDs into GAL files. The Array List Generator is 
specifically designed to make GAL file creation simple. It checks and 
validates GAL files for you, and it previews the array of blocks defined by 
your GAL file. From the Array List Generator you can also open the Well 
Converter, with which you can convert four 96-well plate files into a 
384-well plate file.
When the Software is installed, several sample 384-well plate and 
96-well plate files are copied to your Program Files\Molecular 
Devices\GenePix Pro 7\Sample Settings directory so that you can learn 
how to use the Array List Generator and Well Converter. You might want 
to open one of the 384 Plate text files with a text editor such as Notepad 
to see the file format for yourself—it contains the row and column 
indices and names for each of the wells on a plate.
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To create a GAL file with the Array List Generator from the sample 
text files

1. Open the Array List Generator window from the Start menu by 
selecting Start > All Programs > Molecular Devices > GenePix 
Pro 7 > Tools > Array List Generator.

Figure 2-30: Array List generator window

2. Click Add.
3. If you have 96-well plate files, click Well Converter to open the 

Well Converter dialog box, where you can convert them into 
384-well plate files.

Tip: You can open the Array List Generator window from the 
Image tab by pressing Alt+G.

Note: GAL files can also be opened and edited in Microsoft 
Excel to make minor additions or other modifications.
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Aligning Blocks on an Image
The software uses three sets of alignment algorithms: one for finding the 
entire array of features, one for finding the location of complete blocks of 
feature indicators on an image, and one for aligning the feature 
indicators within the blocks with features on the image.
The Find Array function pre-positions the whole array of blocks over the 
array on the image. Each feature indicator partially overlaps its 
associated feature (for example, about half a feature indicator diameter 
overlap); the feature indicator diameter is slightly smaller than the 
average feature diameter.
The combination of these three procedures is highly robust and reliable, 
so we recommend using the global command Find Array, Find All Blocks, 
Align Features, or the hot key <F8>.
If your slide has features with a range of sizes, you can change the 
maximum and minimum diameters used by the spot-finding algorithm.

To change the diameters used by the spot-finding algorithm
1. Click Options > Alignment tab.
2. Enter the Min diameter and Max diameter as percentages of the 

starting diameter of each feature.

After an automatic alignment is completed, you might need to review 
block and feature positions and make some manual adjustments. To 
operate on blocks manually you need to be in Block mode (Hot Key B).

Creating non-circular Feature Indicators
The Software supports square and irregular feature indicators, as well as 
the default circular feature indicators.

Tip: You can disable diameter-resizing altogether during Auto 
Aligns by clearing the Resize features during alignment check 
box.

Note: For features that are almost circular, with only slight 
imperfections, we recommend that you use the Circular Features option 
rather than the Irregular Features function, as this algorithm will work 
better for these features.
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To create non-circular Feature Indicators
1. Click Options>Alignment tab.
2. Select Find Square Features or Find Irregular Features.
3. If you are using irregular features, you can choose to fill in any 

holes in features by selecting the Fill Irregular Features check 
box.

If you use irregular features, after analysis you can use the Circularity 
column in the Results tab as a quality control measure on your features. 
Circularity ranges from 0 (non-circular) to 100 (circular). Square features 
are always given a value of 79 (100 × /4).

Zooming in on Blocks
While you can use the Zoom Area tool for zooming, the software has 
several special zooming functions for use with blocks.

Figure 2-31: Zoom hot keys

To zoom in on blocks
1. Select a single block.
2. On your keyboard, press one of the following numbers to zoom 

in on a particular area:
 Press1 to zoom in on the top left quadrant of the selected 

block.
 Press 2 to zoom in on the top right corner.
 Press 3 to zoom in on the bottom left corner.
 Press 4 to zoom in on the bottom right corner.
 Press 5 to zoom in on and center the whole block.
 Press > and < to zoom in on the next or previous block.
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After you have zoomed in and can see the location of feature indicators 
and how well they align with features in the image, you can adjust the 
position of the block by dragging it with your mouse cursor, or using the 
arrow keys on the keyboard.

Moving and Resizing Blocks
Although the mouse is useful for quick and crude moving and resizing of 
blocks, for fine positioning it is often more efficient to use the keyboard 
controls.

To move or resize a block
1. Select a single block.
2. To move the block, use the arrow keys.
3. To resize the block, use Ctrl+arrow keys.

Rotating Blocks and Arrays
With a block selected, you can rotate it 0.1 degree at a time with the + 
and  keys, or open the Block Properties dialog box to set a specific 
degree of rotation. If you select multiple blocks and rotate one, the 
rotation is applied to the entire array of selected blocks.

Figure 2-32: Rotating blocks
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Manually Moving, Resizing, and Fine-tuning Feature 
Indicators
After aligning your blocks, you may want to fine-tune some of the feature 
positions manually. For example, you may need to align manually 
features that are flagged Not Found by Align Blocks. This is easily 
accomplished using Feature Mode.
After selecting Feature Mode click on one, or many, feature indicators 
that you would like to move or resize, and they are highlighted.
Feature mode has two sub-modes, rectangle and lasso, for making 
multiple selections. Once you are in Feature mode, click the Feature 
mode button again to display a choice of rectangle or lasso:

• In Rectangle mode, if you hold down the mouse and drag it, 
every feature in the bounding rectangle of the region is selected.

• In Lasso mode, hold down the mouse and draw an arbitrary 
closed region to select all the features in the region.

Feature selection also works when the blocks are defined but not 
displayed. You may find it easier to select irregular regions in lasso mode 
when the blocks are not displayed, as the image is more visible. Use the 
arrow keys to move or resize the features (these keys are also listed in the 
right mouse menu in Feature Mode).

To move or resize features
• Select a feature or features.
• To move the feature(s), use the arrow keys.
• To resize the feature(s), use Ctrl+arrow keys or Ctrl+mouse 

wheel.
If you re-size or move an irregular feature indicator, it is reset to circular. 
The diameters of feature indicators are reported in the Results 
spreadsheet; for non-circular features, the diameter reported is the 
diameter of the circle of best fit. Irregular features also have a measure 
of circularity reported in the Circularity column, where 100 is circular and 
0 is most non-circular. Feature Indicators should fit closely around 
features. Features that cut the boundary are not included.

Note: Feature Indicators cannot be moved or resized if the settings are 
Locked (see Linkage on page 73).
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Quick Zooms
In Feature mode there are several Quick Zoom Hot Keys:

• Alt+arrow keys: select previous or next feature
• [  or ]: move cursor to previous or next selected feature
• 0 (zero): zoom and center current selected feature

If images and Results are linked (see Linkage on page 73), then the 0 
Hot Key on the Results or Scatter Plot tab switches the display to the 
Image tab:

• If a feature is highlighted on the Results tab, pressing 0 zooms 
to it on the Image tab

• If a feature is under the mouse cursor on the Scatter Plot tab, 0 
zooms to it on the Image tab

Flagging Feature Indicators
The Software provides the ability to mark or flag individual feature 
indicators. For example, you might find that some features should be 
ignored during your final analysis because of imperfections on the array.

To flag a feature on the Image tab
1. On the Image tab, click Feature Mode, then click the small 

triangle in the upper right corner of the button to choose either 
the Rectangle or Lasso selection option.

2. On the image, click the feature you want to flag.
3. Click Feature.
4. Select a flag to apply to the feature: Good, Bad, Not Found, or a 

User Defined Flag you have created.

Table 2-2: Icon Descriptions

Icon Description

Block Mode

Feature
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The Software also flags features automatically:
• If Align Blocks fails to find a feature, the feature is flagged Not 

Found.
• If there are blank entries in the active GAL file, the corresponding 

features are flagged Absent.
All flags are stored in the final Results table and are exported with 
numerical equivalents: 

• Good is given the value 100.
• Bad is given the value –100.
• Not Found is –50.
• Absent is –75.
• Unflagged is 0.

See Defining Your Own Flagging Criteria on page 76 for advanced 
feature-flagging techniques.

Creating Custom Flags

Figure 2-33: Feature

You can also create custom User Defined flags to track traits of particular 
importance to your analyses.
For user defined flags, a Good valuation starts at 20 and increments by 
one for each flag (that is, 20, 21, 21, and so on); a Bad valuation starts at 
-20 and decrements by one for each flag (that is, -20, -21, -22, and so on).

Note: Feature Flags cannot be removed or added if settings are Locked 
(see Linkage on page 73).
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To create your own flags
1. On the Image tab, click Feature>Configure User Defined Flags.

Figure 2-34: Configure User Defined Fields Screen

2. Click New.

Figure 2-35: New User Defined Flag Screen

3. In the Name field, type a unique descriptive name for the flag.
4. In the Type group, select Good or Bad to typify the flag.
5. Click OK. 

The new flag appears in the Configure User Defined Flags list.
6. Click New to create another flag, or click OK to save your flags 

and exit the dialog box.
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Resetting Flags and Positions

To remove the flags or nudges from feature indicators
1. On the Image tab, click Feature mode.
2. Select the features to reset by clicking them or by dragging a 

region around them.
3. Click Feature, and then click the desired option:
 Clear Nudges
 Clear Flags
 Clear Flags Except Absent

Saving the Positions of Blocks and Feature Indicators
After you have finished aligning your analysis array, it is important to save 
its configuration.

To save the position of blocks and feature indicators
1. Click File > Save Settings As.
2. Enter a file name for the settings and click OK.

When you save the settings, you not only save the position of the array, 
but you also save any acquisition settings you may have made such as the 
size and position of the scan region, and any display settings such as 
contrast and brightness.

Table 2-3: Icon Descriptions

Icon Description

Feature Mode

Feature
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Locking Settings
After you have aligned the feature indicators and applied any quality 
flags, you may want to lock your settings to prevent you from 
accidentally changing them after the results have been calculated (see 
Linkage on page 73).

To lock settings manually

Figure 2-36: Lock Settings

• On the Image tab, click Lock Settings.
When settings are locked, you cannot move blocks or feature indicators, 
and several other commands (such as Align Blocks and Align Images) are 
disabled.
You can set the locking default to lock settings automatically after an 
Analyze command.

To lock settings automatically
1. Click Options.
2. Click the Workflow tab.
3. Select the Lock Settings After Analysis check box.

You can manually lock and unlock the settings any time by clicking the 
Lock Settings button. Any change you make to your feature settings 
breaks their linkage with downstream results. To re-establish linkage, 
analyze again.
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Customizing Background Subtraction
The Software offers the choice of several background subtraction 
methods. By default, the software uses a local background subtraction 
method (see Background Intensities on page 18). This is the 
recommended method, as it much more responsive to background 
intensity variations across a slide. However, the Software does offer 
global methods, in which a single background value is used for each 
channel, for the whole slide.

To change the background subtraction method
1. Click Options.
2. Click the Analysis tab.
3. In the Background Subtraction group, click Select.
4. Select a new background subtraction method.

Performing the Analysis and Viewing the Results

Figure 2-37: Analyze

After aligning the analysis array, perform the analysis by clicking the 
Analyze button (or by clicking Analyze All to process multiple scan areas 
at once). The analysis extracts data from the single-wavelength images in 
each feature indicator, and the results and subsequent computations are 
sent to the Results tab spreadsheet.
After the analysis a JPEG file of the image is saved and used in the 
Feature Viewer in the Results and Scatter Plot tabs. The image is saved 
with the brightness, contrast and color settings at the time of the 
analysis.

To save a JPEG to be used in the Feature Viewer with saved 
Results

1. Click File>Save Results—Active Scan Area or File > Save 
Results—Active Scan Area, as desired.

2. Select the Save as JPEG Image check box.
3. Click Save.
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Analysis Results for Multiple Scan Areas

The Software creates a separate set of results for each scan area in turn. 
When you create multiple scan areas, you can select and analyze each 
one separately, or click Analyze All to process them all at once.
To view the results for any of a series of multiple scan areas, use the Scan 
Area spin box tool to select the number of the scan area you want to see.

Using the Results Spreadsheet
In addition to the basic raw data and derived ratio measurements, the 
Results spreadsheet shows the location of each feature indicator, 
substance information from the GAL file (such as substance names and 
ID), and any flags that were on the image before the analysis.
To sort the data in the spreadsheet, click on a column title. Click the same 
column title again to sort the data in the reverse order. 

To group several discontinuous rows together
1. Select the rows by holding down the <Ctrl> key and clicking the 

rows.
2. Click Group Rows.

Table 2-4: Icon Descriptions

Icon Description

Analyze All

Scan Area Spinner
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To reorder columns
1. Click on a column title and drag it to a new position in the 

spreadsheet.
OR
In the Table group on the left-hand side of the Results tab, click 
Data Types. 

2. You can customize two different views of the spreadsheet. Select 
Custom 1 or Custom 2, then select the Data Types you want in 
that view.

3. Reorder columns by clicking the up and down arrows. For 
accelerated movement, hold down the button.

4. Show and hide columns by moving them between the Available 
Data Types and Visible Data Types fields with the horizontal 
arrows. Note that grayed-out column names have no data in the 
active Results table, and are not displayed in the Results 
spreadsheet until they do have data.

5. To display the default of all applicable columns, click Restore to 
Default.

To show and hide rows based on their flags
1. In the Table group on the left-hand side of the Results tab, click 

Display.
2. Select the flag types to display. For example, to show all features 

included in normalization, clear all the boxes in the Excluded 
column.

Note that settings in the Display dialog box do not change the underlying 
data set. A GPR file always contains the entire data set. 

To save results with a customized set of Data Types
• On the File menu, choose Export Results.
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Linkage
After an analysis, your images, settings, and Results are linked, shown by 
the message Linked in the Status Bar. Linkage is the state of having the 
current Results match the current image and settings; that is, if you 
re-analyze, you get exactly the same results. When linked, you can flag or 
select in any feature-viewing tab and the others are updated accordingly. 
Locking prevents your data from becoming unlinked.

To flag a feature on the Image, Results, and Scatter Plot tabs 
simultaneously

1. Check that Linked appears in the Status Bar.
2. Select features on the Image tab, Results tab or Scatter Plot tab. 
3. Select a flag command from the right mouse menu, or from the 

Feature menu.

To navigate from the Results tab to the same feature on the 
Image tab

1. Check that Linked appears in the Status Bar.
2. Click on the row of interest in the Results tab.
3. Press the 0 Hot Key.

Results and images that are saved when linked can be opened together 
by opening the Results file. The software automatically locates and opens 
the corresponding image files.

To open linked images and results
1. Click File>Open Results.
2. Select the Open Associated Images and Recreate Analysis 

Settings check boxes.
3. Click Open.

If images and settings are opened and linked successfully, the Status Bar 
message reads Linked.
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Web Interactivity
The software is closely integrated with the Web.

To find a substance ID or name on a web database
1. Open a GAL file or settings file containing substance names and 

IDs.
2. Click Options.
3. Click the Analysis tab.
4. Select the address of a Web database from the Web address list, 

or click Manage to enter a new Web address.
5. Click OK.
6. Select a feature in the Image tab, Results tab, or Scatter Plot tab.
7. Click the right mouse menu and click Go To Web to open the 

database in your default Web browser.

Normalization
The Software includes full normalization of images and data (see Data 
Normalization on page 27). If images and Results are linked, then both 
images and Results will be normalized; if they are not linked, only the 
Results will be normalized. When linked, the Status Bar reads Linked.
Before you normalize, you must decide to normalize on control features 
only, or on all features, or you can choose to apply your own 
normalization factors to the images.

To configure normalize on all features
This lets you normalize on all features except those flagged Bad, Absent, 
and Not Found.

1. Click Configure in the Normalization group on the left-hand side 
of the Results tab.

2. Click Ratio-based.
3. From the mean of the list box, select a ratio type. Typically, this is 

the main ratio value that you use for all your analyses.
4. Select all of the features from the second list box.
5. In the is equal to field, type a ratio value. For example, by 

normalizing on all features, you are assuming that the mean ratio 
of all features on the array is equal to 1, so you would enter 1 in 
this field.
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To normalize on selected features only
1. Flag features for normalization with an Include in Normalization 

flag. See Defining Your Own Flagging Criteria on page 76.
2. In the Normalization group on the left-hand side of the Results 

tab, click Configure.
3. Click Ratio-based.
4. In the mean of the drop-down list, select a ratio type. Typically, 

this is the main ratio value that you use for all your analyses.
5. In the of drop-down list, select the desired normalization 

features.
6. In the is equal to field, type a ratio value. The value here 

depends on the expected behavior of your control features. For 
example, if you expect your control features to have a ratio of 
0.8, enter 0.8.

To configure user-defined normalization factors
1. In the Normalization group on the left-hand side of the Results 

tab, click Configure.
2. Click User-defined.
3. Type your own normalization factor for each image.

To apply normalization to your results and images
• On the Configure tab, click Normalize.

OR
On the Configure tab, click OK to exit from the Configure tab 
(this accepts your normalization configuration but does not 
apply it) and then, in the Normalization group on the left-hand 
side of the Results tab, click Apply.

To remove normalization
• In the Normalization group on the left-hand side of the Results 

tab,click Remove.
If you normalize your results and then save, your normalized results are 
saved. If you intend to do further analyses on your results (for example, 
removing normalization and trying out different normalization methods), 
we recommend that you save your results unnormalized.
After normalization, the status bar reads (Un)Linked—Normalized.
0112-0178 D 75 



GenePix Pro Microarray Acquisition and Analysis Software User Guide
Defining Your Own Flagging Criteria
The Flag Features dialog box is an extremely powerful tool for flagging 
features by constructing general Boolean queries of Results tab data. You 
can type or insert VBScript expressions in the Query field and have them 
evaluated in the Results table. You can also save commonly used queries, 
such as custom quality control or normalization conditions that you apply 
to every array.
A query typically consists of several conditions joined with the logical 
connectives AND or OR. A row satisfies a query consisting of two 
conditions joined by an AND if it satisfies both conditions independently; 
it satisfies a query consisting of two conditions joined by an OR if it 
satisfies at least one condition.

To construct a single condition
Construct a condition, for example [Ratio of Medians (635/532)] > 1.5.

1. In the Normalization group on the left-hand side of the Results 
tab, click Flag Features.

2. To begin a new query, click New.
3. From the Column list, select Ratio of Medians (635/532).
4. From the Operator list, select >.
5. In the Value field, type 1.5.
6. Click Add to add the condition to the current query in the Query 

field.
7. Click Evaluate to find the number of rows to which the condition 

applies.
8. Click Save As to save the query.

To build this expression into a more complex query
You can then develop a more complex query, for example, to add the 
following condition: [Ratio of Medians (635/532)] < 0.66

1. Click Or.
2. From the Column list, select Ratio of Medians (635/532).
3. From the Operator list, select <.
4. In the Value field, type 0.66.
5. Click Add to add the condition to the current query in the Query 

field.
6. Click Evaluate to find the number of rows to which the condition 

applies.
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7. Click Save to save the query. The full expression now looks like:
[Ratio of Medians (635/532)] > 1.5 OR
[Ratio of Medians (635/532)] < 0.6

Features are flagged on exiting the dialog box by clicking the OK button. 
You can also choose to highlight the rows in the Results tab.

To flag features in the Results tab which satisfy the query
1. In the Action group, select the Flag check box.
2. Select the type of flag to apply.
3. Click OK.

To highlight rows in the Results tab which satisfy the query
1. In the Action group, select the Highlight Data check box.
2. Select whether to Replace the current highlighted rows, or to 

Add to the current highlighted rows.
3. Click OK.

Using Flag Features for Complex Quality Control 
Queries
You can use the Flag Features dialog box to construct complex quality 
control conditions on your features.
First, you need to decide on a set of quality control criteria. For example, 
you might choose to exclude (flag as Bad) any feature that satisfies the 
following criteria:

• The feature intensity is near background
• The feature is not uniform
• The background is not uniform

You need to be able to translate these conditions into symbolic 
expressions. The first condition can be expressed as:

[% > B635+2SD] < 70 OR [% > B532+2SD] < 70
This condition picks up features that do not have at least 70% of their 
feature pixels more than two standard deviations above background in 
either the green or the red channel. You may want to experiment with 
the figure of 70% to find a figure that is diagnostic for your arrays.
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The second condition is more complex. One way of measuring the 
non-uniformity of the feature is to compare any of the five ratio types 
reported by the software, for example, the ratio of medians and the 
regression ratio. It can be expressed as:

[Ratio of Medians (635/532)]  > (1.2*[Rgn Ratio (635/532)]) OR
[Ratio of Medians (635/532)] < (0.8*[Rgn Ratio (635/532)])

This condition picks up features that have a ratio of medians greater than 
1.2 or less than 0.8 times the regression ratio. Again, you may want to 
experiment with these values of 1.2 and 0.8.
Finally, to select features with a variable background, compare the mean 
and the median background levels:

([B635 Mean]  > (1.2*[B635 Median]) OR
([B532 Mean]  > (1.2*[B532 Median]) AND
([B635 Median] > 40 OR [B532 Median]) > 40)

This condition selects features that have a mean background greater 
than 1.2 times the median background at either wavelength. It also 
includes a lower bound on the absolute value of the background, as 
variation in a very low background level is not as significant as variation 
when the background is higher. The condition picks out features that 
have bright pixels or smears in their backgrounds, or features with 
irregular shapes that do not fit the circular feature indicators.
Because a feature that fails any of these criteria is deemed to have failed 
overall, join each of the conditions by an OR to construct a single query:

[% > B635+2SD] < 70 OR [% > B532+2SD] < 70 OR
[Ratio of Medians (635/532)]  > (1.2*[Rgn Ratio (635/532)]) OR
[Ratio of Medians (635/532)] < (0.8*[Rgn Ratio (635/532)]) OR
(([B635 Mean]  > (1.2*[B635 Median]) OR
[B532 Mean]  > (1.2*[B532 Median])) AND
([B635 Median] > 40 OR [B532 Median] > 40))

You can continue to add conditions to this query. For example, you may 
want to add checks for absolute feature intensity (that is, features are 
flagged Bad if the Sum of Medians is not above a certain intensity) or 
absolute background intensity (that is, features are flagged Bad if their 
backgrounds are above a certain intensity).
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Saving and Exporting Data
When the analysis is complete, save your results. You can save the data 
for just the selected or active scan area, or you can choose to save the 
data for all existing scan areas on the slide at one time.

To save in the default GPR file format
1. Click File>Save Results—Active Scan Area or File>Save 

Results—All Scan Areas, as desired.
2. Type a file name. 
3. From the group of Naming options, select the boxes to add 

prefixes and suffixes to the name.
4. Click OK.

To ensure consistency among data to be stored in a database, data saved 
in the GPR format always contain the full set of columns, regardless of 
the current column display, or the color mode.

To export only the current view of the Results
This exports only the columns in your customized view.

1. Click File>Export Results.
2. Type a file name. 
3. From the group of Naming options, select the boxes to add 

prefixes and suffixes to the name.
4. Click OK.

Note that exported results are saved as plain text files (*.txt) and cannot 
be opened in the GenePix Pro software.
To export only selected rows from the Results tab

1. Select the rows that you want to export. Select contiguous 
groups of rows by holding down the <Shift> key when selecting; 
select discontiguous rows by holding down the <Ctrl> key when 
selecting. To select all rows, use the <Ctrl+A> Hot Key.

2. Click Copy.
If the buttons for exporting the data are disabled, this is because you 
currently do not have a protection key attached to your computer.
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Viewing Scatter Plots
Use the Scatter Plot tab to generate scatter plots of any two analysis data 
types for all spots on the array, or to draw a histogram of any one analysis 
data type.

Figure 2-38: Scan Area Spinner

To view the scatter plots for any of a series of multiple scan areas, use the 
Scan Area spin box tool to select the number of the scan area you want 
to see.

To choose quantities plotted on each axis
1. Do an analysis or open a Results file.
2. Click the Scatter Plot tab.
3. From the X Axis group on the left-hand side of the Scatter Plot 

tab, choose a quantity to plot along the X Axis; for example, Sum 
of Medians.

4. From the Y Axis group on the left-hand side of the Scatter Plot 
tab, choose a quantity to plot along the Y Axis; for example, Log 
Ratio.

5. You can also specify the Scatter Plot axes directly from the 
Results tab by right-clicking on any column and choosing Set this 
data type as Scatter Plot X- (or Y-) axis.

6. Position the mouse over any point on the Scatter Plot to display 
the associated feature in the Feature Viewer.

The Scatter Plot and the Results spreadsheet are fully integrated—select 
several features on one tab and when you switch to the other tab they 
are highlighted. If images and Results are linked (see Linkage on page 73), 
then selecting or highlighting features on the Scatter Plot tab selects or 
highlights them on all tabs.
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Some useful ways to display data:
• F1 Median vs. F2 Median: the diagonal through the origin 

separates features with a higher activity than the reference from 
features with a lower activity than the reference. If the data 
cloud lies significantly off the 45-degree diagonal, it may indicate 
a significant difference in channel intensity that should be 
normalized. 

• Index vs. Log Ratio: the chosen ratio is displayed as greater or 
less than 1.0 for all spots. Differentially regulated features are 
more easily identified than on a standard intensity comparison 
plot.

• Sum of Medians (Log Axis) vs. Log Ratio: highlights low intensity 
spots with artificially high ratios. If the denominator of a ratio is 
very low, the resulting ratio value may be artificially high. You can 
use this plot to identify such false outliers.

To flag features on the Scatter Plot
1. Click and drag the cursor to select a group of data points.
2. From the right mouse menu, or from the Feature menu, select a 

Flag command.

To show or hide flagged features
1. In the Display group on the left-hand side of the Scatter Plot, 

click Display.
2. Check the types of flagged features to display.

To show or hide analysis lines (regression line, k-standard error 
lines)

• Select the Analysis Lines check box.

To configure analysis lines
1. In the Display group on the left-hand side of the Scatter Plot, 

click Configure.
2. Check which lines to display from: Regression Line; k-standard 

deviation lines.

To draw a histogram
1. In the Visualization list on the Scatter Plot tab, click Histogram.
2. Select a data type from the X Axis list.
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Report Tab and Scripting
The Report tab is an embedded Internet Explorer window, so it has all the 
scripting functionality of that program. Scripts can be written in VBScript, 
JavaScript, or any other scripting language supported by Internet 
Explorer (such as PerlScript or Python).
The Report tab includes ready-to-use Reports for scanner performance 
validation and analysis. It enables full scripting of all acquisition and 
analysis functions. To demonstrate some of the functionality and power 
of the Report tab, several example Reports are installed with the 
program. These are always available from the Report tab by clicking the 
Home button.

To run a report
1. Click the Report tab.
2. Click the Report that you want to run and follow its instructions.

The Analysis Reports are ready to use for advanced data analysis The 
Hardware Diagnostic Reports include tools for scanner performance 
validation. The Example Reports demonstrate how to use some 
properties and methods of the GenePix Pro Object Model. Any of these 
can be customized by clicking the Edit button on the left-hand side of the 
Report tab. 
The online help (press <F1>) includes an extensive scripting tutorial in 
which the GenePix Pro Object Model is documented.

Special Functions
This section describes other special features you might use regularly.

Using the Measuring Tools
When you want to measure pixel values in an arbitrary line or area on an 
image, use the Measuring Tools. With these tools, you can create your 
own data measurement regions, including line profiles, multiple line-
segment profiles, rectangular averaged lines, and rectangular, elliptical, 
and polygonal areas.

Figure 2-39: Measuring Tools
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To create a measuring region
1. On the Image tab, click Measuring Tools. 
2. A menu of options appears.
3. Select the tool you want from the menu.
4. Using your cursor as a drawing tool, create a measuring region 

on the image.
The use of each tool is fully explained in the Help system. You can create 
multiple measuring regions on one image, and move and resize them like 
blocks and features.
The information about the selected region is automatically displayed in 
the Measuring Tools Properties window, including a graph of pixel 
intensity data for each wavelength.

To hide or show the Measuring Tools Properties window

Figure 2-40: View Measuring Tools

• On the Image tab, click View Measuring Tools. 
The Measuring Tools dialog box appears:
0112-0178 D 83 



GenePix Pro Microarray Acquisition and Analysis Software User Guide
Viewing Pixel Plots
Use the Pixel Plot to evaluate individual features in more detail.

To view a Pixel Plot
1. On the Image tab, open an image and place blocks on the image.
2. Position your cursor over a feature indicator.
3. Press the <P> Hot Key or, in Feature mode, right-click and select 

Pixel Plot. 
The Pixel Plot graphs the distribution of the pixels within the 
selected feature indicator.

Figure 2-41: Pixel Plot
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To see the distribution of feature pixels and background pixels for 
the feature

• In the Items to Plot group, select the Feature Pixels and 
Background Pixels check boxes, and clear the Regression Pixels 
check box.
The pixels are plotted as points on the graph, with background 
pixels black and feature pixels yellow.

To see the difference between the Ratio of Medians and the 
Regression ratio for the feature

• In the Items to Plot group, select the Ratio of Medians and 
Regression Ratio check boxes, and clear the Median of Ratios 
check box.
The ratios are plotted as lines through the points, with the Ratio 
of Medians red and the Regression Ratio blue.
The Pixel Plot also shows derived ratio measurements, so you 
can see the relationship between ratio and pixel values.

Viewing Histograms
The Histogram displays the distribution of pixels for each raw wavelength 
image. The display color-codes each distribution according to the ratio 
colors used to create the ratio image; that is, if the first channel is 
displayed in red on the Image tab, its trace on the Histogram is drawn in 
red.
The Histogram is derived from the current view of the image in the Image 
tab, so if you have zoomed in on part of an image, only those pixels 
currently displayed are used to construct the Histogram.

1. To see the Histogram for an entire image
2. Click the Image tab.
3. If you are zoomed in to a part of the image, click Zoom Full Scale 

to see the whole image.
4. Click Zoom Mode.
5. Draw a zoom area tightly around the features on the image to 

exclude as much background as possible.
6. Click the Histogram tab.
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To use the Histogram to see how many pixels are saturating
1. In the X Axis group on the left-hand side of the Histogram tab, 

click Full Scale.
2. Zoom in on the far right edge of the histogram, by holding down 

the mouse cursor and dragging it along the X axis between 
60000 and 65000. The proportion of saturated pixels is plotted at 
65535.

Performing a Batch Scan

If you are connected to a GenePix SL50 Slide Loader, or if you are using 
Analysis Only mode with a GenePix SL50 Slide Loader, the Batch Scan tab 
is visible. Use the Batch Scan tab to perform a batch scan or a manual 
scan. 
In Batch Scan mode, the scanner scans all selected slides in the slide 
loader, without any user intervention.
On the Batch Scan tab, you can customize various settings.

• For each slide in the slide carrier, you can specify hardware 
(scanner) settings and analysis settings.

• For the entire batch scan, you can specify file naming and saving 
options, as well as workflow options.

While scanning, the positions in the GenePix Pro slide carrier map 
change color, depending on their scan status:

• Light-blue outline: Scan is in progress.
• Green: Scan was completed successfully.
• Red: Slide was not scanned because of a slide handling failure or 

scan cancellation.
In Manual scan mode, the GenePix SL50 Slide Loader operates very much 
like a manual GenePix scanner. You can open and close the motorized 
scanner door, perform Preview Scans, Data Scans, adjust scanner settings 
from the Hardware Settings dialog box, and stop and start scans. 

Note: This procedure applies only if you are using a GenePix scanner 
with a GenePix SL50 Slide Loader.
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Any Global file options (Save locations, File name) set during a batch scan 
apply when performing a manual scan.
Follow the instructions carefully when inserting a slide in the scanner 
slide holder. The slide holder is a precision component designed to 
ensure proper focusing and field uniformity. Improper handling may 
damage the slide holder and affect imaging performance. In Manual scan 
mode, the GenePix SL50 Slide Loader is inactive and will not move.

To insert a slide in the scanner
1. In the GenePix Pro Software, click the Open-Close Scanner Door 

icon to raise the scanner door.
The scanner slide holder moves forward into the load position.

2. With the slide held between your thumb and finger, carefully 
place the slide, feature-side down, into the slide holder. 

CAUTION! Never touch the slide holder while it is moving. 
Never force the slide holder closed, or apply significant pressure 
to it.

Note: Make sure the barcode on the slide is facing the front of 
the slide scanner.
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.

3. Click the Open-Close Scanner Door icon to close the scanner 
door.
The door closes and the slide holder moves into the scan 
position.

Figure 2-42: Scanner slide holder

Item Name Description

1 Scanner door In raised position

2 Slide holder In load position

3 Slide Place feature-side down

4 Barcode Barcode is facing the front of the slide 
scanner

2

3

1

4
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To perform a manual scan
1. On the Batch Scan tab, in the Scan Type group, click Select.
2. The Scan Type dialog box appears.
3. Select Manual and click OK.
4. Insert a slide in the scanner. See To insert a slide in the scanner 

on page 87.
5. Click the Hardware Settings icon on the right-hand side of the 

GenePix Pro window.
6. In the Hardware Settings dialog box, set the filter and PMT 

parameters. 
7. Click the Preview Scan icon to scan the slide and display general 

data for the slide.
8. If you want to scan a smaller region, use the Scan Region tool to 

select a region, then click the Data Scan icon.
9. When you are finished scanning, click the Open-Close Scanner 

Door icon.
10. Remove the slide from the slide holder.

To load the slide cassette
1. Use the handle on the right side of the slide loader tower to slide 

open the slide enclosure door.

Figure 2-43: Slide enclosure door handle
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2. Using the handle on top of the slide cassette, lift the left slide 
cassette out and place it on a stable position on the counter.

Figure 2-44: Slide enclosure door open with both slide cassettes 
visible

3. With each slide held between your thumb and finger, carefully 
place slides, feature-side down and barcode facing the front, into 
empty slots in the slide cassette.

4. When you have placed all slides for scanning into the slide 
cassette, return the cassette to the slide enclosure by inserting it 
at a slight angle tilted away from you, then straighten it until it 
fits securely in the slide enclosure. 
You will hear a click when the cassette is in place.

5. If additional slots are required, perform Step 2 through Step 4 
with the right slide cassette.

Note: The motion arm uses a sensor to locate and map slides in 
the cassette slots before beginning the batch scan.
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6. When all slides are loaded into the slide racks and the racks are 
returned to the slide enclosure, use the handle on the slide 
loader tower to slide both racks back into the slide enclosure. 
Both slide racks must be in the slide enclosure for the GenePix 
Pro software to recognize that the slide enclosure is completely 
shut.
You will hear a click when the slide enclosure is completely shut. 
In Batch Scan mode, the slide cassettes are detected and their 
availability is displayed in the Slide Map dialog.

To perform a batch scan
1. On the Batch Scan tab, in the Scan Type group, make sure that 

Batch is the selected scan type. 
If Manual is the selected scan type, click Select, select Batch, 
remove any slides on the scanner’s slide holder, and click OK.

Before scanning, the slide positions are indicated in different 
colors, depending on their scan status and the current GenePix 
SL50 Slide Loader settings:
 Light blue: A slide is present and will be scanned.
 Grey: A slide is present but has not been selected to be 

scanned.
 White: No slide is present.
By default, all slides present in a batch are scanned.

2. Click the Hardware Settings icon on the right-hand side of the 
GenePix Pro window.

3. In the Hardware Settings dialog box, select the laser and filter 
settings for all slides. To override these hardware settings for 
individual slides, ensure that you select specific hardware 
settings for selected sub-batches of slides in Step 8.

CAUTION! Do not access the slides in the cassette through the 
belt opening.

Note: For optimum performance, allow the GenePix 
4300A/4400A Scanner to warm up for 15 minutes before 
scanning slides with the GenePix Pro Software.
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4. In the global file options group, click Save Locations [...] to open 
the Options > Folders dialog box and set the directories in which 
to save various file types.

5. In the global file options group, click File name [...] to open the 
Options > File Save dialog box and set the naming conventions 
for files saved during batch scans.

6. If you want to save all settings on the Batch Scan tab to re-use in 
another scan or if you want to open a previously saved settings 
file, use the Loader Settings group and select one of the 
following options:
 Click New to save the batch scan configuration in a loader 

settings file (*.gpa).
 Click Open to open a previously saved loader settings file 

(*.gpa).
7. Slide enclosure door open with both slide cassettes visible. If you 

want to scan a slide multiple times (for example, at different 
PMT settings or using different scan regions), do the following:
 Select the slide in the Batch Scan list.
 Use the arrows in the Scan # times field to set the number of 

times to scan the slide.
Based on the number of times selected, the scan is copied in the 
Batch Scan list (for example 1a, 1b) and each instance of a scan 
gets its own entry. You can assign scan settings to each entry 
independently.

8. If you want to select a sub-batch of slides for scanning, use 
Ctrl-click and Shift-click to select multiple slides in the Batch Scan 
table, and then select the following settings for the sub-batch 
scan in the For the selected sub-batch of slides group.
 Click the Scans drop-down list to select the type of scan to 

perform on the selected sub-batch of slides.
 Type a File name body to save the selected sub-batch of 

slides with a specific file name.
 Choose the Hardware Settings for the selected sub-batch of 

slides either by clicking Current settings or by clicking GPS 
file and using the [...] button to navigate to a specific 
GenePix Settings (GPS) file.

 For each slide in the selected sub-batch, choose the Auto 
PMT gain either by clicking Selected hardware settings to 
use the current hardware settings or by clicking GAL file and 
using the [...] button to override the specified settings and 
navigate to a specific GenePix Array List (GAL) settings file.
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9. If you have multiple sub-batches, repeat Step 8 for any other 
sub-batches selected.
To copy and paste slide settings from one slide to another, select 
a row and use the Copy Row and Paste Row buttons at the 
bottom of the Batch Scan tab. 

10. In the After batch scan group, select what you want to happen 
when the batch scan is complete:
 If you want to browse the scanned images without analyzing 

them, use the Browse tool on the Batch Analysis tab.
 If you want to run a batch analysis after the batch scan is 

complete, check Add image files and analysis settings files 
to Batch Analysis tab and type a name for the file, and then 
click Run batch analysis.

11. If you want to save the current configuration of the Batch Scan 
tab settings with a new file name, click Save loader settings [...] 
and enter a new file name.

12. Click Scan Batch to perform a batch scan using the settings 
configured on the Batch Scan tab.

When the batch scan is complete, a message appears in the 
GenePix Pro Software. 

Stopping and Restarting a Batch Scan
You can stop a batch scan at any time during the scan. You can then 
choose to continue the scan or to cancel it. 

To stop the current scan
• In the GenePix Pro Software, click the Stop Scan icon.

The SL50 Slide Loader completes its current task and then stops 
the scan. 

Note: Do not disturb the scanner or slide loader during the 
batch scan. Depending on the resolution and the number of 
wavelengths or channels you select for scanning, a single scan 
can take from 4 to 35 minutes to complete.
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To restart a batch scan
• In the GenePix Pro Software, after the current scan has been 

stopped, choose one of the following options:
 To continue scanning the batch from the current position in 

the slide carrier, click Continue. 
 To cancel the batch or to restart a batch from a position that 

has already been scanned, click Stop.

Reviewing the Batch Scan Log File
The GenePix Pro Software saves a text log file for each scanned batch of 
slides. If a batch scan completes successfully, there is no need to see the 
log file. If there is a problem with the scan, the log file can contain 
diagnostic information.
The default location of the log file is in the ...\Documents\Molecular 
Devices\GenePix Pro\Data\ folder. You can change the location of the log 
file.

To open the batch scan log file
• In the GenePix Pro Software, select File > Open Batch Scan Log.

To select a location for the batch scan log file
1. On the Batch Analysis tab, select Use folder options.
2. In the Options dialog box, click the Folders tab.
3. On the Folders tab, click Specified folder for individual file 

types.
4. In the Slide Loader Log field, click Browse to navigate to a 

location to store the batch scan log file.
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Running a Batch Analysis
Use the Batch Analysis tab to do spot finding and analysis on batches of 
images.

1.  Select images and GAL/GPS files to process
The first step in setting up a Batch Analysis is to select the images to 
process.

Add files to the list
Click Add to select images and a GAL or GPS file for the batch. You can 
use a single GAL/GPS file for the whole batch, or different files:

• To use a single GAL/GPS file, select a batch of images and only 
one GAL/GPS file in the Add dialog.

• To use different GAL/GPS files for different images, select the 
images with the Add command, and then select each image in 
turn from the Batch Analysis list, and use Select GAL or Select 
GPS to apply a GAL/GPS to that file only.

When a GAL/GPS file is selected, it is listed in the Initial GAL Or GPS 
column.

File names of generated files
When images are added to the Batch Analysis list, the GPS and GPR file 
names of the files that will be generated from the Batch Analysis are 
listed in the Aligned Settings (GPS) and Results (GPR) columns.
Batch Analysis never overwrites existing GPS or GPR files; generated file 
names are always unique in the directory in which they are saved.

Generated files location
GPS and GPR files generated by Batch Analysis are by default saved in the 
same directory as the images.
However, you can also specify a different directory. To do this, select Use 
folder options and then configure the directory using Options > Folders.

Single-image TIFF files
If you have pairs of single-image TIFF files, then you need specify how 
they are to be paired, typically by a file name suffix. The software 
recognizes a number of common file name suffixes (for example, "_635" 
and "_532") or you can add your own in Options> Batch Analysis.
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Align and Analyze
You can align features in a batch in one of two different ways, depending 
on how you want to review the results:

• Click Process Next to align one image at a time, and then review 
the results at the end of each image alignment.

• Click Align All to align all images, and then review all images.
When the alignment is finished, whether it is one array or a whole batch, 
use the Batch Review dialog box to review the results:

• If you are aligning one image at a time, you can inspect the 
generated settings on the Image tab, edit them as required, save 
settings, and then click Align Next.

• If you have aligned a whole batch, you can step through each 
image in the batch by clicking Open Next.

Find Array (Recommended)
From the Batch Analysis tab, alignment is always Find Array, Find All 
Blocks, Align Features <F8>. 
The only known case in which <F8> may possibly fail is when an image 
has a bright barcode in which the dimmest part of the barcode (generally 
the bars) is brighter than the brightest part of the image. In such a case, 
the Find Array algorithm may find the barcode instead of the features on 
the image. In such a case you should skip the Find Array part of the 
algorithm. For the rest of the spot finding to proceed successfully, the 
starting position of the blocks should overlap the blocks on the image.

Analyze
Select the Analyze option to analyze images and generate GPR files after 
the spot finding has finished.

Run this flag features query
After each GPR file is generated you can run a saved Flag Features query, 
to perform some primary quality control flagging on the generated GPR 
file.
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Workflow Automation Options
The software includes several options designed to automate routine 
tasks, such as the Preview Scan then Data Scan feature. If you are content 
to scan a whole slide, or if you are confident about the placing of your 
scan area, you can press this button and perform the two scans 
consecutively.
Workflow options are useful on their own, but become particularly 
powerful when used together with scripting in the Report tab.

To set workflow options
1. Click Options.
2. Click the Workflow tab.
3. In the Automatically group, select any of the options that you 

want to use to automate acquisition or analysis.

To give each user a unique user name for logging in
1. Click Options.
2. Click the Workflow tab.
3. Select the User Identification check box.

All settings are saved on a per-user basis.

Find
Use the Find command to find substance names and/or IDs anywhere in 
the software.

Figure 2-45: Find

To search for substance names or IDs in the Image tab
1. On the Image tab, click Find.
2. Select the Feature Names and Feature IDs check boxes.
3. In the Containing Text field, type the Name or ID to search for.
4. Select the check boxes next to any other options that you might 

require, such as Exact match or Case sensitive.
5. Click OK.
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In the Image tab, Find highlights features that have the name or ID 
specified and snaps the cursor to the feature. 
In the Lab Book tab you can search for any keyword whatsoever. 
In the Results and Scatter Plot tabs, Find highlights features that match 
the search criteria.

Lab Book
The Lab Book logs all file events that occur while the software is running. 
For example, the Lab Book automatically records whenever an image file, 
a settings file, or an array list file is opened or saved. It is also a simple 
database. Double-clicking on an entry such as a settings or an image file 
opens it in the software.
Logged information from all image acquisition and analysis sessions can 
go to the same file, or alternatively, each session or experiment can have 
its own Lab Book. This allows you to keep track of your files during the 
course of a series of experiments.
Like the Results spreadsheet, the columns in the Lab Book can be 
re-ordered by dragging and dropping their heading tabs. The Lab Book is 
saved as a binary file with a *.gpl extension, and its contents can be 
copied to the Windows clipboard. The Lab Book is automatically saved 
each time a new entry is made.

Calibrate System
The software system calibration procedure resets your scanner’s 
response to benchmark performance levels established at the factory. 
This corrects for variations inherent to all lasers and PMTs over the 
lifetime of the components. The software logs scanner performance in 
the Hardware Diagnostics Report every two hours during operation.
The calibration procedure produces calibration constants that are used 
to adjust the voltage across each PMT. For a calibration constant of 1.0, 
the range of the gain is 100 to 1000. Because calibration constants differ 
among scanners, the range of PMT Gain in the Hardware Settings dialog 
box may differ slightly among scanners (as this is an absolute scale). The 
range may also change over a scanner’s lifetime as the calibration 
constant changes.
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To calibrate your scanner

Figure 2-46: Hardware Diagnostics

1. Click Hardware Diagnostics.
2. Click Calibrate System.
3. Select all the laser check boxes to calibrate all wavelengths.
4. Click Start, and the wizard guides you through the rest of the 

procedure.
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3
Software and Protection Key Installation
This section covers basic installation and hardware issues.
Topics in this section include:

• Installing the Software on page 101
• Computer Requirements on page 101
• Connecting the Protection Key on page 103
• Single-User License Protection Keys on page 103
• Multi-User Network Protection Keys on page 103
• HASP Admin Control Center on page 104
• Troubleshooting the Installation on page 105

Installing the Software
If you purchased a GenePix® scanner, you may have already installed the 
software. However, if you purchased the GenePix Pro Software as a 
standalone product, use the following installation instructions.

Computer Requirements
While the system is fully functional with the minimum computer 
requirements, satisfactory performance depends on the size of the files 
you will generate. The RAM and hard disk configuration is the most 
critical. If you plan to scan areas smaller than a full slide, or to scan 
regularly at 5 μm resolution, the minimum requirements will provide 
satisfactory performance. However, if you plan to scan full slides at 
2.5 μm, or if you plan to run other applications simultaneously, we 
strongly suggest the recommended configuration. Computer 
workstations purchased from Molecular Devices meet or exceed the 
recommended configuration.

Supported Operating Systems
• Windows 7, 32-bit and 64-bit
• Windows 10, 32-bit and 64-bit
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Computer: recommended
• Intel Quad Core 1.8 GHz or faster processor
• 8 GB RAM or more
• Dedicated video card 256MB or more
• 250 GB hard drive (for image storage)
• 3 free USB 2.0 ports (one for the USB software protection key, 

and one for the scanner; if a SL50 slide loader is used, you need 
one more free USB port for the slide loader.)

• 1280 x 1024 display

Computer: minimum
• 1.2 GHz or faster processor
• 4 GB RAM or more
• 250 GB hard drive (for image storage)
• 3 free USB 2.0 ports (one for the USB software protection key, 

and one for the scanner; if a SL50 slide loader is used, you need 
one more free USB port for the slide loader.)

• 1280 x 1024 display

Running the Installation File

To install the Software
1. Double-click the GenePixPro_7_3.exe file to start the 

installation.
2. Click Next.
3. Select I accept the terms of the license agreement, then click 

Next.
4. In the Destination Folder dialog, the Install GenePix Pro 7 to 

field displays the default installation directory. To change the 
installation directory, click Change, navigate to the desired 
directory, then click OK.

5. Click Next.
6. In the Select Program Folder dialog, leave the displayed default 

Program Folder settings. Select Anyone who uses this computer, 
then click Next.

7. In the Simulation Images Setup dialog, click OK.
8. In the Software License Setup dialog, click OK.
9. In the Sentinel Runtime Setup dialog, click Next.
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10. Select I accept the terms of the license agreement, then click 
Next.

11. Click Finish to close the installer.

Connecting the Protection Key
The Software requires a protection key (sometimes called a dongle) to 
operate fully. Without the key, you can open images, but you cannot save 
settings files or analysis results, and you can analyze no more than 1000 
features.
The protection key is a USB device that provides security authorization 
for a single user or for multiple sites across a network (avoiding the 
inconvenience of installing individual devices for each computer on your 
network). The protection keys can also be used across a network for 
remote access. Whether you have a single or multi-user license, your key 
is programmed with the number of licenses purchased.

Single-User License Protection Keys
For single-user licenses, you are provided with a single physical 
protection key device. To install the single-user license key, just connect it 
to a USB port on your computer.

Multi-User Network Protection Keys
If you have a multi-user license, you are provided with a network USB 
protection key and a HASP Admin Control Center software package. To 
take advantage of multiple-site licenses, the USB protection key should 
be used on a local area network.
You must choose a single computer on your network to act as your 
GenePix Pro system server: you will install the physical network key, the 
HASP Admin Control Center software, and the related device drivers on 
this computer.
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Installing the Protection Key on a Network
If you have purchased a multi-site license for your software, you will be 
provided with a USB protection key that you need to install to access the 
full functionality of the software. The USB protection key can be attached 
to any computer on the network that has a free USB port, with the 
following conditions:

• The chosen machine must support USB.
• The chosen computer should be one that is always switched on 

and rarely rebooted, such as a mail, print, or other software 
server.

The GenePix Pro 7 Software protection key may be used in conjunction 
with other HASP USB protection keys; in particular, if you use two or 
more Molecular Devices software products on your network, each with 
its own multi-site license and USB protection key, you can install all the 
network keys on the same computer, as long as they are all HASP Version 
3.0 or greater. To install the network key, attach it to a free USB port on 
the chosen computer.
To see your HASP version, connect the key to your computer and open 
the HASP Admin Control Center. In the HASP Keys Options section, the 
connected keys will be listed, together with their properties and version 
number.

HASP Admin Control Center
To provide centralized control and reporting of license and user 
information within your network, the GenePix Pro 7 software package 
automatically installs the HASP Admin Control Center and HASP 
protection key drivers. The HASP Admin Control Center runs on your 
Internet browser. It serves two purposes:

• For license servers, to manage licenses of any attached USB 
Protection keys.

• For client computers, to view available USB Protection keys and 
licenses on the network.

Note: If you have a previous version of the GenePix Pro Software, you 
may be using HASP 2.x version keys. These require the HASP License 
Manager for network configuration. You can install and run this utility 
on the same computer as your HASP Admin Control Center. See your 
original GenePix Pro user guide for installation instructions.
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Software and Protection Key Installation
For more information about the HASP Admin Control Center, go to 
http://localhost:1947/_int_/ACC_help_index.html after you install your 
GenePix Pro 7 Software.
After you install the GenePix Pro 7 Software and attach the protection 
key to your computer, you can view key properties and manage licenses 
in the HASP Admin Control Center.

Figure 3-1: HASP Admin Control Center

You can access the HASP Admin Control Center from any computer on 
your network where the GenePix Pro 7 Software has been installed. Type 
http://localhost:1947/ in the address bar of your Internet browser. You 
can see all the GenePix Pro 7 Software protection keys installed on your 
local network.
If your multi-site license software came with a bundled computer 
package, that computer already has the GenePix Pro 7 Software and the 
HASP Admin Control Center installed. To use a different computer as the 
license server, install the GenePix Pro 7 Software on that computer to get 
the HASP Admin Control Center. To install the HASP Admin Control 
Center alone, download the HASP SRM Runtime Setup files from 
http://www.Aladdin.com/support/hasp-srm/enduser.aspx.

Troubleshooting the Installation
If you are having problems running the Software, consider the following:

• The Software requires a minimum of 4 GB of RAM to acquire 
images. It is capable of analyzing data when less than 4 GB of 
RAM is present, but the maximum image size is reduced and 
performance will not be optimal.

• The Software requires a protection key to save results and 
settings files, and to analyze images. Without the key, the 
software operates with limited analysis and file-saving 
functionality.
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Glossary
Array List:
An array list is a file (*.gal) that contains block and substance information 
for the array, which is supplied by the slide manufacturer. Create array 
lists from plain text files with the Array List Generator. The Load Array List 
command creates an array of blocks with dimensions based on the Array 
List, and with each feature indicator named according to the substance 
names in the Array List. These names are then used in the various Feature 
Viewers, the Pixel Plot dialog box and the Results tab.

Block:
A collection of feature indicators drawn on an image. The collection of all 
blocks on a slide is called an array, and a subset of identical groups of 
blocks is called a subarray.

Boolean Query:
A Boolean Query is a statement in the Flag Features dialog box expressed 
in Boolean logic, that is, atomic sentences connected by the operators 
AND, OR and NOT.

Feature:
A feature is a spot on an array. The collection of such features is called an 
array. The software assigns feature indicators to features in order to 
analyze each feature separately.

Feature Indicator:
A feature indicator is a circular region defined on an image within which 
the software calculates the pixel intensity and feature intensity of a 
feature on the array. A portion of the image outside the feature indicator 
is used to calculate the feature background intensity.

Feature Background Intensity:
The background intensity is the median intensity of the set of background 
pixels defined for a feature at a certain wavelength. Background pixels 
include all pixels within a circular region of three times the diameter of 
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the current feature indicator surrounding the feature of interest. All 
pixels contained within the feature indicator and neighboring feature 
indicators are excluded. Using the median, rather than the mean, of 
background pixel intensities reduces the effect of extraneous pixels 
contributing to the background.

Feature Intensity:
The feature intensity is the median or mean of all of the pixel intensities 
in a given feature indicator.

Feature Pixel:
A feature pixel is a pixel that falls within (in a technically well-defined 
sense) a feature indicator. Pixel intensities of feature pixels at different 
wavelengths are used to calculate various derived quantities, such as 
feature intensities.

Flag:
Flags are added to a feature indicator to highlight some feature. In 
Feature mode, you can flag features as Good or Bad. Features flagged 
Good are marked with a circle; features flagged Bad are marked with a 
cross. Features used to calculate the normalization factor are marked 
with a square. Flags are exported to the Results window. When exporting 
numerical data to spreadsheet programs, flags appear as ‘100’ (good), 
‘–100’ (bad), ‘0’ (not included in normalization), or ‘1’ (included in 
normalization). If a feature cannot be found during an Auto Align Blocks, 
it is flagged Not Found (numerically reported as –50). If an array list is 
missing a description of a particular feature, the feature is flagged Absent 
(numerically reported as –75).
You can also create and configure your own custom User Defined flags to 
track traits of particular importance to your analyses. For user defined 
flags, a Good valuation starts at 20 and increments by one for each flag 
(that is, 20, 21, 21, and so on); a Bad valuation starts at -20 and 
decrements by one for each flag (that is, -20, -21, -22, and so on).

Nudge:
To move one or more feature indicators within a block. In Feature mode, 
select the desired feature indicators and move with the arrow keys.
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Glossary
Pixel Intensity:
The raw intensity of a pixel on a single-wavelength or ratio image, falling 
in a range from 0 to 65535. Pixel intensity (P) is reported in the Feature 
Viewer, and is one of the quantities exported to the Results window 
during an analysis.

Photomultiplier tube (PMT):
An optical device that detects photons and ultimately generates an 
electrical current that is proportional to the number of detected photons. 
The PMTs in the scanner are used to detect the photons emitted from the 
laser-excited fluorophores on the array.

Ratio Image:
Any ratio image in the software is an RGB (Red-Green-Blue) overlay 
image. Ratio images exported as JPEG or TIFF files are 24-bit RGB color.

Saturation:
Saturation refers to the overloading of the photodetection circuitry. 
Saturation can be reduced by reducing the amount of light that is 
reaching the PMTs, which is done by reducing the amount of incident 
laser light. In practice, this is accomplished by reducing the gain of the 
PMT. Saturating pixels in the software are shown as white pixels in the 
raw wavelength images.
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